zeroc-ice version 3.4.2-4ubuntu1 failed to build with openjdk-7

Bug #889005 reported by James Page on 2011-11-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
zeroc-ice (Debian)
Fix Released
Unknown
zeroc-ice (Ubuntu)
Undecided
Unassigned

Bug Description

During a rebuild test on precise with default-jdk switched to openjdk-7, a build failure was detected for zeroc-ice version 3.4.2-4ubuntu1.

See attached log for full build failure details.

This log snippet might also be of interest:

tasks:
Created dir: /«PKGBUILDDIR»/java/lib/ant
Compiling 5 source files to /«PKGBUILDDIR»/java/lib/ant
/«PKGBUILDDIR»/java/src/ant/SliceTask.java:533: warning: [deprecation] getProcEnvironment() in Execute has been deprecated
        java.util.Vector env = Execute.getProcEnvironment();
                                      ^
1 warning
Building jar: /«PKGBUILDDIR»/java/lib/ant-ice.jar

task-init:

generate:
Created dir: /«PKGBUILDDIR»/java/generated
/«PKGBUILDDIR»/java/../cpp/bin/slice2java --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --stream --ice /«PKGBUILDDIR»/slice/Ice/BuiltinSequences.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2java --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --ice /«PKGBUILDDIR»/slice/Ice/Process.ice /«PKGBUILDDIR»/slice/Ice/FacetMap.ice /«PKGBUILDDIR»/slice/Freeze/Evictor.ice /«PKGBUILDDIR»/slice/Ice/Router.ice /«PKGBUILDDIR»/slice/Ice/Stats.ice /«PKGBUILDDIR»/slice/Ice/ImplicitContext.ice /«PKGBUILDDIR»/slice/Ice/Properties.ice /«PKGBUILDDIR»/slice/Ice/EndpointTypes.ice /«PKGBUILDDIR»/slice/Ice/Communicator.ice /«PKGBUILDDIR»/slice/Ice/LocalException.ice /«PKGBUILDDIR»/slice/Freeze/CatalogData.ice /«PKGBUILDDIR»/slice/Ice/Connection.ice /«PKGBUILDDIR»/slice/Freeze/Connection.ice /«PKGBUILDDIR»/slice/Ice/Endpoint.ice /«PKGBUILDDIR»/java/src/Freeze/PingObject.ice /«PKGBUILDDIR»/slice/Ice/Locator.ice /«PKGBUILDDIR»/slice/Freeze/Exception.ice /«PKGBUILDDIR»/slice/Ice/SliceChecksumDict.ice /«PKGBUILDDIR»/slice/Freeze/DB.ice /«PKGBUILDDIR»/slice/Ice/Identity.ice /«PKGBUILDDIR»/slice/Freeze/TransactionalEvictor.ice /«PKGBUILDDIR»/slice/Ice/ObjectAdapter.ice /«PKGBUILDDIR»/slice/Freeze/BackgroundSaveEvictor.ice /«PKGBUILDDIR»/slice/Ice/Logger.ice /«PKGBUILDDIR»/slice/Ice/Plugin.ice /«PKGBUILDDIR»/slice/Freeze/Transaction.ice /«PKGBUILDDIR»/slice/Freeze/EvictorStorage.ice /«PKGBUILDDIR»/slice/Ice/ServantLocator.ice /«PKGBUILDDIR»/slice/Ice/ObjectFactory.ice /«PKGBUILDDIR»/slice/Ice/Current.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2freezej --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --dict Freeze.Catalog,string,Freeze::CatalogData /«PKGBUILDDIR»/slice/Freeze/CatalogData.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2freezej --ice --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --dict Freeze.CatalogIndexList,string,Ice::StringSeq /«PKGBUILDDIR»/slice/Ice/BuiltinSequences.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2java --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --ice /«PKGBUILDDIR»/slice/IceSSL/ConnectionInfo.ice /«PKGBUILDDIR»/slice/IceSSL/EndpointInfo.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2java --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --checksum Glacier2.SliceChecksums --ice /«PKGBUILDDIR»/slice/Glacier2/Router.ice /«PKGBUILDDIR»/slice/Glacier2/SSLInfo.ice /«PKGBUILDDIR»/slice/Glacier2/PermissionsVerifier.ice /«PKGBUILDDIR»/slice/Glacier2/Session.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2java --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --checksum IceBox.SliceChecksums --ice /«PKGBUILDDIR»/slice/IceBox/IceBox.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2java --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --checksum IceGrid.SliceChecksums --ice /«PKGBUILDDIR»/slice/IceGrid/UserAccountMapper.ice /«PKGBUILDDIR»/slice/IceGrid/FileParser.ice /«PKGBUILDDIR»/slice/IceGrid/Observer.ice /«PKGBUILDDIR»/slice/IceGrid/Admin.ice /«PKGBUILDDIR»/slice/IceGrid/Locator.ice /«PKGBUILDDIR»/slice/IceGrid/Session.ice /«PKGBUILDDIR»/slice/IceGrid/Query.ice /«PKGBUILDDIR»/slice/IceGrid/Registry.ice /«PKGBUILDDIR»/slice/IceGrid/Descriptor.ice /«PKGBUILDDIR»/slice/IceGrid/Exception.ice
/«PKGBUILDDIR»/java/../cpp/bin/slice2java --output-dir /«PKGBUILDDIR»/java/generated -I/«PKGBUILDDIR»/slice --checksum IceStorm.SliceChecksums --ice /«PKGBUILDDIR»/slice/IceStorm/IceStorm.ice

ice-compile:
Created dir: /«PKGBUILDDIR»/java/depcache
Compiling 1228 source files to /«PKGBUILDDIR»/java/lib
/«PKGBUILDDIR»/java/src/IceInternal/OutgoingConnectionFactory.java:20: error: name clash: put(K#1,V#1) in MultiHashMap and put(K#2,V#2) in HashMap have the same erasure, yet neither overrides the other
        put(K key, V value)
        ^
  where K#1,V#1,K#2,V#2 are type-variables:
    K#1 extends Object declared in class MultiHashMap
    V#1 extends Object declared in class MultiHashMap
    K#2 extends Object declared in class HashMap
    V#2 extends Object declared in class HashMap
1 error

BUILD FAILED
/«PKGBUILDDIR»/java/build.xml:186: Compile failed; see the compiler error output for details.

Total time: 29 seconds
make[1]: *** [all] Error 1
make[1]: Leaving directory `/«PKGBUILDDIR»/java'
make: *** [debian/stamp-build-java] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
────────────────────────────────────────────────────────────────────────────────
Build finished at 20111110-0040

Finished
────────

E: Build failure (dpkg-buildpackage died)

Related branches

tags: added: amd64 auto java7-ftbfs
James Page (james-page) on 2011-11-25
tags: added: lang
James Page (james-page) wrote :

Reconfirmed in Ubuntu Quantal - adding ftbfs tag.

tags: added: ftbfs
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zeroc-ice (Ubuntu):
status: New → Confirmed
Changed in zeroc-ice (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeroc-ice - 3.4.2-8.1ubuntu1

---------------
zeroc-ice (3.4.2-8.1ubuntu1) quantal; urgency=low

  * Fix FTBFS with java7 (LP: #889005)
 -- Dmitrijs Ledkovs <email address hidden> Fri, 24 Aug 2012 19:25:19 +0100

Changed in zeroc-ice (Ubuntu):
status: Confirmed → Fix Released
Changed in zeroc-ice (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.