[SRU] Please accept zeroc-ice to supported releases

Bug #1815684 reported by José Gutiérrez de la Concha on 2019-02-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zeroc-ice (Ubuntu)
Low
Unassigned
Bionic
Low
Unassigned

Bug Description

[Impact]

 * zeroc-ice (3.7.2-4) includes various bug fixes for problems reported in
   3.7.1 the most important fixes that can affect Ubuntu users are:

   * Fixed a bug in IceGrid that could result in an infinite loop
      when Ice.ChangeUser is set and the call to getpwnam_r fails with
      ERANGE.

      https://github.com/zeroc-ice/ice/commit/21f5c77fc305ea1441b069753b0467fc145f6547

   * Fixed a bug in the code that parses command line options that caused
     short command line options to be incorrectly parsed when multiple short
     command line options are specified together.

     https://github.com/zeroc-ice/ice/issues/168

   * Fixed a bug in the syslog logger that caused the program name to not be
     correctly displayed with log messages.

     https://github.com/zeroc-ice/ice/issues/230

   * Fixed a bug in the IceGrid GUI that could cause IceGrid GUI to hang
     after a login failure.

     https://github.com/zeroc-ice/ice/issues/90

   * Fixed a bug that caused the generated code to reference undefined variables
     when included (using require or require_once) from a static method.

     https://github.com/zeroc-ice/ice/issues/174

   * Fixed Python segfault that could occur because of a KeyboardInterrupt.

     https://github.com/zeroc-ice/ice/issues/107

[Test Case]

 * There is more details of each bug in the links provided with they
   description

[Regression Potential]

 * Upstream packages are thoroughly tested before each release, and binary
   compatibility testing is done as part of the release process we (upstream)
   are confident that the chance for regression is very low.

 * The package has an extensive test suite that is build and run during
   package builds

[Other Info]

 zeroc-ice (3.7.2-4) corresponds to a new upstream microrelease. This package
 is already available in Ubuntu Disco and Debian Buster.

 The package build logs for bionic and cosmic are available in:

   https://launchpad.net/~y-jose/+archive/ubuntu/ppa/+packages

 The package build logs for debian are available in:

   https://buildd.debian.org/status/package.php?p=zeroc-ice

 A detailed changelog of the bugs included in this release is available at:

   https://raw.githubusercontent.com/zeroc-ice/ice-debian-packaging/master/CHANGELOG-3.7.md

 The debian changelog is available at:

   https://github.com/zeroc-ice/ice-debian-packaging/blob/master/debian/changelog

 Please SRU into bionic and cosmic

Changed in zeroc-ice (Ubuntu):
status: New → In Progress
tags: added: upgrade-software-version
Changed in zeroc-ice (Ubuntu):
importance: Undecided → Low
Changed in zeroc-ice (Ubuntu):
status: In Progress → Fix Released
Changed in zeroc-ice (Ubuntu Bionic):
importance: Undecided → Low
Simon Quigley (tsimonq2) wrote :

Hello José, thanks for your work on this!

Could you please edit the bug description to follow the SRU template? That can be found here: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Unsubscribing the Ubuntu Sponsors Team, please resubscribe us when that is done.

Hi Simon, I have updated the description as requested

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers