Please sync zeroc-ice-all-dev from debian unstable

Bug #1758502 reported by rg on 2018-03-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zeroc-ice (Ubuntu)
Undecided
Unassigned
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

The Ubuntu package currently include an additional patch for php 7.2 compatibility. Do you know if the newer version includes php7.2 support? If it does the patch can be dropped and the package synced, but if additional changes are still required someone will need to perform a manual merge of this package.

Btw, I believe this would fall under "new upstream version" so at this point a FeatureFreezeException is probably required to get it into bionic, see https://wiki.ubuntu.com/FreezeExceptionProcess#FeatureFreeze_for_new_upstream_versions for details.

tags: added: needs-debian-merge upgrade-software-version
rg (raphaelgr) wrote :

Since i never used php for ice, i do not know.
When looking at https://packages.debian.org/sid/php-zeroc-ice
there is the dependency 'dep: php-common (>= 1:7.0+33~)'.
So i guess it uses php7.0.

As for reporting this bug:
I followed this document
https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages

Hi,

The patch is already included in upstream 3.7.0 and the code should work fine with php 7.0, php 7.1 and php 7.2

Be aware there is a mumble bug with attached patch required to build mumble with Ice 3.7.0 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893604

Best Regards,
José

Hans Joachim Desserud (hjd) wrote :

Looks like it was synced, and zeroc-ice 3.7.0-5 is available in Ubuntu 18.04.

Changed in zeroc-ice (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.