Ubuntu 14.04 - Package zentyal-core is not configured yet.

Bug #1310694 reported by Hugo.Batel on 2014-04-21
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
zentyal-core (Ubuntu)
Undecided
Unassigned

Bug Description

Iḿ using Ubuntu Server 14.04 64 bits (trusty). It is a fresh install and iḿ trying to install Zentyal from the ubuntu repositories.

I use Zentyal from the Ubuntu repositories on several servers with ubuntu Server 12.04, and it works just fine.

I need to put another new server on production but now with Ubuntu Server 14.04 64 bits.

My problem is that with a clean and fresh install of ubuntu server 14.04 is that Zentyal will not install propertly . I tried several times on the server and on virtualbox and Zentyal always fail to install with the following error:

Package zentyal-core is not configured yet.

After this all the other packages from Zentyal fail with the same error. (zentyal-dns, zentyal-ntp, zentyal-firewall, etc...)

Its easy to reproduce this error because it happens allways with ubuntu server 14.04 fresh install and after doing:

sudo apt-get install zentyal-core zentyal-dns zentyal-ntp

I think that this is a bug on the packages on oficial ubuntu 14.094 repositories.

Thanks

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zentyal-core (Ubuntu):
status: New → Confirmed
Gryphus71 (gryphus71) wrote :

Hi,

complements on errors begin :

sudo apt-get install zentyal (3.4)
...
Perl API version v5.14.0 of 1 does not match v5.18.0 at /usr/lib/perl/5.18/DynaLoader.pm line 207.
Compilation failed in require at /usr/share/perl5/EBox/Sudo.pm line 25.
BEGIN failed--compilation aborted at /usr/share/perl5/EBox/Sudo.pm line 25.
Compilation failed in require at /usr/share/perl5/EBox/Module/Base.pm line 28.
...

E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks.

Hugo.Batel (hugo-batel) wrote :

Hello,

My bug report is about the zentyal packages existent on ubuntu 14.04 LTS oficial repositories. Until today version 2.3.

This is an "old" version and i think that it is the same on 12.04 LTS oficial repositories.

But i think that is important to mantain a working version on LTS realeases, and this one is not working at all...

slimjim2234 (slimjim2234) wrote :

I have the same error as Gryphus71

John Thom (john-thom) wrote :

I have the same error as Gryphus71. Trying to install on a new Ubuntu Server 14.04 64 bits (trusty).

Sergey Buidenko (sergsoft) wrote :

Yes, same in 14.04 Desktop at i386 arch

Sergey Buidenko (sergsoft) wrote :

So sorry, more info: I tried zentyal 3.3, not 3.4 (for some reasons) at 14.04 i386
 Message remains the same <API version v5.14.0 of 1 does not match v5.18.0>

slimjim2234 (slimjim2234) wrote :

Using zentyal 3.5 (haven't tested 3.4), the latest update as of 05-29-2014 works.
Flawless installation with a "sudo apt-get update && sudo apt-get install zentyal"

Markus Hanke (markus-hanke) wrote :

Indeed. zentyal 3.5 works. Use "deb http://archive.zentyal.org/zentyal 3.5 main" for the "/etc/apt/sources.list".

cdoebbler (cdoebbler) wrote :

Markus Hanke (markus-hanke) wrote on 2014-06-01: #9
Indeed. zentyal 3.5 works. Use "deb http://archive.zentyal.org/zentyal 3.5 main" for the "/etc/apt/sources.list".

Tried this and get this error: Unable to locate package zentyal

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers