zenity zenity --text-info --editable crashes on 56K text file on stdin

Bug #83549 reported by jno on 2007-02-06
6
Affects Status Importance Assigned to Milestone
Zenity
Fix Released
Medium
zenity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: zenity

$ ls -l file.txt
-r-xr-x--x 1 jno jno 56345 2007-01-24 19:55 file.txt
$ zenity --text-info --editable < file.txt # will crash
$ zenity --version
2.16.1
$ uname -a
Linux jno-laptop 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 6.10
Release: 6.10
Codename: edgy
$

jno (jnoster) wrote :

Crash log attached

Áron Sisak (asisak) wrote :

Thanks for your bug report. I tried to reproduce this bug on both Edgy (zenity 2.16.1) and Feisty (zenity 2.17.90) and failed.

Is this the only file that makes crash for you? Can you attach a file the causes crash in case it does not contain any sensitive information, please.

Changed in zenity:
assignee: nobody → asisak
status: Unconfirmed → Needs Info
jno (jnoster) wrote :

I've tried to use this tool as an editor.
I've used the command
$ zenity --text-info --editable < zrc.py
typed space, then "-Ou" just in the first line and clicked "Ok"...

Áron Sisak (asisak) wrote :

Thanks for the file. Confirmed on both Edgy and Feisty.
You don't even need to type anything (just open file and push OK/Close).

I guess the segfault is caused by the special printf format strings in the Python source code (in g_print).

Áron Sisak (asisak) on 2007-02-06
Changed in zenity:
importance: Undecided → Low
status: Needs Info → Confirmed
jno (jnoster) wrote :

Really cool toy:

$ echo '"%d"' | zenity --text-info --editable
"-1081300012"
$ echo '"%x"' | zenity --text-info --editable
"bff17a24"

:-)

jno (jnoster) wrote :

And, yes, it works this way:

$ sed -e '1,$s/%/%%/g' zrc.py | zenity --text-info --editable

Áron Sisak (asisak) wrote :

I created a debdiff that hopefully solves the problem.

Áron Sisak (asisak) on 2007-02-06
Changed in zenity:
assignee: asisak → nobody
Changed in zenity:
status: Unknown → Unconfirmed
Steve Kowalik (stevenk) wrote :
Steve Kowalik (stevenk) wrote :

zenity (2.18.0-0ubuntu2) feisty; urgency=low

  * Apply patch to stop a segfault on Close with large files. (LP: #83549)
  * Link gdialog.1.gz to zenity.1.gz. (LP: #50349)

 -- Steve Kowalik <email address hidden> Wed, 4 Apr 2007 22:48:57 +1000

Changed in zenity:
status: Confirmed → Fix Committed
Steve Kowalik (stevenk) wrote :

zenity 2.18.0-0ubuntu2 has built on all arches.

Changed in zenity:
status: Fix Committed → Fix Released
Changed in zenity:
status: Unconfirmed → Fix Released
Changed in zenity:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.