zenity's option to render html does not work

Bug #1478386 reported by sudodus on 2015-07-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
zenity (Ubuntu)
High
Unassigned

Bug Description

Zenity was updated a few days ago. Until then there was a bug with --checkbox, which is fixed now :-) But another bug was introduced: zenity's option to render html does not work. A similar bug was squashed in OpenSuse last year, and is still there in Fedora and Centos. But --html works in all versions of the Ubuntu flavours from 12.04 LTS 'Precise' to 15,04 'Vivid', and worked in 'Wily' until this last update of/to zenity 3.16.3.

The error output states:

"This option is not available. Please see --help for all possible usages."

The bug that was squashed last year was fixed in OpenSuse by compiling with WebKit. Maybe that works also now, maybe another tool is necessary now to add capability for html with the option --html.

Arx Cruz knows which tool to use:

"The --html is only available when you compile with webkit > 2.8.1 and the library is webkit2gtk. See https://bugzilla.gnome.org/show_bug.cgi?id=749798

If the new zenity wasn't built with support to this, you won't see the --html option."

You can run the following bash shell-script to test if it works or not.
-----
#!/bin/bash

echo "<h1>HTML headline</h1>
Hello World" | zenity --text-info --html --filename=/dev/stdin \
--width=$(($wadd+640)) --height=$(($hadd+400)) \
--title "$btitle" \
--ok-label="Go" --cancel-label="Quit" \
--checkbox="Check this box if you are ready to go"
-----
It should create a window similar to that in the attached file 'correct-rendering-html-precise.png'

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: zenity 3.16.3-1ubuntu1
ProcVersionSignature: Ubuntu 4.1.0-2.2-generic 4.1.3
Uname: Linux 4.1.0-2-generic i686
ApportVersion: 2.18-0ubuntu5
Architecture: i386
CasperVersion: 1.362
CurrentDesktop: LXDE
Date: Sun Jul 26 19:29:08 2015
LiveMediaBuild: Lubuntu 15.10 "Wily Werewolf" - Alpha i386 (20150725)
SourcePackage: zenity
UpgradeStatus: No upgrade log present (probably fresh install)

sudodus (nio-wiklund) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1478386

tags: added: iso-testing
sudodus (nio-wiklund) on 2015-07-26
description: updated
Mélodie (meets) wrote :

Hello,

I was wondering if the name of the option could have changed, or replaced by another action, so I did a check on the info file "text.page" in /usr/share/help/C/zenity for this version of the zenity-common package, and the "--html" is still what is supposed to be used for this case.

*************************************
      <item>
        <title><cmd>--html</cmd></title>
        <p>Enable html support.</p>
      </item>
*************************************

Best regards,
Mélodie

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zenity (Ubuntu):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

Arx Cruz told me:
--
The --html is only available when you compile with webkit > 2.8.1 and the library is webkit2gtk. See https://bugzilla.gnome.org/show_bug.cgi?id=749798

If the new zenity wasn't built with support to this, you won't see the --html option.
--

So please re-compile zenity with such a webkit version :-)

description: updated
Changed in zenity (Ubuntu):
importance: Undecided → High
victor00000 (vict1971) wrote :

hello!
my
zenlty:

yes - <img src="http://localhost/favicon.png"/>

not - <img src="file:///favicon.png"/>

what?

sudodus (nio-wiklund) wrote :

In wily zenity does not even accept the option --html

victor00000 (vict1971) wrote :

Yes http://

L~$
L~$ echo "<img src=\"http://localhost/1.png\"/>" | strace -f zenity --text-info --html --filename=/dev/stdin 2>&1 | grep "1\.png"
read(7, "<img src=\"http://localhost/1.png"..., 4096) = 36
[pid 31543] send(15, "GET /1.png HTTP/1.1\r\nHost: local"..., 169, MSG_NOSIGNAL) = 169
L~$

not file://

Next version?

Changed in zenity (Ubuntu):
status: Confirmed → Fix Committed
sudodus (nio-wiklund) wrote :

Where can I find a fixed version for testing?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zenity - 3.16.3-1ubuntu3

---------------
zenity (3.16.3-1ubuntu3) wily; urgency=medium

  * debian/control.in: build-depends on gnome-common

 -- Sebastien Bacher <email address hidden> Thu, 01 Oct 2015 17:04:38 +0200

Changed in zenity (Ubuntu):
status: Fix Committed → Fix Released
sudodus (nio-wiklund) wrote :

I found it in the repos, upgraded and yes, zenity works with --html again in Wily :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.