Ubuntu

[11.04→12.04 upgrade] Dash is always empty due to zeitgeist crash: Unable to upgrade from schema version 3

Reported by Natalia Bidart on 2012-04-20
58
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
Zeitgeist Framework
Fix Committed
Medium
Siegfried Gevatter
libzeitgeist
Medium
Siegfried Gevatter
unity-lens-applications
Medium
Michal Hruby
libzeitgeist (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
zeitgeist (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Test case:
1. Perform upgrade from 11.04 to 12.04
2. Reboot system
3. Start the dash (Super)
   -> The dash should not be empty
   -> Zeitgeist should not crash (zeitgeist-daemon)

===

Every time I open the dash pressing the super key, I get an empty dash. This has been happening for a long time now, I'm running unity-2d.

Please see screenshot attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,vpswitch,mousepoll,place,gnomecompat,wall,regex,resize,compiztoolbox,snap,session,animation,grid,move,fade,imgpng,workarounds,expo,scale,unitymtgrabhandles,ezoom,unityshell]
Date: Fri Apr 20 10:39:58 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Natalia Bidart (nataliabidart) wrote :
description: updated
Natalia Bidart (nataliabidart) wrote :
affects: unity (Ubuntu) → unity-2d (Ubuntu)
Didier Roche (didrocks) wrote :

Gerry, can you have a look please?

Changed in unity-2d:
milestone: none → 5.12
Michal Hruby (mhr3) wrote :

We were debugging this with Natalia, it seems to be an issue with Zeitgeist unable to start, because it was being used on Natty and then directly with Precise, so the schema was never updated from ver 3 (which would happen if Oneiric was installed), and latest Zeitgeist can't upgrade schema ver 3 or older.

As a workaround for now you can remove the Zeitgeist DB (`rm ~/.local/share/zeitgeist/activity.sqlite`), we'll make an SRU for zeitgeist where the old upgrade path will be re-added.

Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) on 2012-04-23
no longer affects: unity-2d
no longer affects: unity-2d (Ubuntu)
Changed in zeitgeist:
status: New → Fix Committed
assignee: nobody → Siegfried Gevatter (rainct)
importance: Undecided → Medium
Natalia Bidart (nataliabidart) wrote :

Michael,

I can confirm that removing the ZG databases and re-logging in fixed the issue, though I'm worried that accessing the ZG db is a mandatory requirement for the dash to show something.

Wouldn't it be better to show an application list (at least) despite ZG access not being completed successfully?

Thanks, Natalia.

Michal Hruby (mhr3) wrote :

> Wouldn't it be better to show an application list (at least) despite ZG access not being completed successfully?

Of course that was the idea, a bug in one of our libraries prevented that.

Michal Hruby (mhr3) on 2012-04-23
Changed in unity-lens-applications:
status: New → In Progress
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → Medium
milestone: none → 5.12.0
Changed in libzeitgeist:
milestone: none → 0.3.20
assignee: nobody → Siegfried Gevatter (rainct)
importance: Undecided → Medium
status: New → In Progress
Martin Pitt (pitti) on 2012-04-25
summary: - Dash is always empty
+ [11.04→12.04 upgrade] Dash is always empty due to zeitgeist crash:
+ Unable to upgrade from schema version 3
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: none → 5.14.0
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.14.0 → 5.12.0
status: New → Fix Committed
description: updated
Michal Hruby (mhr3) on 2012-04-27
Changed in libzeitgeist:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released

Hello Natalia, or anyone else affected,

Accepted unity-lens-applications into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-lens-applications (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Natalia Bidart (nataliabidart) wrote :

Hello! I would love to test this but I already removed all my "old" ZG databases.
Is there any way to fake an old ZG setup?

2012/4/27 Natalia Bidart <email address hidden>:
> Hello! I would love to test this but I already removed all my "old" ZG databases.
> Is there any way to fake an old ZG setup?

You can download the tarball of an old enough Zeitgeist version (0.7.0
should do, if I remember correctly) from
https://launchpad.net/zeitgeist and run it from there (doesn't need
installation).

To run it uncompress the tarball and build with "./autogen.sh; make".
Then stop any running Zeitgeist instances with "zeitgeist-daemon -q",
delete ~/.local/share/zeitgeist/activity.sqlite (or rename it if you
don't want to lose your history) and start Zeitgeist 0.7 with "python
./zeitgeist-daemon.py".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libzeitgeist (Ubuntu Precise):
status: New → Confirmed
Changed in libzeitgeist (Ubuntu):
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed

Hello Natalia, or anyone else affected,

Accepted libzeitgeist into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libzeitgeist (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in zeitgeist (Ubuntu Precise):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Hello Natalia, or anyone else affected,

Accepted zeitgeist into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.12.0-0ubuntu1

---------------
unity-lens-applications (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Popularity sorting not working correctly (LP: #985495)
    - run command (alt+F2): results do not contain the exact match
      (LP: #842108)
    - [11.0412.04 upgrade] Dash is always empty due to zeitgeist crash:
      Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 11:18:48 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-lens-applications (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libzeitgeist - 0.3.18-1ubuntu1

---------------
libzeitgeist (0.3.18-1ubuntu1) precise-proposed; urgency=low

  * debian/patches/01_fix_schema_upgrade.patch:
    [11.04 → 12.04 upgrade] Dash is always empty due to zeitgeist crash:
    Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Thu, 03 May 2012 14:55:07 -0700

Changed in libzeitgeist (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.9.0-1ubuntu1

---------------
zeitgeist (0.9.0-1ubuntu1) precise-proposed; urgency=low

  * debian/patches/01_upstream_cherry_picks.patch:
    - picks some upstream fixes:
    zeitgeist-fts crashed with SIGSEGV in fast_validate()
    (LP: #981300, #954171)
    [11.04 → 12.04 upgrade] Dash is always empty due to zeitgeist crash:
    Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Thu, 03 May 2012 14:28:29 -0700

Changed in zeitgeist (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libzeitgeist - 0.3.18-1ubuntu1

---------------
libzeitgeist (0.3.18-1ubuntu1) precise-proposed; urgency=low

  * debian/patches/01_fix_schema_upgrade.patch:
    [11.04 → 12.04 upgrade] Dash is always empty due to zeitgeist crash:
    Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Thu, 03 May 2012 14:55:07 -0700

Changed in libzeitgeist (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.9.0-1ubuntu1

---------------
zeitgeist (0.9.0-1ubuntu1) precise-proposed; urgency=low

  * debian/patches/01_upstream_cherry_picks.patch:
    - picks some upstream fixes:
    zeitgeist-fts crashed with SIGSEGV in fast_validate()
    (LP: #981300, #954171)
    [11.04 → 12.04 upgrade] Dash is always empty due to zeitgeist crash:
    Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Thu, 03 May 2012 14:28:29 -0700

Changed in zeitgeist (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers