zeitgeist-fts crashed with SIGSEGV in fast_validate()

Bug #981300 reported by Sam Swift on 2012-04-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
High
Michal Hruby
zeitgeist (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned

Bug Description

Test case:
- make sure zeitgeist-fts doesn't crash after the db is indexed
  (ouput of `ps aux | grep zeitgeist-fts` must be non-empty)

===

crash reported immediately on first boot after upgrading from 11.10

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: zeitgeist-core 0.9.0-1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu2
Architecture: i386
Date: Fri Apr 13 20:51:08 2012
ExecutablePath: /usr/lib/zeitgeist/zeitgeist-fts
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
ProcCmdline: /usr/lib/zeitgeist/zeitgeist-fts
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb727f8c0 <g_utf8_validate+480>: movzbl (%esi),%edx
 PC (0xb727f8c0) ok
 source "(%esi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: zeitgeist
StacktraceTop:
 g_utf8_validate () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: zeitgeist-fts crashed with SIGSEGV in g_utf8_validate()
UpgradeStatus: Upgraded to precise on 2012-04-14 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Sam Swift (samswift) wrote :

StacktraceTop:
 fast_validate (str=<optimized out>) at /build/buildd/glib2.0-2.32.0/./glib/gutf8.c:1461
 g_utf8_validate (str=0x0, max_len=-1, end=0x0) at /build/buildd/glib2.0-2.32.0/./glib/gutf8.c:1629
 ZeitgeistFTS::Indexer::IndexUri (this=0x8193968, uri=..., origin=...) at indexer.cpp:575
 ZeitgeistFTS::Indexer::IndexEvent (this=0x8193968, event=0x857d8c8) at indexer.cpp:1433
 Process (indexer=0x8193968, this=0x8453b98) at task.cpp:51

Changed in zeitgeist (Ubuntu):
importance: Undecided → Medium
summary: - zeitgeist-fts crashed with SIGSEGV in g_utf8_validate()
+ zeitgeist-fts crashed with SIGSEGV in fast_validate()
tags: removed: need-i386-retrace
Michal Hruby (mhr3) on 2012-04-27
visibility: private → public
Changed in zeitgeist:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Michal Hruby (mhr3)
importance: Medium → High
Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) on 2012-04-27
description: updated

Hello Sam, or anyone else affected,

Accepted zeitgeist into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in zeitgeist (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.9.0-1ubuntu1

---------------
zeitgeist (0.9.0-1ubuntu1) precise-proposed; urgency=low

  * debian/patches/01_upstream_cherry_picks.patch:
    - picks some upstream fixes:
    zeitgeist-fts crashed with SIGSEGV in fast_validate()
    (LP: #981300, #954171)
    [11.04 → 12.04 upgrade] Dash is always empty due to zeitgeist crash:
    Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Thu, 03 May 2012 14:28:29 -0700

Changed in zeitgeist (Ubuntu):
status: Confirmed → Fix Released
Changed in zeitgeist (Ubuntu Precise):
status: Fix Committed → Fix Released
Michal Hruby (mhr3) on 2012-10-01
Changed in zeitgeist:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers