zeitgeist-fts crashed with SIGSEGV in fast_validate()

Bug #954171 reported by Marco Trevisan (Treviño) on 2012-03-13
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
High
Michal Hruby
zeitgeist (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned

Bug Description

Test case:
- make sure zeitgeist-fts doesn't crash after the db is indexed
  (ouput of `ps aux | grep zeitgeist-fts` must be non-empty)

===

Got this crash just after upgrading from Oneiric (where I used the PPA version)

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: zeitgeist-core 0.8.99~alpha3-1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Tue Mar 13 16:03:16 2012
ExecutablePath: /usr/lib/zeitgeist/zeitgeist-fts
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: /usr/lib/zeitgeist/zeitgeist-fts
ProcEnviron:
 SHELL=/bin/bash
 LANG=it_IT.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f399f66c088 <g_utf8_validate+488>: movzbl (%rdi),%r8d
 PC (0x7f399f66c088) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%r8d" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: zeitgeist
StacktraceTop:
 g_utf8_validate () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: zeitgeist-fts crashed with SIGSEGV in g_utf8_validate()
UpgradeStatus: Upgraded to precise on 2011-05-07 (311 days ago)
UserGroups: adm admin audio cdrom debian-tor dialout dip fuse lp lpadmin netdev plugdev sambashare sbuild vboxusers video

StacktraceTop:
 fast_validate (str=<optimized out>) at /build/buildd/glib2.0-2.31.20/./glib/gutf8.c:1461
 g_utf8_validate (str=0x0, max_len=-1, end=0x0) at /build/buildd/glib2.0-2.31.20/./glib/gutf8.c:1629
 ZeitgeistFTS::Indexer::IndexUri (this=0xecd7f0, uri=..., origin=...) at indexer.cpp:502
 ZeitgeistFTS::Indexer::IndexEvent (this=0xecd7f0, event=0x684f8c0) at indexer.cpp:1007
 ZeitgeistFTS::IndexEventsTask::Process (this=0x1186db0, indexer=0xecd7f0) at task.cpp:29

Changed in zeitgeist (Ubuntu):
importance: Undecided → Medium
summary: - zeitgeist-fts crashed with SIGSEGV in g_utf8_validate()
+ zeitgeist-fts crashed with SIGSEGV in fast_validate()
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) on 2012-04-27
Changed in zeitgeist:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Michal Hruby (mhr3)
importance: Medium → High
Michal Hruby (mhr3) on 2012-04-27
description: updated

Hello Marco, or anyone else affected,

Accepted zeitgeist into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in zeitgeist (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.9.0-1ubuntu1

---------------
zeitgeist (0.9.0-1ubuntu1) precise-proposed; urgency=low

  * debian/patches/01_upstream_cherry_picks.patch:
    - picks some upstream fixes:
    zeitgeist-fts crashed with SIGSEGV in fast_validate()
    (LP: #981300, #954171)
    [11.04 → 12.04 upgrade] Dash is always empty due to zeitgeist crash:
    Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Thu, 03 May 2012 14:28:29 -0700

Changed in zeitgeist (Ubuntu):
status: Confirmed → Fix Released
Changed in zeitgeist (Ubuntu Precise):
status: Fix Committed → Fix Released
Michal Hruby (mhr3) on 2012-10-01
Changed in zeitgeist:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers