Ubuntu

fts.py crashed with DatabaseLockError in __init__(): Unable to get write lock on /home/ron/.local/share/zeitgeist/bb.fts.index: already locked

Reported by sojourner on 2011-11-25
586
This bug affects 85 people
Affects Status Importance Assigned to Milestone
Unity
High
Michal Hruby
zeitgeist (Ubuntu)
High
Canonical Desktop Team
Precise
High
Canonical Desktop Team

Bug Description

not doing anything inparticular I had just opened a root gedit window with sudo when the box poped up gedit functiond normaly .

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: zeitgeist-core 0.8.99~alpha1-1ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-1.3-generic 3.2.0-rc2
Uname: Linux 3.2.0-1-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Fri Nov 25 18:14:14 2011
ExecutablePath: /usr/share/zeitgeist/fts-python/fts.py
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111123)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: python /usr/share/zeitgeist/fts-python/fts.py
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/share/zeitgeist/fts-python/fts.py']
SourcePackage: zeitgeist
Title: fts.py crashed with DatabaseLockError in __init__(): Unable to get write lock on /home/ron/.local/share/zeitgeist/bb.fts.index: already locked
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

sojourner (itsmealso2) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zeitgeist (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Bryce Harrington (bryce) on 2011-12-22
Changed in zeitgeist (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → High
visibility: private → public
openick (openick) wrote :

This problem occurred when I opened gedit to edit /var/lib/apt/lists Gedit popped up with an error message in red to say that it is a directory. It was then that the error report was generated

Daniel Hahler (blueyed) on 2011-12-31
Changed in zeitgeist (Ubuntu Precise):
status: Confirmed → Triaged
Tadeáš Pařík (pariktadeas) wrote :

I can confirm it. This problem occurred when I wanted to edit /etc/apt/apt.conf.d/50unattended-upgrades

Otto Kekäläinen (otto) wrote :

I was browsing available wallpapers in desktop settings as it crashed and the automatic bug system notified there was an error with fts.py.

I'm running Ubuntu 12.04 with all the latest updates installed.

Sasa Paporovic (melchiaros) wrote :

By me it was on:

sudo nautilus
nautilus to var/crash
openup an crash(read determined to root, because of system crash) with double click(gedit).
On closing gedit I see zeitgeist crash report laying arround in var/crash in the still opened nautilus.

Thats all.

Tadeáš Pařík (pariktadeas) wrote :

Today I only opened terminal and received this bug, I did not edit anything in /etc/apt/... So let's few seconds after the start of the system, no other action done.

Stephen Ewen (ewenste) wrote :

Got the crash when simply running sudo gedit -s for a standalone root instance.

brian baker (brian-m-baker) wrote :

got crash just by opening up the terminal app !
running ubuntu 12.04 with all latest updates!

José Marques (jm-domus) wrote :

same here
inside sudo gedit, editing grub.

mfauzirahman (mfauzirahman) wrote :

it happen right away after login. Before I start anything

Same here, only logged in to Unity, then immediately got fts.py crash error.

jerrylamos (jerrylamos) wrote :

sudo gedit /etc/apt/sources.list and got his error, precise updated to 29 Jan, 3.2.0-12-pae

Jerry

tags: added: rls-mgr-p-tracking
Laura Czajkowski (czajkowski) wrote :

Logged into precise and I immediately get this error of a crash

Alan Pope ㋛ (popey) wrote :

Isn't this a result of people using sudo to run graphical applications, which we (in support circles) tell people not to do?

https://help.ubuntu.com/community/RootSudo#Graphical_sudo

"You should never use normal sudo to start graphical applications as Root. You should use gksudo (kdesudo on Kubuntu) to run such programs. gksudo sets HOME=~root, and copies .Xauthority to a tmp directory. This prevents files in your home directory becoming owned by Root. (AFAICT, this is all that's special about the environment of the started process with gksudo vs. sudo). "

Tadeáš Pařík (pariktadeas) wrote :

@Alan,

it could be answer for one part of this problem, e. g. if I wanted to edit something in /etc/apt/... However in the previous versions this problem did not occur. The second part - now time to time I receive this error opening terminal only (without editing or using sudo for graphical applications) and some users also when they want to log into the system...

Colin Law (colin-law) wrote :

@Alan Pope: It happens at other times also, but even if it did only happen when using sudo gedit (for example) it still should not crash. In fact if you look at your quote it suggests that the only difference between sudo and gksudo is the setting of HOME and copying .Xauthority, there is no way that not doing that should cause a crash.

tags: removed: bugpattern-needed
tags: added: bugpattern-written
kobe (florin-kobe) wrote :

got this bug while using vlc

McVries (mcvries) wrote :

A few seconds after boot while opening terminal.

I got this whilst running sudo gedit /var/log/Xorg.0.log

phillipude (2phillipsmail) wrote :

The bug info appeared when I attepted to report another bug at https://bugs.launchpad.net

Alexandre Jodoin (cacalex) wrote :

I have this as well, a few seconds after boot.
I'm not trying to open anything. It just happen...

David Barth (dbarth) wrote :

The Python version of the FTS extension is going away next week, says mrh3.

Changed in zeitgeist (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Changed in unity:
importance: Undecided → High
status: New → Triaged
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.6.0
status: Triaged → Invalid
Changed in zeitgeist (Ubuntu Precise):
status: Triaged → Invalid
Jacovenko (jacovenko-gmail) wrote :

while doing the update

kevinchou (kevinchou-c-gmail) wrote :

same here...

Edgar (edgar-barker) on 2012-02-13
Changed in zeitgeist (Ubuntu Precise):
status: Invalid → Confirmed
userdce (userdce) wrote :

happened on restart

Juan Carlos (arareka-ha) wrote :

Same here, after login.

Alexx (ag-cdo) wrote :

I've had this a number of times after login. Nothing open or opening.

Omer Akram (om26er) on 2012-02-18
Changed in unity:
milestone: 5.6.0 → none
Michal Hruby (mhr3) wrote :

The fts.py was a temporary solution and is no longer part of zeitgeist package.

Changed in zeitgeist (Ubuntu Precise):
status: Confirmed → Invalid
To post a comment you must log in.