Ubuntu

python-zeitgeist is missing a Replaces on zeitgeist-core (trying to overwrite '/usr/share/pyshared/zeitgeist/__init__.py')

Reported by Michael Bienia on 2011-11-24
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
zeitgeist (Ubuntu)
Undecided
Unassigned

Bug Description

During todays (2011-11-24) precise upgrade:

Selecting previously unselected package python-zeitgeist.
Unpacking python-zeitgeist (from .../python-zeitgeist_0.8.99~alpha1-1ubuntu1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/python-zeitgeist_0.8.99~alpha1-1ubuntu1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/zeitgeist/__init__.py', which is also in package zeitgeist-core 0.8.2-1

Preparing to replace zeitgeist-core 0.8.2-1 (using .../zeitgeist-core_0.8.99~alpha1-1ubuntu1_amd64.deb) ...
Unpacking replacement zeitgeist-core ...

As one can see python-zeitgeist got installed before the updated zeitgeist-core package, so python-zeitgeist needs a Replaces/Breaks on previous zeitgeist-core versions.

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.8.99~alpha1-1ubuntu2

---------------
zeitgeist (0.8.99~alpha1-1ubuntu2) precise; urgency=low

  * debian/control:
    - add replaces to zeitgeist-core (LP: #894356)
 -- Didier Roche <email address hidden> Thu, 24 Nov 2011 13:06:55 +0100

Changed in zeitgeist (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers