zeitgeist-daemon crashed with OperationalError in execute(): database is locked

Bug #848710 reported by Faisal Ahmed on 2011-09-13
960
This bug affects 112 people
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
High
Unassigned
zeitgeist (Ubuntu)
High
Unassigned

Bug Description

.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: zeitgeist-core 0.8.1.1-1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
Date: Tue Sep 13 08:26:28 2011
ExecutablePath: /usr/bin/zeitgeist-daemon
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
ProcCwd: /
PythonArgs: ['/usr/bin/zeitgeist-daemon']
SourcePackage: zeitgeist
Title: zeitgeist-daemon crashed with OperationalError in execute(): database is locked
UpgradeStatus: Upgraded to oneiric on 2011-09-01 (11 days ago)
UserGroups:

Faisal Ahmed (faisdotal) wrote :
tags: removed: need-duplicate-check
Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2011-09-13
visibility: private → public
tags: added: bugpattern-needed
Changed in zeitgeist (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: removed: bugpattern-needed
tags: added: bugpattern-written
Till Kamppeter (till-kamppeter) wrote :

I got the crash when I clicked on a .wav attachment (voice mail) in Thunderbird. Banshee opened and started to play the file. During playback Banshee popped up a dialog asking for my password to open my GNOME keyring. At the same moment I got the crash report pop-up.

Changed in zeitgeist (Ubuntu):
importance: Medium → High

This looks like the symptoms of a bug we fixed a while back with the FTS extension where the worker thread could access the sqlite cursor (which is not thread safe).

Please check if you can still reproduce this with zeitgeist-0.8.2 and zeitgeist-extension-fts-0.0.13 which should both be in Oneiric by now

gabriel staicu (gabriel-staicu) wrote :

Hi,

I updated my machine today 10/4/2011.
I attached a print screen of the error message.
In my environment the steps to reproduce are:
1) from a terminal execute vncserver -pn. This starts Xvnc4
2) connect with vnc to the machine and there execute update-manager
3) on the default screen appears error message regarding zeitgeist-daemon.

First appeared for me when I changed the system language from English to Greek.

Changed in zeitgeist:
status: New → Confirmed
importance: Undecided → High

Can people open up ~/.cache/zeitgeist/daemon.log in a text editor and see if there are any embarrassing, or confidential info in there, and if not attach it to this bug please? (and if there are you can also just delete those sections and attach it anyway)

gabriel staicu (gabriel-staicu) wrote :

here it is my deamon.log.

I am working on a fix

On Mon, Jan 16, 2012 at 3:07 PM, Muelli <email address hidden>wrote:

> ** Attachment added: "daemon.log"
>
> https://bugs.launchpad.net/ubuntu/+source/zeitgeist/+bug/848710/+attachment/2677278/+files/daemon.log
>
> --
> You received this bug notification because you are subscribed to
> Zeitgeist Framework.
> https://bugs.launchpad.net/bugs/848710
>
> Title:
> zeitgeist-daemon crashed with OperationalError in execute(): database
> is locked
>
> Status in Zeitgeist Framework:
> Confirmed
> Status in “zeitgeist” package in Ubuntu:
> Triaged
>
> Bug description:
> .
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: zeitgeist-core 0.8.1.1-1
> ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
> Uname: Linux 3.0.0-11-generic i686
> ApportVersion: 1.22.1-0ubuntu2
> Architecture: i386
> Date: Tue Sep 13 08:26:28 2011
> ExecutablePath: /usr/bin/zeitgeist-daemon
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110427.1)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
> ProcCwd: /
> PythonArgs: ['/usr/bin/zeitgeist-daemon']
> SourcePackage: zeitgeist
> Title: zeitgeist-daemon crashed with OperationalError in execute():
> database is locked
> UpgradeStatus: Upgraded to oneiric on 2011-09-01 (11 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zeitgeist/+bug/848710/+subscriptions
>

Changed in zeitgeist:
status: Confirmed → Fix Committed
Seif Lotfy (seif) on 2012-01-25
Changed in zeitgeist:
milestone: none → 0.9.0
Seif Lotfy (seif) on 2012-01-27
Changed in zeitgeist:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.8.99~alpha2-1

---------------
zeitgeist (0.8.99~alpha2-1) experimental; urgency=low

  * New upstream release. Some of the changes are:
    - Enhanced error handling, reporting and recovery (LP: #848710,
      LP: #743857).
    - The database file is now only readable by the user (LP: #910273).
    - GVFS usage in StorageMonitor has been disabled for now (LP: #905898).
    - Fixed a problem where the FTS extension could block the DB (LP: #919111).
    - Debug messages are no longer displayed by default (LP: #906451).
  * debian/rules:
    - Do not install the raw .trig files.
  * debian/zeitgeist-core.bash_completion:
    - Change source directory from extra/ to data/.

 -- Siegfried-Angel Gevatter Pujals <email address hidden> Fri, 27 Jan 2012 15:56:06 +0100

Changed in zeitgeist (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers