zeitgeist-daemon crashed with DocNotFoundError in _check_index_and_start_worker(): Document 5 not found

Bug #841922 reported by ab
This bug affects 208 people
Affects Status Importance Assigned to Milestone
Zeitgeist Extensions
High
Michal Hruby
zeitgeist (Ubuntu)
High
Michal Hruby
Oneiric
High
Michal Hruby

Bug Description

still crashes on logon after the required package update

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: zeitgeist-core 0.8.1.1-1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
Architecture: i386
Date: Mon Sep 5 16:52:18 2011
ExecutablePath: /usr/bin/zeitgeist-daemon
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=sk_SK.UTF-8
PythonArgs: ['/usr/bin/zeitgeist-daemon']
SourcePackage: zeitgeist
Title: zeitgeist-daemon crashed with DocNotFoundError in _check_index_and_start_worker(): Document 5 not found
Traceback:
 Traceback (most recent call last):
   File "/usr/share/zeitgeist/_zeitgeist/engine/extensions/fts.py", line 282, in _check_index_and_start_worker
     hits = self._enquire.get_mset (0, 1)
 DocNotFoundError: Document 5 not found
UpgradeStatus: Upgraded to oneiric on 2011-08-29 (7 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Revision history for this message
ab (radoslav78) wrote :
tags: removed: need-duplicate-check
Changed in zeitgeist (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
tags: added: bugpattern-written
removed: bugpattern-needed
Didier Roche (didrocks)
visibility: private → public
Revision history for this message
Michal Hruby (mhr3) wrote :

To investigate this further I'm afraid we'd need the Zeitgeist database of anyone who's been hit by this bug. So if anyone of you could send me their ~/.local/share/zeitgeist/activity.sql, id'd be very helpful. Of course your data will be kept private (please send the DB to my mail - <email address hidden>)

Revision history for this message
ab (radoslav78) wrote : Re: [Bug 841922] Re: zeitgeist-daemon crashed with DocNotFoundError in _check_index_and_start_worker(): Document 5 not found

Hello Michal,
I found this files into zeitgeist directory:
activity.sqlite activity.sqlite-journal datasources.pickle fts.index
I`m sending to you activity.sqlite and activity.sqlite-journal.

btw. from whitch country are you comes? because as the surname seems
to me, that we could also speak Slovak or Czech :)
radoslav maruska

2011/9/29 Michal Hruby <email address hidden>:
> To investigate this further I'm afraid we'd need the Zeitgeist database
> of anyone who's been hit by this bug. So if anyone of you could send me
> their ~/.local/share/zeitgeist/activity.sql, id'd be very helpful. Of
> course your data will be kept private (please send the DB to my mail -
> <email address hidden>)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/841922
>
> Title:
>  zeitgeist-daemon crashed with DocNotFoundError in
>  _check_index_and_start_worker(): Document 5 not found
>
> Status in “zeitgeist” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  still crashes on logon after the required package update
>
>  ProblemType: Crash
>  DistroRelease: Ubuntu 11.10
>  Package: zeitgeist-core 0.8.1.1-1
>  ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
>  Uname: Linux 3.0.0-10-generic i686
>  Architecture: i386
>  Date: Mon Sep  5 16:52:18 2011
>  ExecutablePath: /usr/bin/zeitgeist-daemon
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
>  InterpreterPath: /usr/bin/python2.7
>  PackageArchitecture: all
>  ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
>  ProcEnviron:
>   SHELL=/bin/bash
>   PATH=(custom, no user)
>   LANG=sk_SK.UTF-8
>  PythonArgs: ['/usr/bin/zeitgeist-daemon']
>  SourcePackage: zeitgeist
>  Title: zeitgeist-daemon crashed with DocNotFoundError in _check_index_and_start_worker(): Document 5 not found
>  Traceback:
>   Traceback (most recent call last):
>     File "/usr/share/zeitgeist/_zeitgeist/engine/extensions/fts.py", line 282, in _check_index_and_start_worker
>       hits = self._enquire.get_mset (0, 1)
>   DocNotFoundError: Document 5 not found
>  UpgradeStatus: Upgraded to oneiric on 2011-08-29 (7 days ago)
>  UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/zeitgeist/+bug/841922/+subscriptions
>

Revision history for this message
André Oliveira (oribunokiyuusou) wrote :

This happens to me on every single boot.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Marking this with high importance, given the number affected.

Changed in zeitgeist (Ubuntu Oneiric):
importance: Undecided → High
Revision history for this message
Michal Hruby (mhr3) wrote :

Thanks to everyone who sent their DB, we're investigating this.

@Radoslav: Yes we could :) but there are lots of people affected by this bug, so let's no make them use any translation websites. :)

Revision history for this message
Michal Hruby (mhr3) wrote :

Ok. The Desktop team is pushing a candidate fix to a PPA https://launchpad.net/~ubuntu-desktop/+archive/ppa (ppa:ubuntu-desktop/ppa). Anyone willing to test it out will be of great help! Thanks in advance.

Revision history for this message
Svivi (svivi) wrote :

I can confirm André's statement. I have this bug after every boot, too.

Revision history for this message
JahLux (anderson-maurice) wrote :

This also affects me, on EVERY boot . . . . .

Revision history for this message
Alberto Aldegheri (albyrock87) wrote :

Guys, just try with the suggested PPA, it fixes the bug for me.

Michal Hruby (mhr3)
Changed in zeitgeist-extensions:
milestone: none → fts-0.0.13
assignee: nobody → Michal Hruby (mhr3)
status: New → Fix Committed
importance: Undecided → High
status: Fix Committed → Fix Released
Michal Hruby (mhr3)
Changed in zeitgeist (Ubuntu Oneiric):
status: Confirmed → Fix Released
assignee: nobody → Michal Hruby (mhr3)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers