Ubuntu

zeitgeist-daemon crashed with AttributeError in close(): 'NoneType' object has no attribute 'execute'

Reported by Jean-Baptiste Lallement on 2011-06-06
922
This bug affects 173 people
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Undecided
Unassigned
zeitgeist (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: zeitgeist

I got this crash on wake up from hibernate after running out of battery.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: zeitgeist-core 0.8.0-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic i686
Architecture: i386
Date: Mon Jun 6 18:27:42 2011
ExecutablePath: /usr/bin/zeitgeist-daemon
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
ProcCwd: /
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_US.UTF-8
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/zeitgeist-daemon']
SourcePackage: zeitgeist
Title: zeitgeist-daemon crashed with AttributeError in close(): 'NoneType' object has no attribute 'execute'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Jean-Baptiste Lallement (jibel) wrote :
visibility: private → public

Please try running zeitgeist-daemon from the command line to check if everything is fine in the database. This looks like an sqlite issue

Try running
$ zeitgeist-daemon --replace

Please post the output as an attachment.

tags: removed: need-duplicate-check
Jean-Baptiste Lallement (jibel) wrote :

here it is.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Everything looks fine. The DB is fine
[DEBUG - zeitgeist.sql] Core schema is good. DB loaded in 10.7910633087ms

It looks like this exception is being raised when daemon is shutting down.

Jean-Baptiste Lallement (jibel) wrote :

I've got the same crash again this morning after a forced restart of the session (compiz crash)

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

I just got this bug shortly after booting up an Oneiric i386 machine and logging in to a unity-2d session. I have the same zeitgeist-core package version. The traceback text was exactly the same. I followed the instructions in https://bugs.launchpad.net/zeitgeist/+bug/793714/comments/2, and zeitgeist produced some errors not present in Jean-Baptiste Lallement's log. I don't know whether or not they're relevant to this bug. My log is attached.

Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Changed in zeitgeist (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
cgarre (cgarre) wrote :

got this just now after update to latest ... (am on 11.10 daily updates ... ) After reboot , this is a desktop.

Mike Young (chef8) wrote :

I just got this after latest update (11.10 daily updates)

Shyam (reddy-shyam) wrote :

same as Mike Young

Nicolas DERIVE (kalon33) wrote :

Same thing for me under Oneiric.

We are looking into the issue...
Can some1 give us a log ?

On Sat, Jul 2, 2011 at 4:58 PM, Nicolas DERIVE <email address hidden> wrote:

> Same thing for me under Oneiric.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/793714
>
> Title:
> zeitgeist-daemon crashed with AttributeError in close(): 'NoneType'
> object has no attribute 'execute'
>
> Status in Zeitgeist Framework:
> New
> Status in “zeitgeist” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: zeitgeist
>
> I got this crash on wake up from hibernate after running out of
> battery.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: zeitgeist-core 0.8.0-1ubuntu1
> ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
> Uname: Linux 2.6.39-3-generic i686
> Architecture: i386
> Date: Mon Jun 6 18:27:42 2011
> ExecutablePath: /usr/bin/zeitgeist-daemon
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
> ProcCwd: /
> ProcEnviron:
> SHELL=/bin/bash
> LC_MESSAGES=en_US.UTF-8
> LANGUAGE=en_US:en
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> PythonArgs: ['/usr/bin/zeitgeist-daemon']
> SourcePackage: zeitgeist
> Title: zeitgeist-daemon crashed with AttributeError in close(): 'NoneType'
> object has no attribute 'execute'
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zeitgeist/+bug/793714/+subscriptions
>

Christopher Meng (cicku) wrote :

I know the problem's solution,my ThinkPad T410i had this problem too,after this warning,my computer said that my battery was low,so I think system must have some problem on solving the low battery warning,I'm from China.

I will wait for the update of zeitgeist

@Seif, which log do you need. There are already 2 log files attached and the traceback seems to show that 1. the code tries to execute a query while the cursor is already closed, 2. the connection is closed twice when zeitgeist shuts down.

Do we need to run zeitgeist with a specific argument to collect the log you need ?

Crap I missed the log. So do you have an encrypted hard disk?

On Sun, Jul 3, 2011 at 10:23 AM, Jean-Baptiste Lallement <
<email address hidden>> wrote:

> @Seif, which log do you need. There are already 2 log files attached and
> the traceback seems to show that 1. the code tries to execute a query
> while the cursor is already closed, 2. the connection is closed twice
> when zeitgeist shuts down.
>
> Do we need to run zeitgeist with a specific argument to collect the log
> you need ?
>
> --
> You received this bug notification because you are a member of Zeitgeist
> Framework Team, which is subscribed to Zeitgeist Framework.
> https://bugs.launchpad.net/bugs/793714
>
> Title:
> zeitgeist-daemon crashed with AttributeError in close(): 'NoneType'
> object has no attribute 'execute'
>
> Status in Zeitgeist Framework:
> New
> Status in “zeitgeist” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: zeitgeist
>
> I got this crash on wake up from hibernate after running out of
> battery.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: zeitgeist-core 0.8.0-1ubuntu1
> ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
> Uname: Linux 2.6.39-3-generic i686
> Architecture: i386
> Date: Mon Jun 6 18:27:42 2011
> ExecutablePath: /usr/bin/zeitgeist-daemon
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
> ProcCwd: /
> ProcEnviron:
> SHELL=/bin/bash
> LC_MESSAGES=en_US.UTF-8
> LANGUAGE=en_US:en
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> PythonArgs: ['/usr/bin/zeitgeist-daemon']
> SourcePackage: zeitgeist
> Title: zeitgeist-daemon crashed with AttributeError in close(): 'NoneType'
> object has no attribute 'execute'
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zeitgeist/+bug/793714/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~zeitgeist
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~zeitgeist
> More help : https://help.launchpad.net/ListHelp
>

Marc Hines (marc-hines) wrote :

I do not have an encrypted hard disk, and I am running on a desktop (no battery). This happens about 10 seconds after I get the GUI.

Aurélien COUDERC (coucouf) wrote :

Same problem here.

I do have an encrypted disk (LVM in a dmcrypt) although it's not used by Ubuntu.

Aurélien COUDERC (coucouf) wrote :

To correct my last statement, the encrypted partitions are not mounted in /etc/fstab on my Ubuntu installation, but I sometimes mount them manually using nautilus.

Seif Lotfy (seif) wrote :

OK i am looking into it. Please forgive us it took us so long. I hope to find the error tonight :)

Christopher (soft-kristal) wrote :

I have three encrypted (encfs) folders but they are on another partition which doesn't mount automatically when I boot into Oneiric.

Seif Lotfy (seif) wrote :

Ok guys i need a way to replicate this to make it easier to fix. Else everything right now is just me guessing :(

Siegfried Gevatter (rainct) wrote :

Hi,

Thank you for your cooperation tracking down this bug. Unfortunatelly, the logs you've provided don't contain enough information for us to understand what's going on.

Could you please attach the content of your ~/.cache/zeitgeist/daemon.log.YYYY-MM-DD file for some day during which you could reproduce this bug? (Or, even better, ~/.cache/zeitgeist/daemon.log just after the crash happens).

Thanks!

Evan Huus (eapache) wrote :

This is my ~/.cache/zeitgeist/daemon.log shortly after the crash occurred. I believe the crash happened at around 20:39:54, as the nautilus search was done after the crash occurred.

I started with a clean Natty install, and upgraded to Oneiric. Booted up (unity-2d) and opened update-manager. The crash occurred halfway through the check for updates. Firefox was also open, as I was looking at some changelogs.

Evan Huus (eapache) wrote :

And here is the log immediately after the crash. All I did to reproduce was reboot, log in to unity-2d, and wait. I have not opened the dash or done anything but apport this entire session, so the log should be crystal clean :)

tags: added: bugpattern-needed
Matthew Young (gtrsdk) wrote :

I got this after installing updates and rebooting.

tags: added: iso-testing
VinDSL (perfect-pecker) wrote :

Same problem here. Subscribing...

I'll attach my log, as requested.

Same problem here, but the timestamp on the /var/crash/ file seems to indicate the crash happens at logout.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.8.1-1ubuntu1

---------------
zeitgeist (0.8.1-1ubuntu1) oneiric; urgency=low

  * Merge with debian, remaining change:
    - Build-dep on raptor2-utils instead of raptor-utils

zeitgeist (0.8.1-1) unstable; urgency=low

  * New upstream release. Some of the changes are:
     - Database backup before attempting schema upgrades (LP: #660307).
     - Ensure the engine doesn't attempt to close twice in a row (LP: #793714).
     - Improve the Python API's behavior when Zeitgeist is restarted.
     - Added support for registering custom Event and Subject subclasses with
       ZeitgeistClient (LP: #799199), and added some new API methods.
  * debian/control:
     - Fix typo in the description (hold -> held). Thanks to Travis Reddell.
 -- Didier Roche <email address hidden> Thu, 07 Jul 2011 18:49:45 +0200

Changed in zeitgeist (Ubuntu):
status: Triaged → Fix Released
Changed in zeitgeist:
status: New → Fix Released
wojox (wojox) wrote :

Fresh install of 11.10. Rebooted and apt-get update. Rebooted again, opened Ubuntu Software Center and it reported it crashed but still installed the ccsm package I wanted.

To post a comment you must log in.