zeitgeist-daemon crashed with GError in start_datahub(): Failed to execute child process "zeitgeist-datahub" (No such file or directory)

Bug #791392 reported by Alessandro Losavio on 2011-06-01
82
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Medium
Siegfried Gevatter
zeitgeist (Ubuntu)
Low
Siegfried Gevatter

Bug Description

Binary package hint: zeitgeist

- Xubuntu 11.10 alpha 1 amd64

Step to reproduce it:

1) Open Ubuntu Software Center

Appears immediately a crash, but the Software Center works correctly. In fact, I could install the programs without problems.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: zeitgeist-core 0.8.0-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
Architecture: amd64
Date: Wed Jun 1 15:01:24 2011
ExecutablePath: /usr/bin/zeitgeist-daemon
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Xubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110531)
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
PythonArgs: ['/usr/bin/zeitgeist-daemon']
SourcePackage: zeitgeist
Title: zeitgeist-daemon crashed with GError in start_datahub(): Failed to execute child process "zeitgeist-datahub" (No such file or directory)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Alessandro Losavio (alo21) wrote :
tags: removed: need-duplicate-check
tags: added: iso-testing
Siegfried Gevatter (rainct) wrote :

Note to myself:
This should have been ignored by Zeitgeist since zeitgeist-datahub is optional. It looks like glib.spawn_async changed from raising a OSError to raising this GError, so we need to update the try/catch to consider both.

visibility: private → public
Robert Roth (evfool) on 2011-07-14
Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Changed in zeitgeist:
assignee: nobody → Siegfried Gevatter (rainct)
importance: Undecided → Medium
milestone: none → 0.8.1.1
status: New → Fix Committed
Changed in zeitgeist (Ubuntu):
importance: Undecided → Low
assignee: nobody → Siegfried Gevatter (rainct)
Changed in zeitgeist:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.8.1.1-1

---------------
zeitgeist (0.8.1.1-1) unstable; urgency=low

  * New upstream release:
     - Fix problem when replacing an existing Zeitgeist instance (LP: #809569).
     - Fix possible crash when zeitgeist-datahub isn't available (LP: #791392).
     - Python API: fix regression affecting get_version and get_extensions
       (Closes: #634306).
     - Added Esperanto translation by Kristjan Schmidt (Closes: #633421).
  * Switch from dh_pysupport to dh_python2.
 -- Siegfried Gevatter <email address hidden> Mon, 25 Jul 2011 10:04:52 +0000

Changed in zeitgeist (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers