zeitgeist-daemon crashed with OSError in makedirs(): [Errno 13] Permission denied: '/home/ubuntu/.local/share/zeitgeist'

Bug #760111 reported by Charlie Kravetz on 2011-04-13
122
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Undecided
Unassigned
zeitgeist (Ubuntu)
High
Unassigned
Natty
Medium
Mikkel Kamstrup Erlandsen
Oneiric
High
Siegfried Gevatter
Precise
High
Unassigned

Bug Description

Binary package hint: zeitgeist

This error is shown when attempting to perform the screen-reader installation using the Natty Narwhal Beta 2 candidate, ubuntu-desktop-i386.iso, dated 2011-04-13.

1. start the computer with the cd in the drive
2. hit any key to bring up the cd menu, right after the bios check
3. hit enter on language
4. hit F5
5. down arrow three times
6. enter two times
7. When the live desktop starts, orca will start
8. wait for the error to appear

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: zeitgeist-core 0.7.1-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Wed Apr 13 18:42:35 2011
ExecutablePath: /usr/bin/zeitgeist-daemon
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/zeitgeist-daemon']
SourcePackage: zeitgeist
Title: zeitgeist-daemon crashed with OSError in makedirs(): [Errno 13] Permission denied: '/home/ubuntu/.local/share/zeitgeist'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Charlie Kravetz (charlie-tca) wrote :
visibility: private → public
Charlie Kravetz (charlie-tca) wrote :

This is particularly frustrating when the user manages to hit Alt+F1, arow-right, arrow-right, arrow-down, arrow-right, down arrow until the install 11.04, enter, before this error shows up. Since this is normally a visually impaired user, they may not even know why the installation did not proceed when this is on top of the install winodws.

tags: removed: need-duplicate-check
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.
I'm able to reproduce this crash with the steps above.

Changed in zeitgeist (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in zeitgeist (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

As this affects the live system (only, apparently), fixing this in an SRU doesn't make too much sense. Mikkel, is that something we can still get fixed this week? Or is it just cosmetical, and we can ignore it?

Changed in zeitgeist (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Mikkel Kamstrup Erlandsen (kamstrup)
milestone: none → ubuntu-11.04
Kate Stewart (kate.stewart) wrote :

Upping priority so it gets considered for fixing early in Oneiric's cycle.

Changed in zeitgeist (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Changed in zeitgeist (Ubuntu Oneiric):
milestone: ubuntu-11.04 → none
importance: Medium → High
tags: added: rls-mgr-o-tracking
tags: added: rls-mgr-p-tracking testcase
removed: rls-mgr-o-tracking
Jean-Baptiste Mazon (jmazon) wrote :

I was asked in 858812 but it was marked duplicate so I'll answer here: in my case it happened on an installed system (not a live CD). But it hasn't reoccured since a long time.

Siegfried Gevatter (rainct) wrote :

Zeitgeist task: catch this problem and quit with an error message and new exit code. Nothing really we could do.

Changed in zeitgeist:
milestone: none → 0.9.0
status: New → Triaged
David Barth (dbarth) on 2012-01-12
tags: added: rls-p-tracking
David Barth (dbarth) wrote :

The issue is not applicable to Precise, where Zeitgeist is now implemented in Vala.

Changed in zeitgeist (Ubuntu Precise):
status: Triaged → Invalid
Changed in zeitgeist (Ubuntu Natty):
status: Triaged → Won't Fix
Changed in zeitgeist (Ubuntu Oneiric):
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → Siegfried Gevatter (rainct)
Changed in zeitgeist (Ubuntu Precise):
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → nobody
David Barth (dbarth) wrote :

@rainct: if you have a patch handy to do the clean exit, we can consider it for oneiric. Otherwise, I think it's not worth the effort considering that the fix would not even contribute to P. It's worth checking if the vala implementation has a similar problem though.

Changed in zeitgeist:
status: Triaged → Fix Committed
Seif Lotfy (seif) on 2012-01-27
Changed in zeitgeist:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in zeitgeist (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers