Ubuntu

Natty FFE: Update to Zeitgeist 0.7.0

Reported by Mikkel Kamstrup Erlandsen on 2011-03-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zeitgeist (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: zeitgeist

Natty currently ships Zeitgeist 0.5.2. To provide the best application usage logging Zeitgeist 0.7.0 - together with zeitgeist-datahub-0.7.0 - is a way better option.

If we update to Zeitgeist-0.7.0 and Zeitgeist Datahub 0.7.0 we'll get:

 - Better performing Zeitgeist queries
 - Cut 7-8mb of the writable mem-usage of the datahub
 - More precise app usage logging by using the new GIO DBus signal available since glib-2.28
 - We can (and should) get rid of the zeitgeist-gio module which is currently loaded into *all* processes

I've been dogfooding Zeitgeist 0.7.0 (+datahub) on my laptop for the past days and haven't seen any problems.

Martin Pitt (pitti) wrote :

Does that new version introduce any public D-BUS/python API breaks which need changes in other parts of Ubuntu (also universe)?

Siegfried Gevatter (rainct) wrote :

Nope.

(I'm attaching the new entries from the NEWS file, which is more readable than the ChangeLog).

Martin Pitt (pitti) wrote :

Thanks! The news file is indeed a lot better to read. Approved, thanks for the testing already done!

Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

sync as per bug #735586

Changed in zeitgeist (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers