zeitgeist-datahub crashed with AttributeError in _get_items() (apparently when/because the database is still empty)

Bug #531793 reported by Daniel Holm on 2010-03-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Undecided
Siegfried Gevatter
zeitgeist (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: zeitgeist

Installed from Lucids repo and it doesnt seem to work..

ProblemType: Crash
Architecture: amd64
Date: Thu Mar 4 10:15:02 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/zeitgeist-datahub
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: zeitgeist-datahub 0.3.2-1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-datahub
ProcCwd: /
ProcEnviron:
 SHELL=/bin/bash
 LANG=sv_SE.utf8
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
PythonArgs: ['/usr/bin/zeitgeist-datahub']
SourcePackage: zeitgeist
Title: zeitgeist-datahub crashed with AttributeError in _get_items()
Uname: Linux 2.6.32-15-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Daniel Holm (danielholm) wrote :
tags: removed: need-duplicate-check
Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu and Zeitgeist better by reporting this bug. However, this issue is a duplicate of bug #523761, which has already been resolved. I'm marking this bug as a duplicate.

Please use bug #523761 for all conversation regarding this issue.

visibility: private → public
Sense Egbert Hofstede (sense) wrote :

Apologises, I marked the wrong bug as a duplicate. This bug is most certainly not a duplicate of bug #523761.

Sense Egbert Hofstede (sense) wrote :

It appears that this crash happens when you haven't got anything for zeitgeist-datahub to iterate over. I'll forward this issue upstream but leave the importance at Undecided until we know how far this crash reaches.

Changed in zeitgeist (Ubuntu):
status: New → Triaged
summary: zeitgeist-datahub crashed with AttributeError in _get_items()
+ (apparently when/because the database is still empty)
Siegfried Gevatter (rainct) wrote :

Thank you for your bug report. This is now fixed and will be released in 0.3.3.

The problem is the «info.get_uri_display().startswith("/tmp/")»; where get_uri_display() can be None but we weren't checking for that, this has now been fixed (by using get_uri() instead of get_uri_display(), but a "info.get_uri_display() is not None" check would do as well).

Changed in zeitgeist:
assignee: nobody → Siegfried Gevatter (rainct)
milestone: none → 0.3.3
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist - 0.3.2-1ubuntu1

---------------
zeitgeist (0.3.2-1ubuntu1) lucid; urgency=low

  The "let's backport fixes" release.

  * zeitgeist/datamodel.py:
     - Fixes the display name for Interpretation.SOURCECODE.
  * zeitgeist/client.py:
     - Fix find_events_for_values (LP: #510804).
     - Fix find_events_for_template, was returning event IDs only.
  * _zeitgeist/engine/main.py:
     - Ensure event deletions get committed and ignore deletion requests with no
       valid IDs (LP: #566173, #566184).
     - Fix insertion of events with a payloads (LP: #557708).
  * _zeitgeist/engine/remote.py:
     - Fix wrong docstrings (FindEvent mentioned the return type of FindEventIds,
       and the other way around).
  * _zeitgeist/loggers/datasources/recent.py:
     - Recognize additional mime-types (LP: #510761).
     - Fix crash trying to access a broken symlink (LP: #523761, #549567).
     - Fix crash when GtkRecentManager doesn't have a display-friendly version
       of a URI (LP: #531793).
     - Fix crash parsing malformed .desktop files (LP: #526357).
     - Prepend "application://" to the actor name.
  * _zeitgeist/engine/sql.py:
     - Update event_view to lookup the payload's value instead of returning its
       rowid.
  * _zeitgeist/engine/extension.py:
     - Make ExtensionsCollection iterable.
  * doc/zeitgeist-daemon.1:
     - Update information in the "Environment variables" section.
  * debian/control:
     - Version zeitgeist-datahub's zeitgeist-daemon dependency to 0.3.2 or later.
 -- Siegfried-Angel Gevatter Pujals <email address hidden> Fri, 23 Apr 2010 16:46:07 +0200

Changed in zeitgeist (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers