Upgrade zeitgeist to 0.9.14

Bug #1155968 reported by DonnieD on 2013-03-16
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
zeitgeist (Debian)
Fix Released
Unknown
zeitgeist (Ubuntu)
Wishlist
Unassigned

Bug Description

Upgrade zeitgeist to latest 0.9.14 stable
https://launchpad.net/zeitgeist/0.9/0.9.14

Additionally please delete zeitgeist-datahub from archives or make zeitgeist-0.9.14 package conflict with zeitgeist-datahub package in archives because 0.9.14 comes along with datahub in the same source package

With this release libzeitgeist is also deprecated since 0.9.14 comes with libzeitgeist too. It is named libzeitgeist2, but libzeitgeist1 should be kept in archives because other apps still build against it.

Relevant/Significant changes since 0.9.5
* Datahub has been integrated in the source tarball
* libzeitgeist2 is included in tarball which deprecates libzeitgeist1 (both versions have significant changes)
* Fix compilation breaks for --enable-datahub --disable-downloads-monitor
* Improve FTS memory consumption

Related branches

DonnieD (donnied) on 2013-03-16
description: updated
Changed in zeitgeist (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-06-07
summary: - Upgrade to 0.9.9
+ Upgrade to 0.9.13
description: updated
tags: added: upgrade-software-version
Changed in zeitgeist (Ubuntu):
importance: Undecided → Wishlist
summary: - Upgrade to 0.9.13
+ Upgrade to 0.9.14
description: updated
description: updated
description: updated
summary: - Upgrade to 0.9.14
+ Upgrade zeitgeist to 0.9.14
Jeremy Bicha (jbicha) wrote :

After test-building this package I see that zeitgeist-core depends on libzeitgeist-2.0-0.

Have you tested whether the other packages that use libzeitgeist will build and run against libzeitgeist2?
If they don't, will they still work when zeitgeist-core is linked against libzeitgeist-2.0-0?
How much work will it be to port these to libzeitgeist2 and do you have a plan to do that?

$ apt-cache rdepends libzeitgeist-1.0-1
libzeitgeist-1.0-1
Reverse Depends:
  activity-log-manager
  bijiben
  cairo-dock-plug-ins
  diodon-plugins
  gedit
  libfolks-telepathy25
  libzeitgeist-1.0-1-dbg
  libzeitgeist-dev
  nautilus
  synapse
  totem-plugins
  unity
  unity-lens-applications
  unity-lens-files
  unity-lens-video
  unity-scope-video

Shouldn't python-zeitgeist depend on libzeitgeist or libzeitgiest2?

$ apt-cache rdepends python-zeitgeist
python-zeitgeist
Reverse Depends:
  catfish
  zim

Jeremy Bicha (jbicha) wrote :

$ reverse-depends src:zeitgeist
Reverse-Recommends
==================
* libzeitgeist-1.0-1 (for zeitgeist, zeitgeist-core)
* synapse (for zeitgeist, zeitgeist-core)

Reverse-Depends
===============
* activity-log-manager (for zeitgeist, zeitgeist-core)
* catfish (for python-zeitgeist, zeitgeist)
* dockmanager (for zeitgeist)
* gnome-activity-journal (for zeitgeist, zeitgeist-core)
* rhythmbox-plugin-zeitgeist (for zeitgeist-core)

I have been using zeitgeist engine (zeitgeist-core) built against libzeitgeist1 with applications built against libzeitgeist1.

It is working because all the communication happens over dbus. Any changes which took place was at library level. DBus API remained nearly the same, but the programmer facing abstraction of API was vastly improved.

Theoretically, the apps built against libzeitgeist1 do not need to be rebuilt to work against zeitgeist-core built using libzeitgeist2

I would be sooner working on moving everything to libzeitgeist2

libfolks-telepathy25 has been patched upstream to use libzeitgeist2 IIRC. It should make it into saucy if released on time

Typo: I mean
"I have been using zeitgeist engine (zeitgeist-core) built against libzeitgeist2"

Changed in zeitgeist (Ubuntu):
status: Confirmed → Fix Released
Changed in zeitgeist (Debian):
status: Unknown → New
Changed in zeitgeist (Debian):
status: New → Fix Committed
Changed in zeitgeist (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.