zeitgeist-daemon crashed with SIGSEGV in std::_Rb_tree<std::string, std::pair<std::string const, OmDocumentTerm>, std::_Select1st<std::pair<std::string const, OmDocumentTerm> >, std::less<std::string>, std::allocator<std::pair<std::string const, OmDocumentTerm> > >::_M_erase()

Bug #839885 reported by Saravanan Thirumuruganathan
68
This bug affects 8 people
Affects Status Importance Assigned to Milestone
zeitgeist-extensions (Ubuntu)
Invalid
Medium
Unassigned

Bug Description

This error occurred on first reboot after Oneiric beta1 install.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: zeitgeist-core 0.8.1.1-1
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Fri Sep 2 15:39:47 2011
ExecutablePath: /usr/bin/zeitgeist-daemon
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/zeitgeist-daemon
ProcCwd: /
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fc4a3bf86f2 <_ZNSt8_Rb_treeISsSt4pairIKSs14OmDocumentTermESt10_Select1stIS3_ESt4lessISsESaIS3_EE8_M_eraseEPSt13_Rb_tree_nodeIS3_E+130>: lock xadd %edx,-0x8(%rax)
 PC (0x7fc4a3bf86f2) ok
 source "%edx" ok
 destination "-0x8(%rax)" (0x6086b74020b6565) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: zeitgeist
StacktraceTop:
 std::_Rb_tree<std::string, std::pair<std::string const, OmDocumentTerm>, std::_Select1st<std::pair<std::string const, OmDocumentTerm> >, std::less<std::string>, std::allocator<std::pair<std::string const, OmDocumentTerm> > >::_M_erase(std::_Rb_tree_node<std::pair<std::string const, OmDocumentTerm> >*) () from /usr/lib/libxapian.so.22
 std::_Rb_tree<std::string, std::pair<std::string const, OmDocumentTerm>, std::_Select1st<std::pair<std::string const, OmDocumentTerm> >, std::less<std::string>, std::allocator<std::pair<std::string const, OmDocumentTerm> > >::_M_erase(std::_Rb_tree_node<std::pair<std::string const, OmDocumentTerm> >*) () from /usr/lib/libxapian.so.22
 Xapian::Document::Internal::~Internal() () from /usr/lib/libxapian.so.22
 Xapian::Document::Internal::~Internal() () from /usr/lib/libxapian.so.22
 Xapian::TermGenerator::set_document(Xapian::Document const&) () from /usr/lib/libxapian.so.22
Title: zeitgeist-daemon crashed with SIGSEGV in std::_Rb_tree<std::string, std::pair<std::string const, OmDocumentTerm>, std::_Select1st<std::pair<std::string const, OmDocumentTerm> >, std::less<std::string>, std::allocator<std::pair<std::string const, OmDocumentTerm> > >::_M_erase()
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

Revision history for this message
Saravanan Thirumuruganathan (saravanan-thirumuruganathan) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __exchange_and_add (__mem=0x6086b74020b6565, __val=-1) at /usr/include/c++/4.6/ext/atomicity.h:48
 __exchange_and_add_dispatch (__val=-1, __mem=0x6086b74020b6565) at /usr/include/c++/4.6/ext/atomicity.h:81
 _M_dispose (__a=..., this=0x6086b74020b6555) at /usr/include/c++/4.6/bits/basic_string.h:240
 ~basic_string (this=0x24e4868, __in_chrg=<optimized out>) at /usr/include/c++/4.6/bits/basic_string.h:534
 ~OmDocumentTerm (this=0x24e4868, __in_chrg=<optimized out>) at ../common/documentterm.h:36

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in zeitgeist (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in zeitgeist (Ubuntu):
status: New → Confirmed
affects: zeitgeist (Ubuntu) → zeitgeist-extensions (Ubuntu)
Revision history for this message
dino99 (9d9) wrote :

This version has expired long ago; no more supported

Changed in zeitgeist-extensions (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers