NetworkManager cannot connect to WPA network at first boot, (usb device: 0ace:1211)

Bug #103366 reported by Conn O Griofa on 2007-04-05
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
zd1211 (Ubuntu)
Undecided
Unassigned

Bug Description

EDIT: I previously thought that the zd1211rw-mac80211 module solved my problem, but I was incorrect.

System: Intel Pentium II, 192mb RAM, Ubuntu Feisty w/latest updates

I have a USB wireless card branded as "Canyon CN-WF518 Wireless Network Interface USB 2.0 Adapter IEEE 802.11b/802.11g", using zd1211rw driver. When plugged in, Feisty correctly recognises the card and loads the zd1211rw module successfully. NetworkManager can correctly scan wireless networks, but when I try to connect to my home network using WPA/WPA2-PSK, the connection can never establish correctly the first time. I have installed libpam-keyring and added "@include common-pamkeyring" to /etc/pam.d/gdm.

Steps to reproduce:
1. Boot computer with USB wireless card connected
2. Log in to GNOME
3. Wait for NetworkManager to establish connection to wireless network (preconfigured previously).
4. After waiting for network to connect (the two spheres remain grey), NetworkManager gives up and disconnects.
5. Click on the NetworkManager applet, then click on my wireless network (43OGR)
6. The spheres will turn green and the connection will establish correctly.

This behaviour occurs at every boot, and the network will always connect successfully on the second (manual) attempt. Below is my kernel version and lsusb output, and I attached system logs. However, I am not sure what logs are useful to troubleshoot this issue, so please let me know what you need.

conn@compaq:~/bugreport$ lsusb
Bus 001 Device 003: ID 413c:3200 Dell Computer Corp.
Bus 001 Device 002: ID 0ace:1211 ZyDAS 802.11b/g USB2 WiFi
Bus 001 Device 001: ID 0000:0000

conn@compaq:~/bugreport$ uname -a
Linux compaq 2.6.20-14-generic #2 SMP Mon Apr 2 20:37:49 UTC 2007 i686 GNU/Linux

Conn O Griofa (psyke83) on 2007-04-05
description: updated

I whipped up a script that essentially fixes the problem, but it's working around what I suspect to be a driver or NetworkManager issue.

/etc/network/if.pre-up.d/hackwireless:
#!/bin/sh
iwconfig eth1 essid MYESSID
sleep 2

Replace your network interface name (eth1) and your wireless network's ESSID (MYESSID), and chmod +x the file. From now on, NetworkManager connects to my wireless network flawlessly every time. I tried simpler things such as "iwconfig eth1 rate 11M" or "ifconfig eth1 up", but it seems that setting your wireless ESSID manually before NetworkManager kicks in is the only way to fix the issue. Setting a dummy ESSID also doesn't help, it has to be your real ESSID.

What logs do you need to troubleshoot this issue?

Conn O Griofa (psyke83) wrote :

Please see this thread on the developer's list, I believe it is the same issue: http://<email address hidden>/msg00802.html

Tim Gardner (timg-tpi) wrote :

Please try this update:

cd /lib/modules/2.6.20-15-generic/kernel/net/ieee80211/softmac
sudo cp ieee80211softmac.ko ieee80211softmac.ko.old
sudo wget -O ieee80211softmac.ko http://people.ubuntu.com/~rtg/ieee80211softmac.ko-2.6.20-15.27

Either reboot or remove/insert your softmac based wireless driver using modprobe.

Changed in zd1211:
assignee: nobody → timg-tpi
importance: Undecided → Critical
status: Unconfirmed → In Progress
Conn O Griofa (psyke83) wrote :

I have unmarked this as a duplicate of bug #103768. I tested Tim Gardner's workaround but my issue still occurs, so it's a different bug with similar symptoms.

Conn O Griofa (psyke83) wrote :

From: http://www.linuxwireless.org/en/users/Drivers/zd1211rw#head-dfa194ef8747529a0c18b3efae51430abd3fb34f

"On some distributions (e.g., Debian) dhclient scripts do an ifconfig down/up before trying to get an IP which causes the driver to disassociate. Add iface eth1 inet dhcp to your /etc/networking/interfaces and bring up the interface with ifup eth1."

Could driver-specific quirks such as mentioned above cause Network Manager to fail associating? Again, I tried Tim Gardner's proposed fix and it didn't help, the network will only associate if I manually uncheck "Enable wireless" and recheck it via the applet.

Martin Pitt (pitti) on 2007-06-05
Changed in linux-source-2.6.20:
importance: Critical → Medium
Tim Gardner (timg-tpi) on 2007-06-19
Changed in linux-source-2.6.20:
assignee: timg-tpi → ubuntu-kernel-team
status: In Progress → Fix Released
Daniel T Chen (crimsun) wrote :

Are you having any luck w/ 8.10 beta on this affected hardware?

Changed in zd1211:
status: New → Incomplete

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Changed in zd1211 (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers