build zaptel against kernel 2.6.28

Bug #353024 reported by steppenwolfe3 on 2009-04-01
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
zaptel (Debian)
Fix Released
Unknown
zaptel (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Ian McMichael

Bug Description

Binary package hint: zaptel-source

i tried to build the zaptel-source package against the 2.6.28 kernel from Jaunty!
But during the build process, the following error occured:
  CC [M] /usr/src/modules/zaptel/kernel/ztdummy.o
/usr/src/modules/zaptel/kernel/ztdummy.c: In function 'ztdummy_hr_int':
/usr/src/modules/zaptel/kernel/ztdummy.c:203: error: 'struct hrtimer'
has no member named 'expires'
make[4]: *** [/usr/src/modules/zaptel/kernel/ztdummy.o] Error 1

I managed to fix this problem, by editing the code of ztdummy.c as you can see here:
http://svn.debian.org/viewsvn/*checkout*/pkg-voip/zaptel/trunk/debian/patches/hrtimer_2628?rev=6683

after this i generated a tarball and started the compilation process and it worked!
It would be very nice, if the modified code would be inserted into the package.

mfg steppenwolfe3

Related branches

steppenwolfe3 (patrick-praher) wrote :
Changed in zaptel (Debian):
status: Unknown → Fix Committed
Tobias Richter (tsr-ubuntu) wrote :

Yes, please update with the fix! Nasty regression.

Changed in zaptel (Ubuntu):
status: New → Confirmed
Darik Horn (dajhorn) wrote :

I've tried the patch, confirmed that it works on Jaunty i386 and Jaunty amd64 with Asterisk, and uploaded a fixed package to my PPA at: https://launchpad.net/~dajhorn/+archive/ppa

Ryan Tucker (rtucker) wrote :

I can reproduce the original bug on my freshly-installed 9.04 with 2.6.28-14-server kernel, and I can also confirm that the debs from Darik's PPA resolve the issue.

I can also reproduce the original bug on a (reasonably) fresh 9.04 with 2.6.28-14-desktop kernel, and I can confirm that the debs from Darik's PPA resolved the issue for me. Thanks, Darik! Now I can get on with the fun part.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zaptel - 1:1.4.11~dfsg-3ubuntu2

---------------
zaptel (1:1.4.11~dfsg-3ubuntu2) karmic; urgency=low

  * debian/patches/2.6.28_hrtimer_changes: New patch to fix compliation
    with kernels > 2.6.28. (LP: #353024)

 -- Steve Kowalik <email address hidden> Fri, 07 Aug 2009 21:38:56 +0100

Changed in zaptel (Ubuntu):
status: Confirmed → Fix Released
Ian McMichael (ian-sigma-uk) wrote :

I've just pulled the zaptel package from the repositories in Jaunty and received 1:1.4.11~dfsg-3ubuntu1. This refuses to build because of the issue reported in this bug on the current 2.6.28-17-server kernel. After applying the patch from http://svn.debian.org/viewsvn/*checkout*/pkg-voip/zaptel/trunk/debian/patches/hrtimer_2628?rev=6683 manually everything is fine.

Is there any chance of getting this patch applied to the Jaunty (and possibly Hardy) packages?

Changed in zaptel (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.