Upgrade from 1.8 on 12.04 to 2.2.2 on 14.04 is faulty

Bug #1367865 reported by Mark Thornton on 2014-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zabbix (Ubuntu)
Undecided
Unassigned

Bug Description

First the apache.conf file is linked into /etc/apache2/conf.d which is useless. It needs to be in /etc/apache2/sites-available and /etc/apache2/sites-enabled

Second the configuration wizard does not accept a postgres password properly - supplying the correct details results in an invalid password being reported by postgres. I overcame this by getting the example zabbix.conf.php file and filling in the details using an editor.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: zabbix-frontend-php 1:2.2.2+dfsg-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-35.62-generic 3.13.11.6
Uname: Linux 3.13.0-35-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
Date: Wed Sep 10 19:21:11 2014
InstallationDate: Installed on 2012-04-27 (866 days ago)
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Release amd64 (20120424.1)
PackageArchitecture: all
SourcePackage: zabbix
UpgradeStatus: Upgraded to trusty on 2014-09-10 (0 days ago)

Mark Thornton (mthornton-2) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers