Zabbix 2.0.6 PHP mysql_connect() deprecated warning

Bug #1239782 reported by Nick on 2013-10-14
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
WordPress
New
Undecided
Unassigned
zabbix (Ubuntu)
Undecided
Unassigned

Bug Description

On Ubuntu 13.10 RC, running Zabbix server. The PHP frontend gives the following warning all over the Web GUI:
mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead

It looks like this is an issue with PHP5.5 and the code used in Zabbix frontend. From Zabbix's bugtracker this has been fixed in Zabbix 2.1.4, which I believe is their testing release before 2.2.

Not sure what can be done before 2.2 comes out, but right now it makes the Web UI look like there are errors everywhere (even though it does function OK).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zabbix (Ubuntu):
status: New → Confirmed
Andreas Fischer (bantu) on 2013-10-17
summary: - Zabbix 2.0.6 PHP mysql_connect() depricated warning
+ Zabbix 2.0.6 PHP mysql_connect() deprecated warning
James (morris-570) wrote :

I have this problem to.

WORKAROUND:

Download zabbix-2.0.9 source from their website and replace the contents of zabbix-2.0.9/frontend/php/ into /usr/share/zabbix/ (rename the old zabbix to zabbixold). Then log into the web interface. It will have you go through all the config again, it will generate a zabbix.conf.php file for you to copy into this directiory, but once a connection is established to the databse it should restore your frontend without the error.

Sean Monroe (seanamonroe) wrote :

After upgrading to 13.10 the Zabbix UI is broken, so I'd say this is a relatively major issue.

Nick (kg6nmp) wrote :

After further review it appears no graphs are displaying and historical data is impossible to review. The web frontend is much more broken than just a warning being displayed.

neutrico (neutrico) wrote :

This affects also WordPress frontend.

Philipp Noack (philipp-noack-b) wrote :

I followed James' instruction to get the zabbix webinterface up again.

This absolutely is a major issue!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers