zabbix-agent upstart script incorrect daemonization

Bug #1103720 reported by Nathan Bird on 2013-01-23
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
zabbix (Ubuntu)
Undecided
Unassigned

Bug Description

The upstart init script packaged with zabbix-agent (1:2.0.3+dfsg-1~exp0ubuntu1) doesn't track it's daemonization correctly and leaves a non-functioning init script.

It's using Zabbix-agent(1:2.0.3+dfsg-1~exp0ubuntu1) from raring and upstart(1.5-0ubuntu9) from quantal so there is a chance that the two aren't happy together. I suspect that's not it.

Behavior:
sudo status zabbix-agent
zabbix-agent start/running, process 955

None of the zabbix processes have that pid, /var/run/zabbix/zabbix_agentd.pid is 982.

sudo stop zabbix-agent
<hangs forever, expected it to stop>

sudo reload zabbix-agent
reload: No such process

This causes problems for logrotate scripts too.

Nathan Bird (ecthellion) wrote :

It looks like this is upstream bug https://support.zabbix.com/browse/ZBX-5234

Changed in zabbix (Ubuntu):
status: New → Invalid

The bug is valid.
It was introduced with conversion with conversion to upstart job.
https://bugs.launchpad.net/ubuntu/+source/zabbix/+bug/1047837

I suggest to go back to SysVInit until the issue is fixed

Changed in zabbix (Ubuntu):
status: Invalid → Confirmed
Andrey Ivanov (andrey-v-ivanov) wrote :

It seems solved in zabbix agent 2.2

Indeed, solved with the version in 14.04. Caused trouble during the upgrade form 13.10 though, of course, because the shutdown did not work correctly. Had to kill it during the upgrade, but that was all. Now it comes up correctly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers