r3c.zml: depends on python-pypdf, which is removed and superseded by python-pypdf2

Bug #1665464 reported by Steve Langasek on 2017-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
z3c.rml (Ubuntu)
Undecided
Unassigned

Bug Description

The z3c.rml package depends on the PyPdf module, provided by the python-pypdf package. This package is obsolete and removed from Debian unstable; and I've also just removed it from zesty. This makes python-z3c.rml uninstallable.

I was going to fix z3c.rml up thinking it would be a quick fix, but:

 - the module name has changed, someone will need to check that s/PyPdf/PyPdf2/ is enough to let the code work.
 - z3c.rml relies on van.pydeb for generating its binary dependency list, so that would also need updated to know about PyPdf2.

You could also just hard-code the dependency in debian/control instead of relying on van.pydeb's behavior.

This is an Ubuntu-specific package that hasn't been updated in 4 years, so it's possible it should be removed rather than being fixed. But it's used by schooltool, so someone would need to look at that first.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers