Cannot launch yubioath - throws Python ImportError

Bug #1586751 reported by Schlomo Schapiro on 2016-05-29
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
yubioath-desktop (Ubuntu)
Medium
Unassigned
Xenial
Medium
Hans Joachim Desserud

Bug Description

SRU:
[Impact]
The program lacks neccessary dependencies in order to start.
The SRU adss these dependencies.

[Test case]
1. Install yubioath-desktop
2. (Verify that python-pkg-resources is installed)
3. Attempt to run yubioath from a terminal
With python-pkg-resources in place, the program should start as expected.
(Note that due to the nature of the program, it will almost immediately check for an USB key, which it won't find if none is inserted.)
4. Attempt to remove python-pkg-resources. Verify that this cannot be removed without also marking yubioath-desktop for removal.

[Regression potential]
Low. Dependencies are only added. These are the same ones used by newer versions of the package in for instance 17.04.

Original report:

Found on Ubuntu 16.04 Xenial Xerus amd64 running on Dell Latitude E6420

Launching yubioath does not start the application but aborts with the following error:

$ yubioath
Traceback (most recent call last):
  File "/usr/bin/yubioath", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources

I installed the package from universe:

$ apt show yubioath-desktop
Package: yubioath-desktop
Version: 2.3.0-1
Priority: optional
Section: universe/utils
Origin: Ubuntu
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian Authentication Maintainers <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 385 kB
Depends: libykpers-1-1 (>= 1.11), python-pyside.qtgui, python-pyside.qtnetwork, python (>= 2.7), python (<< 2.8), python-pyscard, python-crypto
Recommends: pcscd
Homepage: https://developers.yubico.com/yubioath-desktop/
Download-Size: 98,1 kB
APT-Manual-Installed: yes
APT-Sources: http://de.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
Description: Graphical interface for displaying OATH codes with a Yubikey
 The Yubico Authenticator is a graphical desktop tool for generating Open
 AuTHentication (OATH) event-based HOTP and time-based TOTP one-time password
 codes, with the help of a Yubikey that protects the shared secrets.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: yubioath-desktop 2.3.0-1
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun May 29 12:04:30 2016
InstallationDate: Installed on 2016-05-25 (3 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
SourcePackage: yubioath-desktop
UpgradeStatus: No upgrade log present (probably fresh install)

Schlomo Schapiro (sschapiro) wrote :
Schlomo Schapiro (sschapiro) wrote :

I was able to solve this problem by installing the python-setuptools package which was missing for python 2.7.

Please add this to the dependency

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in yubioath-desktop (Ubuntu):
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I (and the duplicate bug report) got the same error message when attempting to run the program without python-pkg-resources installed. Luckily, the version available in Ubuntu 17.04 and later have added the missing dependencies, see http://changelogs.ubuntu.com/changelogs/pool/universe/y/yubioath-desktop/yubioath-desktop_3.0.1-2/changelog (or compare https://packages.ubuntu.com/xenial/yubioath-desktop with the newer https://packages.ubuntu.com/zesty/yubioath-desktop).

It is therefore fixed in newer releases, however, since Ubuntu 16.04 is still affected I'm preparing an SRU. In the meantime, people may install the missing dependencies: pcscd, python-pkg-resources and python-click manually.

description: updated
Hans Joachim Desserud (hjd) wrote :

Attached debdiff for 16.04.

(To be frank I don't know why the two other dependencies have been added in newer package versions, but I assume it might be due to similar issues)

Changed in yubioath-desktop (Ubuntu):
status: Confirmed → Fix Released
Simon Quigley (tsimonq2) wrote :

Uploaded.

Changed in yubioath-desktop (Ubuntu Xenial):
importance: Undecided → Medium
Changed in yubioath-desktop (Ubuntu):
importance: Undecided → Medium
Changed in yubioath-desktop (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Hans Joachim Desserud (hjd)

Hello Schlomo, or anyone else affected,

Accepted yubioath-desktop into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/yubioath-desktop/2.3.0-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in yubioath-desktop (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Hans Joachim Desserud (hjd) wrote :

I've successfully verified the -proposed package on a 16.04 VM. While do not have an USB key so I'm a bit limited in my exploratory testing, the program starts without crashing and it is not possibly to remove the key dependencies without also removing yubioath-desktop.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yubioath-desktop - 2.3.0-1ubuntu0.1

---------------
yubioath-desktop (2.3.0-1ubuntu0.1) xenial; urgency=medium

  * Add missing dependencies (Fixes LP: #1586751)
  * Add dependency on python-pkg-resources, python-click and pcscd.
  * Drop recommends on pcscd.

 -- Hans Joachim Desserud <email address hidden> Wed, 20 Sep 2017 18:13:12 +0200

Changed in yubioath-desktop (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for yubioath-desktop has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers