The 'PySide' distribution was not found and is required by yubikey-piv-manager

Bug #1648772 reported by Hadmut Danisch on 2016-12-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yubikey-piv-manager (Debian)
Fix Released
Unknown
yubikey-piv-manager (Ubuntu)
High
Luke Faraone
Zesty
High
Luke Faraone

Bug Description

[Impact]

`pivman` crashes on start with a traceback.

[Test Case]

% pivman
Traceback (most recent call last):
  File "/usr/bin/pivman", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2976, in <module>
    @_call_aside
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2962, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2989, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 660, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 968, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 854, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'PySide' distribution was not found and is required by yubikey-piv-manager

[Regression Potential]

No reverse dependencies, software does not function at all at present.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: yubikey-piv-manager 1.3.0-1
ProcVersionSignature: Ubuntu 4.8.0-30.32-generic 4.8.6
Uname: Linux 4.8.0-30-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Dec 9 12:05:51 2016
InstallationDate: Installed on 2016-04-22 (230 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420)
PackageArchitecture: all
SourcePackage: yubikey-piv-manager
UpgradeStatus: Upgraded to yakkety on 2016-10-17 (53 days ago)

Hadmut Danisch (hadmut) wrote :
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I get a similar error message when attempting to start pivman. I also found a corresponding bug report in Debian, so I have attached a bug watch.

Changed in yubikey-piv-manager (Ubuntu):
status: New → Confirmed
tags: added: zesty
Changed in yubikey-piv-manager (Debian):
status: Unknown → New
Luke Faraone (lfaraone) on 2017-05-17
Changed in yubikey-piv-manager (Ubuntu):
status: Confirmed → Triaged
Luke Faraone (lfaraone) on 2017-05-17
Changed in yubikey-piv-manager (Ubuntu Zesty):
status: New → In Progress
assignee: nobody → Luke Faraone (lfaraone)
Changed in yubikey-piv-manager (Ubuntu):
importance: Undecided → High
Changed in yubikey-piv-manager (Ubuntu Zesty):
importance: Undecided → High
Changed in yubikey-piv-manager (Ubuntu):
assignee: nobody → Luke Faraone (lfaraone)
Changed in yubikey-piv-manager (Debian):
status: New → Fix Committed
Changed in yubikey-piv-manager (Debian):
status: Fix Committed → Fix Released
Luke Faraone (lfaraone) on 2017-05-30
description: updated

Hello Hadmut, or anyone else affected,

Accepted yubikey-piv-manager into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/yubikey-piv-manager/1.3.0-1+ubuntu17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in yubikey-piv-manager (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty

The fix for this bug has been awaiting testing feedback in the -proposed repository for zesty for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Hans Joachim Desserud (hjd) wrote :

I've tested this on an up-to-date Ubuntu 17.04 vm now. After installing 1.3.0-1+ubuntu17.04.1 from -proposed, I no longer see the error message when attempting to start `pivman`. I don't have a yubikey so it is a bit limited how much I can verify, but the program seems to run as expected and I haven't seen any crashes.

tags: added: verification-done verification-done-zesty
removed: removal-candidate verification-needed verification-needed-zesty yakkety
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yubikey-piv-manager - 1.3.0-1+ubuntu17.04.1

---------------
yubikey-piv-manager (1.3.0-1+ubuntu17.04.1) zesty-proposed; urgency=high

  * Re-add PySide patch.
  * Remove requires.txt requiring PySide (Closes: #847493; LP: #1648772)

 -- Luke Faraone <email address hidden> Tue, 30 May 2017 16:04:59 -0700

Changed in yubikey-piv-manager (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for yubikey-piv-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hans Joachim Desserud (hjd) wrote :

Thanks :)

Also marking it fixed in artful, since it has worked there for quite some time.

Changed in yubikey-piv-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.