The 'PySide' distribution was not found and is required by yubikey-piv-manager

Bug #1648772 reported by Hadmut Danisch on 2016-12-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yubikey-piv-manager (Debian)
Fix Released
Unknown
yubikey-piv-manager (Ubuntu)
High
Luke Faraone
Zesty
High
Luke Faraone

Bug Description

When starting pivman, I just get an error message:

% pivman
Traceback (most recent call last):
  File "/usr/bin/pivman", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2976, in <module>
    @_call_aside
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2962, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2989, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 660, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 968, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 854, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'PySide' distribution was not found and is required by yubikey-piv-manager

Missing dependency in package?

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: yubikey-piv-manager 1.3.0-1
ProcVersionSignature: Ubuntu 4.8.0-30.32-generic 4.8.6
Uname: Linux 4.8.0-30-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Dec 9 12:05:51 2016
InstallationDate: Installed on 2016-04-22 (230 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420)
PackageArchitecture: all
SourcePackage: yubikey-piv-manager
UpgradeStatus: Upgraded to yakkety on 2016-10-17 (53 days ago)

Hadmut Danisch (hadmut) wrote :
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I get a similar error message when attempting to start pivman. I also found a corresponding bug report in Debian, so I have attached a bug watch.

Changed in yubikey-piv-manager (Ubuntu):
status: New → Confirmed
tags: added: zesty
Changed in yubikey-piv-manager (Debian):
status: Unknown → New
Luke Faraone (lfaraone) on 2017-05-17
Changed in yubikey-piv-manager (Ubuntu):
status: Confirmed → Triaged
Luke Faraone (lfaraone) on 2017-05-17
Changed in yubikey-piv-manager (Ubuntu Zesty):
status: New → In Progress
assignee: nobody → Luke Faraone (lfaraone)
Changed in yubikey-piv-manager (Ubuntu):
importance: Undecided → High
Changed in yubikey-piv-manager (Ubuntu Zesty):
importance: Undecided → High
Changed in yubikey-piv-manager (Ubuntu):
assignee: nobody → Luke Faraone (lfaraone)
Changed in yubikey-piv-manager (Debian):
status: New → Fix Committed
Changed in yubikey-piv-manager (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.