yubikey login segfaults /bin/login

Bug #1525105 reported by Petter Adsen
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yubico-pam (Ubuntu)

Bug Description

I received a Yubikey 4 yesterday, and attempted to set up authentication with it on my Wily system. After installing the necessary packages, I ran 'dpkg-reconfigure libpam-yubico' and added my ID number and key. When I now try to log in on a VC, I first enter my username, then I get prompted for my Yubikey. I press the button on the key and immediately get thrown back to a VC with a login prompt and the following message in the log:

[1805628.239225] login[29456]: segfault at 0 ip 00007f16bcb0030f sp 00007f16b1d0a540 error 4 in libc-2.21.so[7f16bca84000+1c0000]

Logins via SSH work, however; I get prompted for the Yubikey, press the button, enter password at the next prompt and I'm logged in. It seems authentication methods that do not open a network connection work, since if I edit /etc/pam.d/common-auth to use challenge-response authentication instead it works fine. The problem is that this will not work with a remote SSH connection as it requires hardware access.

(I tried upgrading to the packages in ppa:yubico/stable, but there was no difference - /bin/login still segfaults. I reverted to the original Wily packages and tried again before filing this bug.)

  Installed: 2.19-1

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: libpam-yubico 2.19-1
ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
Uname: Linux 4.2.0-18-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Dec 11 08:27:52 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-07-16 (147 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422.1)
SourcePackage: yubico-pam
UpgradeStatus: Upgraded to wily on 2015-10-20 (51 days ago)

Revision history for this message
Petter Adsen (ducasse) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers