ytnef missing package dependency

Bug #292696 reported by Samuel Atlan
14
Affects Status Importance Assigned to Milestone
ytnef (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: ytnef

The ytnef-filter script in the ytnef package uses 'file' to deduct the type of the attachments. The dependency list in ytnef does not list the 'file' package.

ytnef-filter reads from stdin a MIME email and print out a new MIME formatted email with TNEF attachments decoded. The attachments should have a proper Content-Type field. However, when 'file' is missing, ytnef-filter will also output an error message and all attachments will end up 'application/binary'.

Checking in the online package repository, it seems that all ubuntu releases so far are missing the dependency.

$ lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

$ sudo aptitude show ytnef
[...snip...]
Depends: libc6 (>= 2.3.4-1), libytnef0
[...snip...]

$ sudo apt-cache policy ytnef
ytnef:
  Installed: 2.6-1
  Candidate: 2.6-1
  Version table:
 *** 2.6-1 0
        500 http://archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status

$ less /usr/bin/ytnef-filter | grep "\`file"
                        $filetype = `file -bi $qfile`;

Revision history for this message
Alessio Treglia (quadrispro) wrote :

I'm working on it.

Changed in ytnef:
assignee: nobody → quadrispro
status: New → In Progress
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Fix for intrepid.

Requested SRU.

Changed in ytnef:
assignee: quadrispro → nobody
status: In Progress → Confirmed
Revision history for this message
Devid Antonio Filoni (d.filoni) wrote :

motu-sru ACK.

Revision history for this message
Alessio Treglia (quadrispro) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ytnef - 2.6-1ubuntu1

---------------
ytnef (2.6-1ubuntu1) jaunty; urgency=low

  * Depends on file (LP: #292696).

 -- Stefan Ebner <email address hidden> Tue, 16 Dez 2008 14:39:05 +0100

Changed in ytnef:
status: Confirmed → Fix Released
Revision history for this message
Stefan Ebner (sebner) wrote :

I uploaded the fix for jaunty.

Revision history for this message
Alessio Treglia (quadrispro) wrote :

fix for dapper

Revision history for this message
Alessio Treglia (quadrispro) wrote :

fix for gutsy

Revision history for this message
Devid Antonio Filoni (d.filoni) wrote :

motu-sru ACK for all debdiff.

Changed in ytnef:
status: New → Confirmed
status: New → Confirmed
status: New → Confirmed
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ytnef:
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

gutsy is going EOL in two months, and this is not a critical fix, thus we won't fix that in gutsy.

Changed in ytnef:
status: Confirmed → Won't Fix
Revision history for this message
Alessio Treglia (quadrispro) wrote :

ytnef (2.6-1) intrepid: doesn't depend on file
ytnef (2.6-1ubuntu0.1) intrepid: depends correctly on file

Revision history for this message
Alessio Treglia (quadrispro) wrote :

s/ytnef (2.6-1ubuntu0.1) intrepid/ytnef (2.6-1ubuntu0.1) intrepid-proposed

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ytnef - 2.6-1ubuntu0.1

---------------
ytnef (2.6-1ubuntu0.1) intrepid-proposed; urgency=low

  * Depends on file (LP: #292696).

 -- Alessio Treglia <email address hidden> Mon, 03 Nov 2008 10:19:05 +0100

Changed in ytnef:
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ytnef:
status: Confirmed → Fix Committed
Revision history for this message
Paul Elliott (omahn) wrote :

ytnef in hardy-proposed confirmed as fixed.

In 2.6-1 from hardy, ytnef does not have 'file' as a dependency. In 2.6-1ubuntu0.0.8.04 from hardy-proposed, it does have the file dependency and installs without issue.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ytnef - 2.6-1ubuntu0.0.8.04

---------------
ytnef (2.6-1ubuntu0.0.8.04) hardy-proposed; urgency=low

  * Depends on file (LP: #292696).

 -- Alessio Treglia <email address hidden> Mon, 15 Dec 2008 09:45:57 +0100

Changed in ytnef (Ubuntu Hardy):
status: Fix Committed → Fix Released
Revision history for this message
JC Hulce (soaringsky) wrote :

Thank you for reporting this bug to Ubuntu. The version of Ubuntu referenced in this issue has reached end of life, and the issue is fixed in newer versions of Ubuntu. Therefore, I am closing the Dapper task.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

Changed in ytnef (Ubuntu Dapper):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers