Lucid and maverick version of Youtube-dl no longer work

Bug #671436 reported by Virgil Brummond
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Unassigned
youtube-dl (Debian)
Fix Released
Unknown
youtube-dl (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: youtube-dl

When trying to download videos ( with permission), all that happens is a list of all the quality version not being found. I downloaded the latest python script from the authors site and it successfully downloaded the videos. I think the version in Lucid is incompatible with some update to youtube.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: youtube-dl (not installed)
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic x86_64
Architecture: amd64
Date: Fri Nov 5 10:27:03 2010
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: youtube-dl

Revision history for this message
Rogério Theodoro de Brito (rbrito) wrote :

Hi there.

I can't even remember the version that comes with lucid (and the bug report apparently doesn't contain the version of the package).

Anyway, my recommended answer in this case is to just go grab the versions that I upload to Debian sid, as they are usually released only two or three days at most after upstream releases something and it is not unusual for me to include some patches that may happen to be in future versions.

That being said, I don't know which procedures I should follow to sync my packages in Debian with the ones in Ubuntu. If anybody could educate me, that would be great, as I have some other packages that are in need of a refresh.

Failing all that, I can try to keep an uploaded version of the packages on my PPA, if that's OK with you guys.

Regards, Rogério Brito.

tags: added: needs-packaging
Revision history for this message
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Lucid version of Youtube-dl no longer works
+ [needs-packaging] Lucid version of Youtube-dl no longer works
Changed in youtube-dl (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Virgil Brummond (uraharakisuke153) wrote : Re: [needs-packaging] Lucid version of Youtube-dl no longer works

Version of youtube-dl is 2010.04.04-1

tags: removed: needs-packaging
summary: - [needs-packaging] Lucid version of Youtube-dl no longer works
+ Lucid version of Youtube-dl no longer works
Revision history for this message
Rolf Leggewie (r0lf) wrote : Re: Lucid version of Youtube-dl no longer works

Judging from the Debian changelog I suppose that the Maverick version would be affected as well. Upstream has committed a fix in https://github.com/rg3/youtube-dl/commit/d157d2597a5fe99db60304fe1e89523de78b7981 which landed in Debian in youtube-dl/2010.12.09-1. I'll see if that patch can be applied to Lucid and Maverick and if it fixes the issue at hand.

Changed in youtube-dl (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
importance: Wishlist → High
status: New → In Progress
Rolf Leggewie (r0lf)
summary: - Lucid version of Youtube-dl no longer works
+ Lucid and maverick version of Youtube-dl no longer work
Revision history for this message
Rolf Leggewie (r0lf) wrote :

for what it's worth, the patch does not apply cleanly to lucid or maverick sources. And it does not seem to be an immediately straight-forward port for lucid, either. The patch can probably be tweaked easily enough for maverick, though.

good night

Changed in youtube-dl (Debian):
status: Unknown → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

I run lucid, not maverick. Here's what I did for maverick.

1) run the maverick package in lucid and confirm the problem exists in that package as well
2) recompile the maverick package with the attached debdiff

but it looks like other code was added surrounding that change which is not yet part of the maverick package. The package patched with the attached debdiff fails in the following manner:

$ youtube-dl http://www.youtube.com/watch?v=AWpsOqh8q0M
  File "/usr/bin/youtube-dl", line 909
    video_url_list = [(existing_formats[0], url_map[existing_formats[0])] # Best quality
                                                                       ^
SyntaxError: invalid syntax

tags: added: maverick
Revision history for this message
Rolf Leggewie (r0lf) wrote :

I've taken it about as far as I can. Unassigning myself.

I've recompiled the natty package for lucid for me and can confirm that the problem is not present any longer. As a workaround, I've published that package in my "Stable" PPA for others who are looking for a fix for lucid (or maverick, the package should run in that release without any issues as well).

Changed in youtube-dl (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
status: In Progress → Triaged
Revision history for this message
Rogério Theodoro de Brito (rbrito) wrote :

Hi, Rolf.

As I mentioned many times, the very nature of youtube-dl (and similar packages, like clive, cclive, minitube etc.) make them very volatile. In other words, any such application will break and if we don't have a way to upload a new version, like I can easily do in Debian, we are subject to have broken, unusable packages in the distribution.

If we don't have a mechanism to provide speedy uploads, then we might as well stop distributing the software.

OTOH, I am willing to upload a copy of the package to Ubuntu whenever I upload a new version to Debian, to keep them in sync.

Regards, Rogério Brito.

Changed in youtube-dl (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Rolf Leggewie (r0lf) wrote :

Rogério, thank you for your comment. I understand your frustration. But as it is, Ubuntu currently does not have the equivalent of Debian volatile. At least I'm not aware of it. As you've seen, it was easy enough to fix for myself. But the situation remains as it is and I think that currently there is no way around an SRU (https://wiki.ubuntu.com/StableReleaseUpdates) to get a fix into the official repos. As I mentioned, it's not as straightforward to extract a minimal patch as I had hoped, so the software as shipped is bound to remain broken in the meantime. FWIW, the software shipping in the next release works fine (for the moment ;-))

Changed in youtube-dl (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Michael Terry (mterry) wrote :

Since 2010.12.09-1 is in natty, marking this Fix Released. If an SRU is filed, please open a release-targeted subtask.

Changed in youtube-dl (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

Michael, strictly speaking you are right. This ticket does not affect Natty. But look at the title, this ticket has been about Maverick and Lucid all along.

Reopening the task to make sure it stays on the radar. Series nominations fall through the cracks.

Changed in youtube-dl (Ubuntu):
status: Fix Released → Triaged
Loïc Minier (lool)
Changed in youtube-dl (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Rogério Theodoro de Brito (rbrito) wrote : Re: [Bug 671436] Re: Lucid and maverick version of Youtube-dl no longer work

Hi there.

On Jan 10 2011, Rolf Leggewie wrote:
> As a workaround, I've published that package in my "Stable" PPA for others
> who are looking for a fix for lucid (or maverick, the package should run
> in that release without any issues as well).

Just for the record, I created a new PPA for keeping a fresh version of
youtube-dl available to Ubuntu users. I will keep it in sync with the
version in Debian's unstable.

    https://launchpad.net/~rbrito/+archive/youtube-dl

Besides all the goodies in the new version released this week, I also
updated the documentation.

Hope this helps,

--
Rogério Brito : rbrito@{ime.usp.br,gmail.com} : GPG key 4096R/BCFCAAAA
http://rb.doesntexist.org : Packages for LaTeX : algorithms.berlios.de
DebianQA: http://qa.debian.org/developer.php?login=rbrito%40ime.usp.br

Revision history for this message
Virgil Brummond (uraharakisuke153) wrote :

Excellent, thanks! :)

Revision history for this message
Micah Gersten (micahg) wrote :

Since this will be fixed in the main archive, I'm marking the backports task invalid.

Changed in lucid-backports:
status: New → Invalid
Revision history for this message
Rolf Leggewie (r0lf) wrote :

Oh, will it? I'm not seeing much activity, just everybody closing tasks left and right, but no real fixes. That's pretty frustrating.

Rolf Leggewie (r0lf)
Changed in youtube-dl (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
Changed in youtube-dl (Ubuntu Maverick):
status: New → Triaged
Adolfo Jayme (fitojb)
Changed in youtube-dl (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in youtube-dl (Ubuntu Maverick):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.