Sync youtube-dl 2010.04.04-1 (universe) from Debian unstable (main)

Bug #562272 reported by Stefano Rivera
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
youtube-dl (Ubuntu)
Undecided
Unassigned

Bug Description

Please sync youtube-dl 2010.04.04-1 (universe) from Debian unstable (main)

The youtube-dl currently shipping in Ubuntu can't handle a recent YouTube
redesign, and is so essentially useless. Without this sync, there's no point
shipping the package at all.
The sync will fix LP: #485442, #555002

This version will hit testing in a day or so, and the Debian Maintainer for it believes it's the best version for lucid (see comments).

Upstream doesn't ship a changelog.

Changelog entries since current lucid version 2009.09.13-2:

youtube-dl (2010.04.04-1) unstable; urgency=low

  * New upstream release:
    + allow grabbing videos from vevo.
    + allow download whole playlists and keep the videos numbered.
    + add support for new playlist style.
    + fix detection of multipage playlists.
    + insist a little bit more to grab videos from youtube.
    + add information extractor for video.yahoo.com.
    + fix cosmetic issues with rtmpdump.
    + add option --all-formats to grab all available formats for a given video.
    + add "-" (without quotes) as an alias to output videos to stdout.

 -- Rogério Brito <email address hidden> Sun, 04 Apr 2010 17:55:00 -0300

youtube-dl (2010.03.13-1) unstable; urgency=low

  * New upstream release
    + added option to disable the status/progress updates.
    + fine tuned the sequence of formats searched to discover the best quality.

 -- Rogério Brito <email address hidden> Sun, 14 Mar 2010 23:33:48 -0300

youtube-dl (2010.02.13-1) unstable; urgency=low

  * New upstream release
    + stronger parsing of URLs.
    + better generation of filenames.
  * debian/control:
    + include misc-depends due to debhelper.
    + the package is compliant with policy 3.8.4.

 -- Rogério Brito <email address hidden> Wed, 17 Feb 2010 00:19:23 -0200

youtube-dl (2010.01.19-1) unstable; urgency=low

  * New upstream release. As upstream does not provide a changelog, here
    are the highlights:
    + patched to add Google Video and Photobucket support
    + add support for using rtmpdump
    + added support to download all of a user's videos!
    + fix detection of uploader nickname in metacafe
    + take format 37 into account
    + add self-updating code
    + allow empty titles because they do appear in some videos
    + use default values for "continuedl" and "nooverwrites" parameters
    + avoid using Unicode strings when forming URL requests
    + improve preferred encoding detection method
  * Remove all patches (applied upstream).
  * Add suggests on rtmpdump.
  * Shorten the short description.
  * Include list of sites supported in the long description.

 -- Rogério Brito <email address hidden> Tue, 26 Jan 2010 11:28:40 -0200

Revision history for this message
Stefano Rivera (stefanor) wrote :

Appears to work as expected:

$ youtube-dl -b 'http://www.youtube.com/watch?v=nFicqklGuB0&feature=player_embedded'
[youtube] Setting language
[youtube] nFicqklGuB0: Downloading video info webpage
[youtube] nFicqklGuB0: Extracting video information
[download] Destination: nFicqklGuB0.mp4
[download] 18.7% of 85.78M at 7.28M/s ETA 00:09

Revision history for this message
StefanPotyra (sistpoty) wrote :

Yes, makes sense, thanks. FFe granted, please go ahead.

Changed in youtube-dl (Ubuntu):
status: New → Confirmed
Revision history for this message
Rogério Theodoro de Brito (rbrito) wrote :

Hi, Stefan and Stefano.

The request to sync with my package in Debian got so old that, in the mean time, I had already uploaded a newer version. It will even, in 2 days, enter testing.

Could you please consider uploading the newer version?

Regards, Rogério.

Revision history for this message
Rogério Theodoro de Brito (rbrito) wrote :

Hi again,

Just an off-topic comment here, since we are already syncing things from Debian: there are two nasty segfaults that I fixed and which are already in upstream repositories.

One of those is in fontforge (with a newer release already in the new version on Debian) which has already migrated to testing.

http://packages.debian.org/changelogs/pool/main/f/fontforge/current/changelog

Another one is an extremely important bugfix to libspectre. The bug makes evince and the nautilus thumbnailer (among others) unuseable in big-endian platforms. The fix is already commited in libspectre's upstream repository (and the patch is already here in launchpad).

Regards,

Revision history for this message
Benjamin Drung (bdrung) wrote :

You need a FFe again. Please update the title and description accordingly.

Changed in youtube-dl (Ubuntu):
status: Confirmed → New
Revision history for this message
Stefano Rivera (stefanor) wrote :

> Just an off-topic comment here, since we are already syncing things from Debian:
> there are two nasty segfaults that I fixed and which are already in upstream repositories.

Yes, that's off topic. You'll need to file separate sync requests:

https://wiki.ubuntu.com/SyncRequestProcess
https://wiki.ubuntu.com/FreezeExceptionProcess

You can use requestsync to generate the syncrequest, and you must justify it to obtain the FFe.

summary: - Sync youtube-dl 2010.03.13-1 (universe) from Debian testing (main)
+ Sync youtube-dl 2010.04.04-1 (universe) from Debian unstable (main)
description: updated
Revision history for this message
Stefano Rivera (stefanor) wrote :
Revision history for this message
Stefano Rivera (stefanor) wrote :
Revision history for this message
Stefano Rivera (stefanor) wrote :
Revision history for this message
StefanPotyra (sistpoty) wrote :

2010.04.04-1 is fine for me as well.

Changed in youtube-dl (Ubuntu):
status: New → Confirmed
Revision history for this message
Benjamin Drung (bdrung) wrote :

package builds, sync request ACK'd

Revision history for this message
Rogério Theodoro de Brito (rbrito) wrote : Re: [Bug 562272] Re: Sync youtube-dl 2010.03.13-1 (universe) from Debian testing (main)

Hi there.

On Wed, Apr 14, 2010 at 04:59, Stefano Rivera <email address hidden> wrote:
> Yes, that's off topic. You'll need to file separate sync requests:
>
> https://wiki.ubuntu.com/SyncRequestProcess
> https://wiki.ubuntu.com/FreezeExceptionProcess

This is quite bureacratic, but I tried to follow the process. It
doesn't make the bugs any less important if I did not follow the
protocol correct, though. :-)

Help is HIGHLY appreciated (that's why I am asking here---I only want
help, nothing else). I want to have a LTS release that won't be a
nightmare to use and to maintain for the next few semesters.

If I did something incorrectly, please advise. Here are the other bugs:

https://bugs.edge.launchpad.net/ubuntu/+source/libspectre/+bug/298139
https://bugs.edge.launchpad.net/ubuntu/+source/fontforge/+bug/563052

Thanks, Rogério Brito.

--
Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8
http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org

Revision history for this message
Benjamin Drung (bdrung) wrote :

Stefan Potyra granted the FFe. Just wait, a archive admin will do the sync.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Martin already took bug #298139, I've subscribed ubuntu-sponsors to bug #563052, which is only bug fix and doesn't need an FFe. If nobody will take it in the mean time, I'll get to it, but not before Friday.

Btw., thanks for the patches of both, that's greatly appreciated!

Revision history for this message
Steve Langasek (vorlon) wrote :

e Getting binaries for lucid...
[Updating] youtube-dl (2009.09.13-2 [Ubuntu] < 2010.04.04-1 [Debian])
 * Trying to add youtube-dl...
2010-04-18 06:18:23 INFO - <youtube-dl_2010.04.04.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-18 06:18:23 INFO - <youtube-dl_2010.04.04-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-18 06:18:23 INFO - <youtube-dl_2010.04.04-1.dsc: downloading from http://ftp.debian.org/debian/>
I: youtube-dl [universe] -> youtube-dl_2009.09.13-2 [universe].

Changed in youtube-dl (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers