[needs-packaging] Yo Frankie!

Bug #311938 reported by kernel_script on 2008-12-28
134
This bug affects 17 people
Affects Status Importance Assigned to Milestone
GetDeb Software Portal
Undecided
Unassigned
Playdeb
Undecided
Unassigned
Debian
New
Unknown
yofrankie (Ubuntu)
Wishlist
Unassigned
Declined for Hardy by Andrew Starr-Bochicchio
Declined for Intrepid by Andrew Starr-Bochicchio
Declined for Jaunty by Andrew Starr-Bochicchio
Declined for Karmic by Andrew Starr-Bochicchio

Bug Description

Yo Frankie! is a 3D current generation platform game.

URL: http://www.yofrankie.org/
License: Creative Commons Attribution license 3.0
Notes: The project delayed and was released early December 2008.

Source: https://svn.blender.org/svnroot/yofrankie
Issues: No licence headers or COPYING file included in source.

Related branches

description: updated
description: updated
description: updated
description: updated
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Martin Olsson (mnemo) wrote :

I just wanted to say that I also wanted to have this in Ubuntu. Because the entire game has been constructed entirely using free tools and free contents, it's a nice talking point when promoting free software.

Robert Schuster (thebohemian) wrote :

I want to see this game in Debian, then it can be moved into Ubuntu just easily.

I created a cofundos.org project to get this done. This means I am willing to throw money at the problem. You can join the bidders and increase the amount of money the implementor gets or take the job. Its all to be found here:

http://cofundos.org/project.php?id=155

That is a great effort, but somewhat ironic :)

Jack Deslippe (jdeslip) wrote :

Anyone try the deb at getdeb: http://www.getdeb.net/release/4322

Kẏra (thekyriarchy) wrote :

This bug seems to be quite old even though there is a lot of interest in it. What is needed to help fix this?

Christoph Korn (c-korn) on 2009-06-15
Changed in getdeb.net:
status: New → Fix Released
Christoph Korn (c-korn) wrote :

The problem is that the game requires a more recent version of Blender than it is available in the Ubuntu repositories.

So we would have to release Blender in playdeb and it would be automatically updated when people use the playdeb repository.

We will release it in the karmic repository when the time has come.

Changed in playdeb:
status: New → Invalid
Kẏra (thekyriarchy) wrote :

What's needed to get this in debian/ubuntu?

ideasman42 (ideasman42) wrote :

It needs blender 2.49b, was released September 3rd, 2009

Kẏra (thekyriarchy) wrote :

Right, so since that's available, how can we get it packaged for Lucid?

Matthias Klumpp (ximion) wrote :

We need an Ubuntu Universe Developer (MOTU) to sponsor this.
Alternatively this package needs to be accepted in Debian and synced into Ubuntu Lucid repos.

Kẏra (thekyriarchy) wrote :

Ideally, i'd love to see it accepted in Debian first, but i don't know where to go to give it some attention. I brought it up on ubuntu-devel-discuss a while back...but that's for ubuntu

Matthias Klumpp (ximion) wrote :

Just look at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497859
I'm sure this package will go into Debian, because someone will pay money if it reaches at least Debian Experimental sources. :-P

Kẏra (thekyriarchy) wrote :

Yeah, i'm subscribed to that but but it was filed in Sep 2008 and hasn't had any activity lately =[

Robert Schuster (thebohemian) wrote :

Hi,
I *will* pay. :)

All the best,
Robert

Danny Piccirillo schrieb:
> Yeah, i'm subscribed to that but but it was filed in Sep 2008 and hasn't
> had any activity lately =[
>

Changed in ubuntu:
assignee: MOTU (motu) → nobody
description: updated
Dimitri John Ledkov (xnox) wrote :

Can we add this binary deb blob to multiverse? =)

Benjamin Drung (bdrung) wrote :

Last week I wrote a mail to upstream requesting a proper source tarball. This tarball must not contain generated binaries and must contain a license file, which contains copyright information about all contained packages. Once upstream provides such an tarball, we have a package in the archive in no time.

Emmet Hikory (persia) wrote :

I've chatted with upstream on IRC about the licensing issue, and requested the following:

1) A verbatim copy of each license under which materials are distributed to be included in the tarball
2) For those files that cannot represent their license correctly internally (mostly .blend files), that the license under which they are distributed be described somewhere else in the upstream tarball (COPYING, LICENSE, README, or somewhere)
3) That the licenses not all be conflated into a single COPYING file which requires detailed review to determine if any of the licenses happen to match licenses in /usr/share/common-licenses/

ideasman42 (ideasman42) wrote :

@Benjamin Drung, YoFrankie contains no generated binaries or compilable code (all python and media files)

Would this file suffice?
http://apricot.blender.org/wp-content/uploads/COPYING

I could do some kind of ls -R on all the media files but not sure if this helps.

Benjamin Drung (bdrung) wrote :

This paragraph is not clear to me:
Excluded from the Creative Commons license is:
- the corporate/product logos on the website (including Blender logo,
Creative Commons logo) and associated trademarks

Does the source include any logos? Which logos are affected? Blender, Creative Commons, and?

Is the source code GPLv2 only or GPLv2+? In other words, are later versions of GPL allowed?

Benjamin Drung (bdrung) wrote :

I found these files missing in the COPYING file.

./textures/level_nut/raw/donotenter.svg
./textures/temp_river2.jpg
./textures/level_lighthouse/rusty_col.jpeg
./textures/level_lighthouse/doris_nor.jpeg
./textures/level_lighthouse/rusty_nor.jpeg

*.svg, *.jpg, *.jpeg should be added to the media list.

menus/yo_frankie.ttf

Is this font under the CC 3.0?

Makefile
dist/yofrankie-bge
dist/yofrankie-bge.desktop

Do these file fall under GPL or CC 3.0?

Benjamin Drung (bdrung) wrote :

Can you add the license header to all python files? You can find an example header here: http://www.gnu.org/licenses/gpl-2.0.html#SEC4

Changed in ubuntu:
assignee: nobody → Benjamin Drung (bdrung)
ideasman42 (ideasman42) wrote :

Benjamin, Ill have to double check but I think the blender logo is in the credits (as an image).

GPLv2 or greater, Ill clarify this also.

Ill include svg, jpeg's & ttf as media in the list.

Makefile is GPLv2, updated in our svn alredy.

- others - GPLv2 since its not media. where should this be listed? I didnt see GPL in *.desktop headers before.
dist/yofrankie-bge
dist/yofrankie-bge.desktop

Benjamin Drung (bdrung) wrote :

Mention the license for dist/yofrankie-bge and dist/yofrankie-bge.desktop in the COPYING file is enough. You can't add a license header to a *.desktop file.

BTW, can you use exec in the yofrankie-bge script:
#!/bin/sh
exec blenderplayer /usr/share/yofrankie-bge/levels/start_menu.blend

Benjamin Drung (bdrung) wrote :

Is the Yo Frankie logo excluded from the CC 3.0?

ideasman42 (ideasman42) wrote :

Hi Benjamin
Updated http://apricot.blender.org/wp-content/uploads/COPYING

- removed part about logos, no logos are included so this is not needed.
- included these as media - svg, jpeg, jpg, ttf
- use GPLv2 or greater.
- include files dist/yofrankie-bge dist/yofrankie-bge.desktop as GPLv2 or greater.
- use exec dist/yofrankie-bge as suggested.

Benjamin Drung (bdrung) wrote :

It looks good except that a verbatim copy of the CC 3.0 is missing.

You do not have to put everything in one file. You could put the verbatim copy of the CC 3.0 and GPL-2 into separate file. Then you would have a short COPYING, GPL-2, CC3.0 (or similar file names).

All python files should contain a license header [1]. For example the files in chars/frankie_scripts have none.

[1] http://www.gnu.org/licenses/gpl-2.0.html#SEC4

ideasman42 (ideasman42) wrote :

No worries, will batch GPL header all py scripts and split out the license text as you suggest.
will try do this tomorrow night.

ideasman42 (ideasman42) wrote :

Added these files to the root directory

http://apricot.blender.org/wp-content/uploads/COPYING
http://apricot.blender.org/wp-content/uploads/GPL-2
http://apricot.blender.org/wp-content/uploads/CC3.0

All python scripts now have GPL2 headers.

If theres no other issues I can bundle this up into an archive.

Benjamin Drung (bdrung) wrote :

You use an outdated FSF address. The last line of the GPL2 headers should be

Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.

The file GPL-2 has the wrong address, too.

Can you add a copyright line to the top of the GPL2 headers. It should look like:

Copyright (C) 2008-2010 Blender Foundation, www.blender.org

Benjamin Drung (bdrung) wrote :

The are different types of CC 3.0 licenses. Can you please make sure that CC-BY 3.0 is used a abbreviation instead of CC 3.0?

There is a space missing in the first line of COPYING (CommonsAttribution -> Commons Attribution).

ideasman42 (ideasman42) wrote :

Looks like its getting close.
renamed CC3.0 to CC-BY3.0
replaced GPL-2 with this file http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt

committed to svn r88

ideasman42 (ideasman42) wrote :

corrected every address in the GPL python headers (also did blender3d while I was at it :) )
http://markmail.org/message/4astbgxtvdj2t6lp

Kẏra (thekyriarchy) wrote :

Just wondering what the status of this was, thanks

Benjamin Drung (bdrung) wrote :

The status is that I uploaded a current SVN snapshot to Ubuntu just before the feature freeze. It is waiting in the NEW queue [1] for being accepted. Six days ago I wrote ideasman42 a mail requesting some improvements (Copyright line in each .py file, install target patch, man page, yofrankie VS yofrankie-bge name). Once these things are resolved, he has to release the tarball to an place, where it can be easily checked by a debian/watch file.

[1] https://launchpad.net/ubuntu/lucid/+queue

Benjamin Drung (bdrung) wrote :

yofrankie is now available in lucid.

Changed in ubuntu:
assignee: Benjamin Drung (bdrung) → nobody
affects: ubuntu → yofrankie (Ubuntu)
Changed in yofrankie (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
status: Confirmed → Fix Released
assignee: Benjamin Drung (bdrung) → nobody
Fred (eldmannen+launchpad) wrote :
Jack Leigh (leighman) wrote :

Anyone else who can't turn left whilst running?
I am on Karmic, but tried in Blender 2.49b

https://apricot.blender.org/yofrankie-11/#comment-93966
"The project is long finished. It may be updated in the future but as it stands the final product is a 2.49a-compatible game demo rough around all of its edges. Of course it’s open source as you know, so anyone can update this to make it compatible with 2.6 and fix any bugs."

It isn't maintained and seem to be deprecated with current versions of blender.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.