search not implemented

Bug #710901 reported by Brian Murray on 2011-01-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yelp (Ubuntu)
High
Rodrigo Moya
Natty
High
Rodrigo Moya

Bug Description

Binary package hint: yelp

It seems that search is not implemented in the reworking of yelp. I see the following in a terminal:

7:57:48 - flash:[...ents/canonical/launchpadlib] yelp
FIXME: search_activated

Not being able to search seems likely a serious regression in functionality to me.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: yelp 2.91.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
Architecture: amd64
CheckboxSubmission: fee5e196cb921cbd36888f428b38b488
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Mon Jan 31 12:48:59 2011
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/zsh
SourcePackage: yelp

Related branches

Brian Murray (brian-murray) wrote :
tags: added: regression-release
tags: added: mago
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I reproduced this in Xubuntu Natty Narwhal as follows:
yelp in the terminal opens "Desktop User Guide". Typing gedit in the search box does not do anything, but in the terminal I have "FIXME: search_activated".

Thanks for taking the time to make Ubuntu better!

Changed in yelp (Ubuntu):
importance: Undecided → High
status: New → Triaged
Martin Pitt (pitti) on 2011-02-25
Changed in yelp (Ubuntu Natty):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Rodrigo Moya (rodrigo-moya) wrote :

Is this with yelp 2.91.90? The code in git master does indeed include an implementation of the search, so maybe you're running an older version? (sorry, can't check it myself right now, as I can't upgrade yelp because of some broken packages)

Rodrigo Moya (rodrigo-moya) wrote :

oh, sorry, just saw you're running 2.91.10, so we need an upgrade it seems

Changed in yelp (Ubuntu Natty):
status: Triaged → In Progress
Rodrigo Moya (rodrigo-moya) wrote :

This is now in lp:~ubuntu-desktop/yelp/ubuntu, so will be uploaded by pitti soon

Changed in yelp (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yelp - 2.91.90-0ubuntu1

---------------
yelp (2.91.90-0ubuntu1) natty; urgency=low

  * New upstream release
    - Brings back searching. (LP: #710901)
  * debian/control:
    - Add build-depends on libsqlite3-dev
 -- Robert Ancell <email address hidden> Fri, 25 Feb 2011 16:13:37 +0100

Changed in yelp (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers