Missing dependency on xulrunner-1.9.1

Bug #527453 reported by Charlie Kravetz on 2010-02-24
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
yelp (Ubuntu)
High
Didier Roche

Bug Description

Binary package hint: xubuntu-docs

RELEASE: Lucid Lynx
CD/DVD VARIANT: Xubuntu 32bit and 64bit - Alternate and Desktop images
ISO BUILD: 2010-02-24

SYMPTOMS:
    Help is unavailable for any application that uses Yelp to display it. It simply fails without any error or other message.

STEPS TO REPRODUCE:

    1. Install Xubuntu Lucid
    2. Open Gnumeric, Synaptic Package Manager, or any other application that uses yelp to display Help.
    3. Click on Help -> Content
    4. Note it fails without error or warning. It just doesn't display anything.

Jim Campbell (jwcampbell) wrote :

This is an interesting problem, Charlie. Is yelp installed in prior releases, but is not installed by default in lucid, or did we just not notice this problem before?

We've marked this as a Xubuntu-docs problem, but I wouldn't see a solution to it unless we installed yelp by default. The Gnome-based applications (Gnumeric, Synaptic, etc.) all have docs that are just straight-up xml, thus they need yelp to be displayed.

I'll mark this as related to the seeds.

affects: xubuntu-docs (Ubuntu) → xubuntu-default-settings (Ubuntu)
Matthew East (mdke) wrote :

Is yelp really not installed? Applications which use yelp for their help really should depend on yelp so that it is installed whenever they are.

Charlie Kravetz (charlie-tca) wrote :

Yelp is installed when testing today on my installed lucid system, and help opens. Why it was not working remains a mystery. I will test the iso images again today to verify this is now working.

Charlie Kravetz (charlie-tca) wrote :

I can verify that yelp is installed in Xubuntu using image dated 2010-02-26, however, clicking on help does nothing.

Jim Campbell (jwcampbell) wrote :

On an updated 10.04 install of Ubuntu, yelp is opening from Gnumeric (I installed Gnumeric separately), and is displaying help, but I am getting crashes. Apport reports bugs similar to this one ( https://bugs.launchpad.net/ubuntu/+source/yelp/+bug/528169 ). Same error message.

Charlie, yelp can take a long time to load initially, even from a fairly powerful system. Maybe yelp doesn't work so well from a live-cd environment?

Lionel Le Folgoc (mrpouit) wrote :

Yeah, definitely a yelp issue (rr72 on #xubuntu-devel is experiencing crashes as well). Charlie, feel free to mark it as duplicate if you have the same error message when you have some time to retry.

affects: xubuntu-default-settings (Ubuntu) → yelp (Ubuntu)
Charlie Kravetz (charlie-tca) wrote :

Jim: Yelp does work in Ubuntu when opening Gnumeric. It does not work when you do a fresh install using Xubuntu.

I can not say if the bugs are duplicates, I do not get a crash. It fails silently. Even when waiting 5 minutes, I do not get any help to open in Xubuntu when using Gnumeric.

Charlie Kravetz (charlie-tca) wrote :

Fresh installation of Xubuntu using Alternate image - lucid-alternate-i386.iso dated 2010-02-26. This is installed on hardware with the specs: 1.5GHz P4 CPU; 1GB RAM; NVidia 6200 video card with 256MB onboard memory.

Gnumeric opened, click on Help -> Content. No response in 5 full minutes

jhtadmin@justhaveto:~$ date
Fri Feb 26 14:31:32 MST 2010
jhtadmin@justhaveto:~$ gnumeric
jhtadmin@justhaveto:~$ date
Fri Feb 26 14:37:13 MST 2010
jhtadmin@justhaveto:~$

There is no crash, there is no error message.

I am attaching dmesg, syslog, and ~/.xsession-error file

Installing Ubuntu and Gnumeric on this same system, help opens in about 1 minute.

Charlie Kravetz (charlie-tca) wrote :
Charlie Kravetz (charlie-tca) wrote :
Charlie Kravetz (charlie-tca) wrote :

jhtadmin@justhaveto:~$ apt-cache policy yelp
yelp:
  Installed: 2.29.5-0ubuntu1
  Candidate: 2.29.5-0ubuntu1
  Version table:
 *** 2.29.5-0ubuntu1 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

jhtadmin@justhaveto:~$ apt-cache policy gnumeric
gnumeric:
  Installed: 1.10.0-1ubuntu1
  Candidate: 1.10.0-1ubuntu1
  Version table:
 *** 1.10.0-1ubuntu1 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Lionel Le Folgoc (mrpouit) wrote :

yelp can't initialize gecko without xulrunner-1.9.1, and yelp doesn't depend on it (see with strace, it tries to open several files in /etc/gre.d, fails to find them, and abort).

summary: - [Lucid Xubuntu] No help is available in any application using Yelp
+ Missing dependency on xulrunner-1.9.1
Changed in yelp (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in yelp (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2010-03-01
Changed in yelp (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: Confirmed → In Progress
Didier Roche (didrocks) on 2010-03-01
Changed in yelp (Ubuntu):
assignee: Martin Pitt (pitti) → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yelp - 2.29.5-0ubuntu2

---------------
yelp (2.29.5-0ubuntu2) lucid; urgency=low

  * debian/control.in: Add missing xulrunner-1.9.1 binary dependency, to fix
    yelp on Xubuntu. (LP: #527453)
 -- Martin Pitt <email address hidden> Mon, 01 Mar 2010 20:59:07 +0100

Changed in yelp (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers