In Help, Table of Contents switches from left to right when user selects topic

Bug #507788 reported by Vish on 2010-01-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Yelp
Fix Released
Low
yelp (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: yelp

Currently, when the user selects a topic in the help documentation the TOC abruptly switches from being on the left side in the main page to the right side.

It would be ideal if the contents are maintained always on the left side. Would be easier for the user to orient.

Attaching screenshots
1 > Main page , TOC is on the left
2 > TOC is on the right. [in all contents]

ProblemType: Bug
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
Package: yelp 2.28.0+webkit-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: yelp
Tags: lucid
Uname: Linux 2.6.32-10-generic i686

Vish (vish) wrote :
Vish (vish) on 2010-01-15
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → lucid-round-10
status: New → Triaged
Vish (vish) on 2010-01-15
description: updated
Emmet Hikory (persia) on 2010-01-15
Changed in yelp (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Vish (vish) on 2010-01-15
description: updated
Vish (vish) wrote :

Matthew East suggested, we switch the main TOC to the right instead. As the topics on right was the standard in gnome else.

Keeping the contents on one side [any] would be ideal.

Vish (vish) wrote :
Matthew Paul Thomas (mpt) wrote :

I suggest that on all pages other than the front page, the table of contents not appear at all. That way the window can be smaller, more easily fitting alongside whatever you're wanting help with.

summary: - Help Documentation, TOC switches from left to right when user selects
+ In Help, Table of Contents switches from left to right when user selects
topic
Changed in yelp (Ubuntu):
status: Confirmed → Triaged
Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-10 → maverick-round-8-potpourri
Andrew (and471) wrote :

For anyone working on this, the relevant files are /usr/share/yelp/xslt/toc2html.xsl and /usr/share/yelp/toc.xml

It is just a bit of CSS that needs changing

Changed in yelp:
importance: Unknown → Low
status: Unknown → New
Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-8-potpourri → nt7-potpourri
Vish (vish) on 2010-11-26
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)

@mpt: if we do that, we'll lose the ability to jump from a topic to another ; a handy feature IMO. Do you think there could be an alternative to that?

Anyway, I need a final design suggestion, then I'll start working on this :)

Matthew Paul Thomas (mpt) wrote :

Users go to help for two reasons: (1) they're confused about something, or (2) they're trying to find something. <https://www.uie.com/articles/online_information/> In both cases, what they need is *one* particular page. Once they're done, they'll close the window.

If they end up in the wrong topic, that's probably a problem with bad information scent. <http://en.wikipedia.org/wiki/Information_foraging#Information_scent> If the help author foresees this problem but can't avoid it, they should include links at the bottom of that topic to the individual pages users may want instead. (For example, in Ubuntu Software Center's help, at the bottom of the "Removing software" topic, I link to the "Why is it asking me to remove several programs together?" topic.)

Otherwise, there's a simple way to get back to the table of contents: click the Back button.

That's why I suggest getting rid of the table of contents from topic pages.

It seems Yelp 3 actually solves the problem! See attached screenshot.

Changed in yelp (Ubuntu):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Vish (vish) on 2011-01-18
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → nobody
Changed in yelp:
status: New → Fix Released

I'm out of the office until 1st August.

On 27 Apr 2011, at 22:10, Bug Watch Updater
<email address hidden> wrote:

> ** Changed in: yelp
>       Status: New => Fix Released
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/507788
>
> Title:
>  In Help, Table of Contents switches from left to right when user
>  selects topic
>
> Status in One Hundred Paper Cuts:
>  Fix Committed
> Status in The Yelp Help Browser for Gnome:
>  Fix Released
> Status in “yelp” package in Ubuntu:
>  Fix Committed
>
> Bug description:
>  Binary package hint: yelp
>
>  Currently, when the user selects a topic in the help documentation
> the
>  TOC abruptly switches from being on the left side in the main page to
>  the right side.
>
>  It would be ideal if the contents are maintained always on the left
>  side. Would be easier for the user to orient.
>
>  Attaching screenshots
>  1 > Main page , TOC is on the left
>  2 > TOC is on the right. [in all contents]
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 10.04
>  InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
>  Package: yelp 2.28.0+webkit-1ubuntu1
>  ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
>  SourcePackage: yelp
>  Tags: lucid
>  Uname: Linux 2.6.32-10-generic i686

Timothy Arceri (t-fridey) wrote :

Updated yelp is in Oneiric marking as fix committed.

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in yelp (Ubuntu):
status: Fix Committed → Fix Released
Timothy Arceri (t-fridey) wrote :

I mean fix released

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.