documentation not accessible from yelp

Bug #334593 reported by John Pye on 2009-02-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yelp (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: openoffice.org

As far as I can tell, the OpenOffice SDK documentation, as provided by the package openoffice.org-dev-doc is not accessible from either DevHelp or from Yelp. Presumably the documentation needs to be registered in some way so that it can be conveniently accessed from one or other of these help browsers.

I'm using Ubuntu 8.10 with current openoffice packages.

Chris Cheney (ccheney) wrote :

OOo isn't a gnome application, Yelp is for gnome applications whose help documentation is written in xml located in /usr/share/gnome/help/foo/ DevHelp is similiary an application to show Gnome developer documentation written in a special format.

Marking this bug invalid.

Changed in openoffice.org:
status: New → Invalid
John Pye (jdpipe) wrote :

It's true that Yelp is a GNOME application however I believe that you may be wrong to say that because of this it doesn't support documentation for programs other than GNOME. For example, it provides access to all 'man' pages on my system, which are clearly not GNOME. Also, Yelp implements support for the Rarian documentation metadata system, which is an initiative of Freedesktop.org, aiming to be desktop-agnostic, i.e. it is not limited to only KDE or only GNOME (and this is a successor to Scrollkeeper, which was the same).

If Ubuntu doesn't provide a unified way for such -doc packages' files to be accessible from a unified 'librarian' program, then I will report this elsewhare. But I believe that Rarian is performing exactly this role.

Changed in openoffice.org:
status: Invalid → New
Chris Cheney (ccheney) wrote :

Yelp is not just a Gnome application it is a Gnome application to view documentation written in the Gnome help format. It also has parsers written to view man and GNU info pages. I don't see anything in Yelp that doesn't fall into one of those categories so I highly doubt it has some manner to view random -doc packages.

If you can point me in the direction of a non-gnome application that has its help in a format that Yelp can read that isn't man or info pages then I will look at its packaging to see if OOo can be conformed to display in a similar manner.

Thanks,

Chris

Changed in openoffice.org:
status: New → Incomplete
John Pye (jdpipe) wrote :

My point was that Yelp sits on top of Rarian, which is a freedesktop initiative to provide a documentation library of all documentation available on a system. My understanding is that Rarian is also exposed in KDE, although a KDE user could confirm this. This would mean that Rarian is the single correct place for 'registering' the OpenOffice documentation.

I hunted for non-GNOME documentation referenced in Yelp. I found "dive into python", but it is not working correctly on my machine, so this is looking like a yelp or ubuntu bug of some sort.

See bug https://bugs.launchpad.net/ubuntu/+source/yelp/+bug/337096

Changed in openoffice.org:
status: Incomplete → New
John Pye (jdpipe) wrote :

Here is another non-GNOME package that installs documents into Rarian/Scrollkeeper/Yelp: the package is SWIG.

Although please note problems due to current bug https://bugs.launchpad.net/ubuntu/+source/yelp/+bug/335218/

Yelp does clearly therefore attempt to play that role of centralised documentation resource.

Chris Cheney (ccheney) on 2009-03-19
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Chris Cheney (ccheney) wrote :

openoffice.org-dev-doc does already register with doc-base... So this looks like it might be a bug in yelp itself?

Description: utilities to manage online documentation
 This package contains utilities to manage documentation installed on
 a Debian system. It contains a database of document metadata.
 Various third-party systems such as 'dwww', 'dhelp', 'doc-central'
 or 'scrollkeeper' use this data to provide a catalog of available
 documentation.
 .
 If you want to get additional information about 'doc-base' please
 consult the `Debian doc-base Manual' included in this package.

Changed in yelp (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → New
Mitchell (mitchellvc) wrote :

I can confirm that yelp can't access to documentation other than of gnome, for example if you perform a search and then yelp shows search results from docs that are not gnome specific (i.e. I installed the Debian mantainer's manual) and if you intend to access to any of the links that yelp shows it will show an error "the file can't be read, maybe the file is missing or you don't have permission to read it" despite I can browse through nautilus to the folder where it is (/usr/share/doc/....../index.html). It happens with many other documentation, not only with that manual, for example:
file:///usr/share/doc/nano/faq.html#
file:///usr/share/doc/libglib2.0-doc/glib/index.html#
etc, to reproduce, make a search like with a word like "debian" and make click in some content not gnome specific.
After clicking in links that give the error yelp finally closes.

*** glibc detected *** yelp: corrupted double-linked list: 0x0000000002ece4f0 ***

Changed in yelp (Ubuntu):
status: New → Confirmed
Mitchell (mitchellvc) wrote :

Forget to mention I'm using yelp on ubuntu intrepid, don't know if this is still present in jaunty

See-ming Lee (seeminglee) wrote :

fyi, there's now an idea on the Ubuntu Brainstorm that may interest you:

Idea #20219: Integrate Help Systems
http://brainstorm.ubuntu.com/idea/20219/

I am in favor of a unified help system across all documentation - or at least provide some kind of index to locate them. Simply put, aptitude is aware of any *-doc packages installed (aptitude search), and was able to show me where those files got install (aptitude show) so it simply doesn't make sense to me why there cant' be an index which points to all of them (right now I wrote a bash script to find them but it seems it'd make more sense for the system to implement such feature.

Changed in yelp (Ubuntu):
importance: Undecided → Low
John Pye (jdpipe) wrote :

Maybe this issue is a documentation issue... something needs to happen so that documentation is correctly registered so that it can be found and read by users in a centralised way...

John Pye (jdpipe) wrote :

(what I mean is that the documentation on how documentation is to be delivered needs to be improved/clarified)

Adolfo Jayme (fitojb) on 2013-06-19
Changed in yelp (Ubuntu):
importance: Low → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints