Ubuntu

Yelp:ERROR:(yelp-document.c:275):yelp_document_cancel_page: assertion failed: (document != NULL && YELP_IS_DOCUMENT (document))

Reported by Gisli Ottarsson on 2008-04-21
154
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Yelp
Expired
High
yelp (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

On 8.04 Release Candidate Yelp window closes silently and .xsession-error contains

Yelp:ERROR:(yelp-document.c:275):yelp_document_cancel_page: assertion failed: (document != NULL && YELP_IS_DOCUMENT (document))

when these steps are followed:

Open yelp window
Go to Advanced Topics
Go to Writing Your Own Programs
Go to Learning how to program

On my machine nothing happens except a spinning-disk pointer. Impatiently select "Learning how to program" again and Poof!

LAST VERSION TESTED: 2.29.5-0ubuntu3 (Lucid)

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=530589

Changed in yelp:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in yelp:
status: Unknown → New
Changed in yelp:
status: New → Confirmed
Jouni Mettala (jouni-mettala) wrote :

Works as expected in yelp 2.25.1-0ubuntu2.

Changed in yelp:
status: Triaged → Fix Released
Jesse Burt (avsa242) wrote :

yelp 2.25.1-0ubuntu2 seems to be afflicted with this bug when clicking on "Connecting to the internet" (Ubuntu help center welcome page) - this is consistently reproducible here. Jaunty, current as of approximately two hours ago.

Changed in yelp:
status: Fix Released → Triaged
Jouni Mettala (jouni-mettala) wrote :

Can you reproduce with yelp 2.25.1-0ubuntu3? I can't.

Jesse Burt (avsa242) wrote :

Nope this seems fixed with -0ubuntu3.

Changed in yelp:
status: Triaged → Fix Released
Oliver Gerlich (ogerlich) wrote :

I think the original bug is still present - you can verify it by going to the keyboard config documentation (gnome-help ghelp:user-guide#goscustperiph-2) and clicking on the 8.4.1.6 Mouse Keys Preferences link. The link doesn't work, and clicking it again after a while leads to this crash.

Maybe the problem only happens on certain links which are somehow broken. The "Learning how to program" mentioned above seems to be fixed now, but apparently there are other such links which cause the crash.

Changed in yelp (Ubuntu):
status: Fix Released → Confirmed
antonioni (antonioni-rocha) wrote :

Waiting the resolution.

Changed in yelp (Ubuntu):
status: Confirmed → Triaged
bwallum (rbw2) wrote :

I searched for 'wireless', clicked on a 'Users Administration Tool Manual' link, minutes drifted by, just a default arrow (not spinning wheel) as mouse pointer in most of the window, with a spinning wheel pointer on the window menu bar; window title showed 'Loading...', then I closed down with close Window X button; seemed to close clean.

Restarted help with panel icon, searched again for 'wireless', clicked on 'Internet and Networks' and got the following message:-

The file ‘/usr/share/gnome/help/internet/en_GB/internet.xml’ could not be parsed because one or more of its included files is not a well-formed XML document

Michael Terry (mterry) wrote :

Here's the first of two patches from duplicate bug 235954. Will also attach upstream.

Michael Terry (mterry) wrote :
tags: added: oem
Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
removed: oem
C de-Avillez (hggdh2) on 2010-03-11
description: updated
David Futcher (bobbo) on 2010-06-10
tags: added: patch-forwarded-upstream
Changed in yelp:
importance: Unknown → High
Changed in yelp:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.