segmentation fault when launching yelp

Bug #1404728 reported by fossfreedom on 2014-12-21
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
yelp (Ubuntu)
High
Unassigned

Bug Description

using vivid.

Help does not launch when running from the new GTK3.14 versions of Nautilus or gnome-terminal

running yelp from a terminal reveals a segmentation fault issue:

dad@dad-VirtualBox:~$ yelp

** (yelp:5114): WARNING **: Failed to get GNOME shell mode: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: No such property 'Mode'

(yelp:5114): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(yelp:5114): Gtk-CRITICAL **: gtk_entry_set_icon_from_icon_name: assertion 'GTK_IS_ENTRY (entry)' failed

(yelp:5114): Gtk-CRITICAL **: gtk_entry_set_icon_activatable: assertion 'GTK_IS_ENTRY (entry)' failed

(yelp:5114): Gtk-CRITICAL **: gtk_entry_set_icon_activatable: assertion 'GTK_IS_ENTRY (entry)' failed

(yelp:5114): Gtk-CRITICAL **: gtk_editable_set_editable: assertion 'GTK_IS_EDITABLE (editable)' failed

(yelp:5114): Gtk-CRITICAL **: gtk_entry_set_icon_from_icon_name: assertion 'GTK_IS_ENTRY (entry)' failed

(yelp:5114): Gtk-CRITICAL **: gtk_entry_set_icon_from_icon_name: assertion 'GTK_IS_ENTRY (entry)' failed

(yelp:5114): Gtk-CRITICAL **: gtk_entry_set_icon_from_icon_name: assertion 'GTK_IS_ENTRY (entry)' failed

(yelp:5114): Gtk-CRITICAL **: gtk_entry_set_icon_from_icon_name: assertion 'GTK_IS_ENTRY (entry)' failed
Segmentation fault (core dumped)
dad@dad-VirtualBox:~$ ubuntu-bug yelp

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: yelp 3.12.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1
Uname: Linux 3.16.0-28-generic x86_64
ApportVersion: 2.15.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Dec 21 21:04:34 2014
InstallationDate: Installed on 2014-11-27 (24 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141123)
SourcePackage: yelp
UpgradeStatus: No upgrade log present (probably fresh install)

fossfreedom (fossfreedom) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in yelp (Ubuntu):
status: New → Confirmed
Changed in yelp (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yelp - 3.12.0-1ubuntu2

---------------
yelp (3.12.0-1ubuntu2) vivid; urgency=medium

  * debian/patches/location-entry-constructed-chain-up: Call constructed of
    our parent class. Fixes crash on gtk 3.14 due to widgets not being
    created. (LP: #1404728)
 -- Iain Lane <email address hidden> Wed, 14 Jan 2015 12:05:19 +0000

Changed in yelp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers