Check and Radio buttons state is unclear in GTK2

Bug #1878199 reported by Carlo Lobrano on 2020-05-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yaru-theme (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Carlo Lobrano

Bug Description

Some GTK2 applications use the new black and white menu-radio buttons in an inconsistent way outside the menus, resulting in a confused representation of their state.

Steps to reproduce:
1. open Inkscape > edit > preferences
2. look at the "Tools" view: "Visual bounding box" label uses b/w radio-button (that should only be used in menu), while "Geometric bounding box" uses the colored unchecked radio button. Note that check-button is used correctly in the colored form just below in the same view.

Our solution consists in have both menu-radio and normal radio buttons use the same colored style to show no differences whatever asset is used by GTK2 applications. No regression is expected because this is how the assets looked like in previous Yaru version and so is well tested.

Carlo Lobrano (c-lobrano) wrote :
affects: gnome-software (Ubuntu) → yaru-theme (Ubuntu)
Iain Lane (laney) on 2020-05-12
Changed in yaru-theme (Ubuntu Focal):
status: New → In Progress
assignee: nobody → Carlo Lobrano (c-lobrano)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yaru-theme - 20.10.1

---------------
yaru-theme (20.10.1) groovy; urgency=medium

  [ ubuntujaggers ]
  * adding full colour app icon for accessories-dictionary (LP: #1877468)
  * Let Gnome Software use upstream icon (LP: #1878198)

  [ Carlo Lobrano ]
  * use colored radio/check buttons in menu (LP: #1878199)

  [ Marco Trevisan (Treviño) ]
  * gnome-shell, dock: Remove the top/bottom padding (LP: #1873321)
  * gnome-shell, dock: Sync style parameters with upstream

 -- Carlo Lobrano <email address hidden> Fri, 08 May 2020 15:26:23 +0200

Changed in yaru-theme (Ubuntu):
status: New → Fix Released
tags: added: focal groovy
Carlo Lobrano (c-lobrano) wrote :
description: updated
description: updated

Hello Carlo, or anyone else affected,

Accepted yaru-theme into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/yaru-theme/20.04.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in yaru-theme (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Paul White (paulw2u) wrote :

To verify I took the following steps:

1) I installed Inkscape
2) As I had already upgraded the yaru packages by enabling -proposed to verify another fix I downgraded them to version 20.04.6
3) I verified that radio buttons looked like as described above
4) I upgraded the yaru packages again to version 20.04.7
5) I then saw that the radio buttons had changed as intended

So marking as verified

tags: added: verification-done-focal
removed: verification-needed-focal

The verification of the Stable Release Update for yaru-theme has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yaru-theme - 20.04.7

---------------
yaru-theme (20.04.7) focal; urgency=medium

  [ ubuntujaggers ]
  * adding full colour app icon for accessories-dictionary (LP: #1877468)
  * Let Gnome Software use upstream icon (LP: #1878198)

  [ Carlo Lobrano ]
  * use colored radio/check buttons in menu (LP: #1878199)

  [ Marco Trevisan (Treviño) ]
  * gnome-shell, dock: Remove the top/bottom padding (LP: #1873321)
  * gnome-shell, dock: Sync style parameters with upstream

 -- Carlo Lobrano <email address hidden> Fri, 08 May 2020 15:26:23 +0200

Changed in yaru-theme (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers