Ubuntu-Software icon should not be used for Gnome-Software

Bug #1878198 reported by Carlo Lobrano on 2020-05-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
yaru-theme (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Carlo Lobrano

Bug Description

org.gnome.Software and ubuntu software use the same icon

This causes confusion for users that choose to install gnome-software for flatpak support.

First reported here https://github.com/ubuntu/yaru/issues/2144#issuecomment-620092334

Steps to reproduce:
1. install org.gnome.Software
2. open both org.gnome.Software and Ubuntu Software, or even just search for "software" in gnome-shell
3. The icons of both applications are shown, and they are the same

The fix is to allow org.gnome.Software to use its upstream icon, removing a Yaru symlink between gnome-software app name and Yaru's icon. The system is expected to automatically use the application provided icon if the selected icon set does not provide one, so no regression is expected.

Iain Lane (laney) on 2020-05-12
Changed in yaru-theme (Ubuntu Focal):
assignee: nobody → Carlo Lobrano (c-lobrano)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yaru-theme - 20.10.1

---------------
yaru-theme (20.10.1) groovy; urgency=medium

  [ ubuntujaggers ]
  * adding full colour app icon for accessories-dictionary (LP: #1877468)
  * Let Gnome Software use upstream icon (LP: #1878198)

  [ Carlo Lobrano ]
  * use colored radio/check buttons in menu (LP: #1878199)

  [ Marco Trevisan (Treviño) ]
  * gnome-shell, dock: Remove the top/bottom padding (LP: #1873321)
  * gnome-shell, dock: Sync style parameters with upstream

 -- Carlo Lobrano <email address hidden> Fri, 08 May 2020 15:26:23 +0200

Changed in yaru-theme (Ubuntu):
status: New → Fix Released
tags: added: focal groovy
description: updated

Hello Carlo, or anyone else affected,

Accepted yaru-theme into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/yaru-theme/20.04.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in yaru-theme (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Paul White (paulw2u) wrote :

I already had the .deb and snap versions of "Software" installed.
I searched for 'Software' and verified that the icons for Software and Ubuntu Software were the same as per the bug report.
I enabled -proposed and updated the yaru packages
I searched for 'Software' again and saw that the icons are now different as the fix intended.
So marking as verified.

tags: added: verification-done-focal
removed: verification-needed-focal

The verification of the Stable Release Update for yaru-theme has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yaru-theme - 20.04.7

---------------
yaru-theme (20.04.7) focal; urgency=medium

  [ ubuntujaggers ]
  * adding full colour app icon for accessories-dictionary (LP: #1877468)
  * Let Gnome Software use upstream icon (LP: #1878198)

  [ Carlo Lobrano ]
  * use colored radio/check buttons in menu (LP: #1878199)

  [ Marco Trevisan (Treviño) ]
  * gnome-shell, dock: Remove the top/bottom padding (LP: #1873321)
  * gnome-shell, dock: Sync style parameters with upstream

 -- Carlo Lobrano <email address hidden> Fri, 08 May 2020 15:26:23 +0200

Changed in yaru-theme (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers