ln: creating symbolic link `./yaml-mode.el': File exists

Bug #533549 reported by Skully on 2010-03-06
244
This bug affects 44 people
Affects Status Importance Assigned to Milestone
yaml-mode (Debian)
Fix Released
Unknown
yaml-mode (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

TEST CASE:
1. Install karmic version of yaml-mode
2. Upgrade to lucid version
3. Should fail
4. Reinstall karmic version
5. Upgrade to lucid-proposed version
6. Should not have an issue

-----------------

Binary package hint: yaml-mode

The yaml-mode postinst script will attempt to create a symbolic link to yaml-mode.el, but fails if it already exists.

Purging and then reinstalling yaml-mode appears to be a viable workaround.

The upstream package yaml-mode 0.0.5-2 contains a fix. Unfortunately, Lucid users are stuck with an older version.

--- Original bug report ---

was upgrading from 9.10 to 10.04

ProblemType: Package
Architecture: i386
Date: Sun Mar 7 00:15:06 2010DistroRelease: Ubuntu 10.04
ErrorMessage:
 ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Package: yaml-mode 0.0.4-2
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.31-20.57-genericSourcePackage: yaml-mode
Title: package yaml-mode 0.0.4-2 failed to install/upgrade:
Uname: Linux 2.6.31-20-generic i686

Skully (skully) wrote :
Marien Zwart (marienz) wrote :

This interrupted the upgrade from karmic to lucid (I'm sorry, I don't have exactly how logged). A manual reinstall attempt at the commandline gave me:

Setting up yaml-mode (0.0.4-2) ...
emacsen-common: Handling install of emacsen flavor emacs
emacsen-common: Handling install of emacsen flavor emacs23
emacsen-common: byte-compiling for emacs23
Wrote /etc/emacs23/site-start.d/00debian-vars.elc

In debian-run-directories:
debian-startup.el:131:25:Warning: `mapcar' called for effect; use `mapc' or
    `dolist' instead
Wrote /usr/share/emacs23/site-lisp/debian-startup.elc
install/yaml-mode: Handling install for emacsen flavor emacs23
ln: creating symbolic link `./yaml-mode.el': File exists
emacs-package-install: /usr/lib/emacsen-common/packages/install/yaml-mode emacs23 emacs23 failed at /usr/lib/emacsen-common/emacs-package-install line 30, <TSORT> line 2.
dpkg: error processing yaml-mode (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 yaml-mode
E: Sub-process /usr/bin/dpkg returned an error code (1)

which I'm assuming is the same failure the upgrader hit. Purging and then reinstalling got past this.

Fjodor (sune-molgaard) wrote :

Got it too...

Andrew Svetlov (andrew-svetlov) wrote :

The same for x64 architecture.

draptik (patrick-pdrechsler) wrote :

Purging and reinstalling fixed the problem for me (also on x64).

slowneutrino (russ-berger) wrote :

Right! I too was upgrading from 9.10 to 10.04 (now "Linux owyhee 2.6.31-21-generic #59-Ubuntu SMP Wed Mar 24 07:28:56 UTC 2010 i686 GNU/Linux")

I did
apt-get purge yaml-mode
apt-get install yaml-mode

and emacs23 yaml-mode works now.

Michael Vogt (mvo) wrote :

It fails with emacs22

Changed in yaml-mode (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: pkg-auto-install-tester

fails with emacs22, purge and reinstall seems to work too.

andi bachmann (bachmann) wrote :

purge and re-install worked for me. (emacs23)

era (era) on 2010-09-14
summary: - package yaml-mode 0.0.4-2 failed to install/upgrade:
+ ln: creating symbolic link `./yaml-mode.el': File exists
era (era) wrote :

Posted a backport request: bug #701421

era (era) on 2011-05-30
description: updated
tags: added: dist-upgrade
Changed in yaml-mode (Debian):
status: Unknown → Fix Released
Micah Gersten (micahg) wrote :

Should be fixed in Maverick and higher

Changed in yaml-mode (Ubuntu):
status: Confirmed → Fix Released
Changed in yaml-mode (Ubuntu Lucid):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Micah Gersten (micahg)
Micah Gersten (micahg) wrote :

Uploaded to lucid-proposed, waiting for review

description: updated
tags: added: testcase
Changed in yaml-mode (Ubuntu Lucid):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Fix Committed

Hello Skully, or anyone else affected,

Accepted yaml-mode into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

The fix for the this bug has been awaiting testing feedback in the -proposed repository for lucid for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now the package will be removed from the -proposed repository.

tags: added: removal-candidate
Micah Gersten (micahg) wrote :

I attempted to verify this, but following the steps in the description, I was not able to verify the initial failure. Unfortunately, I don't have time to dig into why either the steps aren't right or why it didn't fail.

Do not worry about. I've since been able to update that laptop. Thank you for trying.

dave

> Date: Mon, 26 Nov 2012 15:33:13 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 533549] Re: ln: creating symbolic link `./yaml-mode.el': File exists
>
> I attempted to verify this, but following the steps in the description,
> I was not able to verify the initial failure. Unfortunately, I don't
> have time to dig into why either the steps aren't right or why it didn't
> fail.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (706283).
> https://bugs.launchpad.net/bugs/533549
>
> Title:
> ln: creating symbolic link `./yaml-mode.el': File exists
>
> Status in “yaml-mode” package in Ubuntu:
> Fix Released
> Status in “yaml-mode” source package in Lucid:
> Fix Committed
> Status in “yaml-mode” package in Debian:
> Fix Released
>
> Bug description:
> TEST CASE:
> 1. Install karmic version of yaml-mode
> 2. Upgrade to lucid version
> 3. Should fail
> 4. Reinstall karmic version
> 5. Upgrade to lucid-proposed version
> 6. Should not have an issue
>
> -----------------
>
> Binary package hint: yaml-mode
>
> The yaml-mode postinst script will attempt to create a symbolic link
> to yaml-mode.el, but fails if it already exists.
>
> Purging and then reinstalling yaml-mode appears to be a viable
> workaround.
>
> The upstream package yaml-mode 0.0.5-2 contains a fix. Unfortunately,
> Lucid users are stuck with an older version.
>
> --- Original bug report ---
>
> was upgrading from 9.10 to 10.04
>
> ProblemType: Package
> Architecture: i386
> Date: Sun Mar 7 00:15:06 2010DistroRelease: Ubuntu 10.04
> ErrorMessage:
> ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
> Package: yaml-mode 0.0.4-2
> PackageArchitecture: all
> ProcVersionSignature: Ubuntu 2.6.31-20.57-genericSourcePackage: yaml-mode
> Title: package yaml-mode 0.0.4-2 failed to install/upgrade:
> Uname: Linux 2.6.31-20-generic i686
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/yaml-mode/+bug/533549/+subscriptions

Brian Murray (brian-murray) wrote :

The version of yaml-mode in lucid-proposed has been removed as this bug report was not verified in a timely fashion.

Changed in yaml-mode (Ubuntu Lucid):
status: Fix Committed → Won't Fix
Changed in yaml-mode (Ubuntu Lucid):
status: Won't Fix → Triaged
tags: removed: verification-needed
tags: removed: removal-candidate
Changed in yaml-mode (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.