Ubuntu

[Gutsy] creating initrd image fails with "invalid option -- c"

Reported by Michael Flaig on 2007-08-01
4
Affects Status Importance Assigned to Milestone
yaird (Ubuntu)
Undecided
Unassigned

Bug Description

This applies to gutsy gibbon

I prefer to use yaird because initramfs-tools seem to not create correct ramdisk images on my macpro (need to check again, nontheless yaird seems to fail - but it shouldn't and didn't with feisty)

I'm not sure if this is a bug in initramfs-tools (update-initramfs) or yaird itself

Here goes the error log ...
--- snip ---
root@titan:~# LANG=C dpkg --configure -a
Setting up linux-image-2.6.22-8-386 (2.6.22-8.18) ...
Running depmod.
mkinitrd.yaird: invalid option -- c
Terminating...
Failed to create initrd image.
dpkg: error processing linux-image-2.6.22-8-386 (--configure):
 subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-ubuntu-modules-2.6.22-8-386:
 linux-ubuntu-modules-2.6.22-8-386 depends on linux-image-2.6.22-8-386; however:
  Package linux-image-2.6.22-8-386 is not configured yet.
dpkg: error processing linux-ubuntu-modules-2.6.22-8-386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-2.6.22-8-386
 linux-ubuntu-modules-2.6.22-8-386
--- snap ---

--- snip ---
root@titan:~# cat /etc/kernel-img.conf
do_symlinks = yes
relative_links = yes
do_bootloader = no
do_bootfloppy = no
do_initrd = yes
link_in_boot = no
ramdisk = /usr/sbin/mkinitrd.yaird
--- snap ---

Colin Watson (cjwatson) wrote :

I don't believe we've ever supported yaird on Ubuntu; interested people are welcome to dig into what's going wrong and submit patches.

Luca Falavigna (dktrkranz) wrote :

Thank you for your bug report.
How did you instruct your system to use yaird instead of update-initramfs?

Changed in yaird:
assignee: nobody → dktrkranz
status: New → Incomplete
Luca Falavigna (dktrkranz) wrote :

I noticed just now the output you attached to the bug report.
Attached debdiff should fix this report.

Changed in yaird:
assignee: dktrkranz → nobody
status: Incomplete → Confirmed
Daniel Holbach (dholbach) wrote :

Can somebody of the kernel team check this one out?

Changed in yaird:
assignee: nobody → ubuntu-kernel-team
Scott Kitterman (kitterman) wrote :

This debdiff is a bit odd. At the time it was uploaded, Ubuntu had version 0.0.12-20, but the debdiff is against 0.0.12-22. Was this meant to be a merge? 0.0.12-22 is in the Ubuntu archive now. Please verify that this problem still exists and that this is the correct solution. Please resubscribe UUS once that's done.

Changed in yaird:
assignee: ubuntu-kernel-team → nobody
Luca Falavigna (dktrkranz) wrote :

Issue is still present, here are the steps to reproduce:
1) Open /etc/kernel-img.conf
2) Insert ramdisk = /usr/sbin/mkinitrd.yaird, save and exit
3) Run dpkg-reconfigure linux-image-`uname -r` or install a new kernel
You will get this:
root@sauron:~# dpkg-reconfigure linux-image-`uname -r`
Running depmod.
mkinitrd.yaird: invalid option -- u
Terminating...
Failed to create initrd image.
root@sauron:~#

After applying the new debdiff, here is the output:
root@sauron:~# dpkg-reconfigure linux-image-`uname -r`
Running depmod.
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.22-10.30 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.22-10.30 was configured last, according to dpkg)
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.22-10-generic
Found kernel: /boot/vmlinuz-2.6.22-9-generic
Found kernel: /boot/vmlinuz-2.6.22-4-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done
root@sauron:~#
Ramdisk has been succesfully created and system boots correctly.

Changed in yaird:
assignee: nobody → ubuntu-kernel-team
Changed in yaird:
assignee: ubuntu-kernel-team → kitterman
status: Confirmed → In Progress
Changed in yaird:
assignee: kitterman → nobody
Luca Falavigna (dktrkranz) wrote :

yaird (0.0.12-22ubuntu1) gutsy; urgency=low

  * mkinitrd-yaird: update-initramfs compatibility (LP: #129828)
  * Update Maintainer field in debian/control

 -- Luca Falavigna <email address hidden> Sun, 19 Aug 2007 23:51:27 +0200

Changed in yaird:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers