Segmentation fault (core dumped) while try open file

Bug #1432768 reported by Pavel-II on 2015-03-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yagf (Ubuntu)
Undecided
Unassigned

Bug Description

Try open file and yagf crush with Segmentation fault (core dumped)

run on gdb:

gdb yagf
GNU gdb (Ubuntu 7.8-1ubuntu4) 7.8.0.20141001-cvs
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from yagf...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/yagf
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffec740700 (LWP 7571)]
[New Thread 0x7fffebf3f700 (LWP 7572)]

Program received signal SIGSEGV, Segmentation fault.
__memcpy_sse2_unaligned () at ../sysdeps/x86_64/multiarch/memcpy-sse2-unaligned.S:36
36 ../sysdeps/x86_64/multiarch/memcpy-sse2-unaligned.S: No such file or directory

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: yagf 0.9.3.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-31.41-generic 3.16.7-ckt5
Uname: Linux 3.16.0-31-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.2
Architecture: amd64
Date: Mon Mar 16 21:10:13 2015
InstallationDate: Installed on 2009-11-30 (1932 days ago)
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
SourcePackage: yagf
UpgradeStatus: No upgrade log present (probably fresh install)

Pavel-II (dzy4) wrote :

Using Lubuntu 15.10, same version of YAGF, same result...

Have not tried latest version (0.9.5). Downloaded it, thinking it was a binary, but must compile. Don't know...

Tried to compile. Says it needs cmake - installed that.

Got:
qmake: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/qmake': No such file or directory
CMake Error at /usr/share/cmake-3.2/Modules/FindQt4.cmake:1326 (message):
  Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x

Installed qt4-qmake (My setup seems to have both qt4 and qt5 aspects, but as:
scott@scott-Asus-M2M68-AM-Plus:/data/scott/Downloads/yagf-0.9.5/yagf-build$ ls -lha /usr/lib/i386-linux-gnu/qt-default/qtchooser
total 8.0K
drwxr-xr-x 2 root root 4.0K Oct 24 18:25 .
drwxr-xr-x 3 root root 4.0K Oct 24 18:25 ..
lrwxrwxrwx 1 root root 51 Jul 12 17:34 default.conf -> ../../../../share/qtchooser/qt4-i386-linux-gnu.conf

it therefore appears that qt4 is default, and only the /usr/lib/i386-linux-gnu/qt4 folder has a /bin folder (and once I installed the qt4 qmake package, that is where qmake was), the /usr/lib/i386-linux-gnu/qt5 folder does not have a /bin folder.)

Now that qmake was installed, I tried again...

No.

Got:
"CMake Warning at /usr/share/cmake-3.2/Modules/FindQt4.cmake:626 (message):
  /usr/bin/qmake reported QT_INSTALL_LIBS as "/usr/lib/i386-linux-gnu" but
  QtCore could not be found there. Qt is NOT installed correctly for the
  target build environment.
"
I DO have QT 4 core module package installed:
"libqtcore4
Qt 4 core module"
and the following is in /usr/lib/i386-linux-gnu
lrwxrwxrwx 1 root root 21 Jul 12 17:34 libQtCLucene.so.4 -> libQtCLucene.so.4.8.6
lrwxrwxrwx 1 root root 21 Jul 12 17:34 libQtCLucene.so.4.8 -> libQtCLucene.so.4.8.6
      -rw-r--r-- 1 root root 927K Jul 12 17:37 libQtCLucene.so.4.8.6
lrwxrwxrwx 1 root root 18 Jul 12 17:34 libQtCore.so.4 -> libQtCore.so.4.8.6
lrwxrwxrwx 1 root root 18 Jul 12 17:34 libQtCore.so.4.8 -> libQtCore.so.4.8.6
      -rw-r--r-- 1 root root 3.1M Jul 12 17:37 libQtCore.so.4.8.6

which are directly from the qt4 Core package...

I don't know exactly what is mising, or I could try further...

As suggested, I will attach:
 "/data/scott/Downloads/yagf-0.9.5/yagf-build/CMakeFiles/CMakeOutput.log"

Tehnick (tehnick) wrote :

This bug is not fixed in yagf 0.9.5. It is not fixed even in master branch in git repo. Do not waste your time for compiling.

Tehnick (tehnick) wrote :

Just disable option "Crop Image When Loaded" in Settings --> Image processing.

-->Tehnick: Thanks for the tip!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers