Ubiquity crashed on PowerPC after working a long time to install Lubuntu.

Bug #944639 reported by Jeff Day on 2012-03-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
yaboot-installer (Ubuntu)
High
Unassigned

Bug Description

Description: Ubuntu precise (development branch)
Release: 12.04

ubiquity:
  Installed: 2.9.23
  Candidate: 2.9.23
  Version table:
 *** 2.9.23 0
        500 http://ports.ubuntu.com/ubuntu-ports/ precise/main powerpc Packages
        100 /var/lib/dpkg/status

I expected the installation to complete and the bootloader to get installed.
We did the "Something Else" option, kept the existing sda1 new world boot partition, created a 2048m swap partition as sda2 and the rest of the drive as sda3 ext4 mountpoint /
The color theme looked a bit dark and hard to read but this is a Beta so that might be normal.

Things looked like they were going fine for about a half hour then we got a message that the installer crashed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.23
ProcVersionSignature: Ubuntu 3.2.0-17.27-powerpc 3.2.6
Uname: Linux 3.2.0-17-powerpc ppc
ApportVersion: 1.93-0ubuntu2
Architecture: powerpc
CasperVersion: 1.305
Date: Fri Mar 2 00:55:04 2012
InstallCmdLine: ro ramdisk_size=1048576 file=/cdrom/preseed/lubuntu.seed boot=casper quiet splash --
LiveMediaBuild: Lubuntu 12.04 "Precise Pangolin" - Beta powerpc (20120301.1)
ProcEnviron:
 TERM=unknown
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jeff Day (jeff-storago) wrote :

Exception during installation:
Mar 2 08:54:19 lubuntu plugininstall.py: Traceback (most recent call last):
Mar 2 08:54:19 lubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1690, in <module>
Mar 2 08:54:19 lubuntu plugininstall.py: install.run()
Mar 2 08:54:19 lubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 55, in wrapper
Mar 2 08:54:19 lubuntu plugininstall.py: func(self)
Mar 2 08:54:19 lubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 204, in run
Mar 2 08:54:19 lubuntu plugininstall.py: self.configure_bootloader()
Mar 2 08:54:19 lubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1014, in configure_bootloader
Mar 2 08:54:19 lubuntu plugininstall.py: "YabootInstaller failed with code %d" % ret)
Mar 2 08:54:19 lubuntu plugininstall.py: InstallStepError: YabootInstaller failed with code 1
Mar 2 08:54:19 lubuntu plugininstall.py:

tags: added: installer-crash
affects: ubiquity (Ubuntu) → yaboot-installer (Ubuntu)
Changed in yaboot-installer (Ubuntu):
importance: Undecided → High
miegiel (nix-miegiel) wrote :

@Jeff Day : Is this a duplicate of bug #909179 ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers