Disable button does not work

Bug #1737564 reported by SebA on 2017-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xymon (Ubuntu)
Undecided
Unassigned

Bug Description

The Disable button from the Info host pages does not work, and neither does the Toggle buttons, and, in Chrome, the History button from any service status page.

This affects Xymon 4.3.25-1 in Xenial.

Manually installing the latest version of Xymon (xymon_4.3.28-2_amd64.deb) from http://mirrors.kernel.org/ubuntu/pool/universe/x/xymon/xymon_4.3.28-2_amd64.deb fixes all these issues, so please update the Upstream version in Xenial.

May be relevant to this bug:
[Xymon] disable not always working in 4.3.25
http://lists.xymon.com/archive/2016-February/043016.html

Revision history for this message
SebA (seba1) wrote :

P.S. Debian Stable has already updated to xymon_4.3.28-2
Ref: https://packages.debian.org/search?keywords=xymon

Revision history for this message
Axel Beckert (xtaran) wrote :

> P.S. Debian Stable has already updated to xymon_4.3.28-2

No, that's wrong. Debian Stretch (current stable) has been initially released with that version.

And neither Debian (nor AFAIK) Ubuntu will update to newer upstream releases in stable releases unless there's a critical security issue which can't be backported at all.

There is a small chance that someone from Ubuntu will backport the according upstream fixes to Xenial.

tags: added: xenial
Revision history for this message
SebA (seba1) wrote :

>> P.S. Debian Stable has already updated to xymon_4.3.28-2

> No, that's wrong. Debian Stretch (current stable) has been initially released with that version.

Sloppy semantics on my part. This is what I meant.

The issues I identify in the above bug report are not security issues, but if you were developer of a product and approximately 25% of your product stopped working (due to Browser changes), I think you would classify that as 'critical'. The downstream maintainer should take the same view IMHO.

As I'm sure you already know Axel, this is a point release and the vast majority of changes between 4.3.25 and 4.3.28 are fixes or security enhancements (Ref: https://sourceforge.net/projects/xymon/files/Xymon/4.3.28/). I don't know much about Debian or Ubuntu policy, but if you were to apply all the patches for fixes (and especially if you include the security enhancements) to 4.3.25 you would nearly end up with 4.3.28 anyway. I have confirmed that 4.3.28 (from Artful) works on Xenial (when installed with the same version of xymon-client, librrd8_1.6.0-1ubuntu2_amd64.deb and libpng16-16 (from Xenial), so if there is refusal to updating the Xenial version, I will certainly be requesting a backport.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers