[Feisty] libxvidcore missing dependency for yasm for i386 arch : more than 3 times slower than in edgy

Bug #84705 reported by Kent Gibson
16
Affects Status Importance Assigned to Milestone
xvidcore (Ubuntu)
Fix Released
Medium
Loïc Martin
Nominated for Feisty by Scott Kitterman
Nominated for Gutsy by Scott Kitterman

Bug Description

Binary package hint: libxvidcore4

Feisty's libxvidcore4 debian/control is missing a dependency for yasm [i386] - thus making any xvid encode 3 times slower than it should. This problem doesn't affect amd64, nor should affect other arch

debian/changelog should have as Depends: debhelper (>> 4), yasm [i386 amd64], dpatch

After an upgrade from edgy to feisty I noticed that Xvid transcoding was significantly slower.
e.g. mencoder blah.avi -ovc xvid -xvidencopts bitrate=2000 -nosound -o blah.mp4

Reverting to the edgy libxvidcore4 (2:1.1.0-final-0.1ubuntu1) fixed the problem.
Switching back to the feisty package (2:1.1.2-0.1ubuntu1) again produced the slower performance. No other libraries were changed.

Building libxvidcore from source produced a package which performed badly as per (2:1.1.2-0.1ubuntu1).

Reading the doc/INSTALL I noticed this in the build Requirements:

   - nasm on ia32 platforms for MMX/SSE optimized code.

Installing nasm and rebuilding the package produced a libxvidcore that performed at least as well as (2:1.1.0-final-0.1ubuntu1).
So I'm guessing that (2:1.1.2-0.1ubuntu1) was built without nasm.

Revision history for this message
disturbed (disturbed1976) wrote :

I had the same experience.

With the default Fiesty libxvid I only achieved 3-4 FPS. Simply downloading the xvid 1.1.2 source tarball and doing
./configure --prefix="/usr"
make
sudo make install

I now get 14-15 FPS.

Revision history for this message
Mark Jovalekic (m-jovalekic) wrote :

I can confirm this.

Xvid-Encoding in feisty is significantly slower than in edgy (dapper)

Revision history for this message
Albert Gasset (albertgasset) wrote :

I also can confirm this.

For me the version in Edgy is 3 times faster.

Changed in xvidcore:
status: Unconfirmed → Confirmed
description: updated
Revision history for this message
Loïc Martin (loic-martin3) wrote :

I've quickly built a dirty package that fixes the problem - it's the Ubuntu Feisty one compiled with yasm as Depends not only for amd64 but also for i386.

However, it's not signed - I'll try to find my key tomorrow (laaate now) and upload a prefect one.

Except for that everything works - I've gone from 2 fps to 15 fps (2nd pass). It depends on yasm now, so if dpkg complains just :
sudo apt-get install yasm

description: updated
Revision history for this message
Loïc Martin (loic-martin3) wrote :

New package, signed, correct dependencies now (so you won't have to install yasm anymore)

Revision history for this message
Loïc Martin (loic-martin3) wrote :
Changed in xvidcore:
assignee: nobody → loic-martin3
status: Confirmed → In Progress
Revision history for this message
Loïc Martin (loic-martin3) wrote :
Revision history for this message
Brandon Holtsclaw (imbrandon) wrote :

uploaded to proposed

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into feisty-proposed, please go ahead with QA testing.

Changed in xvidcore:
status: In Progress → Fix Committed
Revision history for this message
Mark Jovalekic (m-jovalekic) wrote :

I tried the fixed libxvidcore with mencoder and the speed is normal again.
Thank you.

Revision history for this message
Loïc Martin (loic-martin3) wrote :

The new package works for me too, I tried a few encodes

Revision history for this message
BradPhipps (bradphipps) wrote :

Works for me!
Using feisty's original libxvidcore4 I encoded at 8 frames per second. After installing "1.1.2-0.1ubuntu1.1~proposed1". I'm now getting 23 frames per second, with no problems.

Daniel T Chen (crimsun)
Changed in xvidcore:
importance: Undecided → Medium
Revision history for this message
Steve Kowalik (stevenk) wrote :

Unsubscribing ubuntu-universe-sponsors since this is being taken care of.

Revision history for this message
jslawler (jlawler) wrote :

I can also confirm that this new package has fixed the problem.
My encode speeds increased from around 17 FPS to 55 FPS.

Revision history for this message
Loïc Martin (loic-martin3) wrote :

I've check with upstream that yasm is needed for i386 and amd64, but not for other architectures. This patch is a diff for gutsy xvid package

Revision history for this message
Reinhard Tartler (siretart) wrote :

uploaded, please set to fix released if all builds are available

Revision history for this message
Martin Pitt (pitti) wrote :

Reinhard, there is nothing in the feisty-updates queue. Can you please try again? NB that I cannot copy the -proposed package because it has the ~proposed version suffix.

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into feisty-updates.

Changed in xvidcore:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers