Ubuntu

xvidcap audio settings missing in preferences

Reported by Liassic on 2009-05-12
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Xvidcap
Unknown
Unknown
xvidcap (Ubuntu)
Low
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: xvidcap

I'm running Ubuntu 9.04
I had Package xvidcap 1.1.7-0.2ubuntu1 installed from the jaunty/multiverse repository.
In XvidCap Preferences / Multi-frame the Audio Settings block is totally missing. Not displayed at all. The Video settings block is displayed correctly.
I un-installed this version and downloaded version xvidcap_1.1.7intrepid_i386.deb from the XvidCap sourceforge.net site.
When installed this version worked fine - the Audio Settings block is now visible.

I reverted back to 1.1.7-0.2ubuntu1 to double-check and the problem was back again.
Reverted back to 1.1.7intrepid and no problem.

description: updated
Thonix (thonix) wrote :

I have the same situation ...

gnowak (gnowak-gmail) wrote :

Me too...

gnowak (gnowak-gmail) wrote :

I can add this:
xvidcap --audio yes
Audio support not present in this binary.
Usage: xvidcap, ver 1.1.7, (c) rasca, berlin 1997,98,99, khb (c) 2003 - 07

Hmm why?

Danny Howard (dannyman) wrote :

Hello,

I too have noticed the "Audio support not present in this binary." I think the binary would be more useful if audio support were enabled.

Aaron LaCluyze (mrbook2) wrote :

This bug also affects me.

Ubuntu 9.10, 64-bit. Installed xvidcap via the Ubuntu software center, version 1.1.7 on 2009-11-19.

Several discussions suggested that installing the .deb from sourceforge would fix this. There only seem to be i386 binaries there. Installing that with --force-architecture worked, but xvidcap won't run, claiming that libtheora.so.0 is missing (even though /usr/lib/libtheora.so.0 exists.)

Aaron LaCluyze (mrbook2) wrote :

A note re: my previous comment.

I downloaded the 1.1.7 source tarball and compiled. This works, with sound on my 64 bit 9.10 Ubuntu install. Not an ideal solution, but should work until the package in the repository gets fixed.

Changed in xvidcap (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Alessio Treglia (quadrispro)
status: In Progress → Fix Committed
assignee: Alessio Treglia (quadrispro) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xvidcap - 1.1.7-0.2ubuntu6

---------------
xvidcap (1.1.7-0.2ubuntu6) lucid; urgency=low

  * Switch to debhelper 7.
  * debian/patches/01_configure.diff:
    - Horrible-fix for adding audio support (LP: #375711).
  * debian/patches/04_desktop.diff:
    - Fix desktop file as per spec.
  * Bump debhelper,quilt build-dependencies.
  * Refresh patches, add descriptions.
 -- Alessio Treglia <email address hidden> Tue, 24 Nov 2009 23:45:26 +0100

Changed in xvidcap (Ubuntu):
status: Fix Committed → Fix Released
Alessio Treglia (quadrispro) wrote :

debdiff for asking an SRU for karmic

John Dong (jdong) wrote :

Haha, "horrible fix" is kinda right :)

Is there an explanation of what causes this behavior?

Alessio Treglia (quadrispro) wrote :

Of course, John.

As you can see from the buildlog, some functions that have been used are now deprecated:

xtoffmpeg.c: In function 'add_audio_stream':
xtoffmpeg.c:427: warning: 'audio_resample_init' is deprecated (declared at /usr/include/libavcodec/avcodec.h:2555)
xtoffmpeg.c:447: warning: 'audio_resample_init' is deprecated (declared at /usr/include/libavcodec/avcodec.h:2555)
xtoffmpeg.c: In function 'do_audio_out':
xtoffmpeg.c:551: warning: 'av_fifo_write' is deprecated (declared at /usr/include/libavutil/fifo.h:82)
xtoffmpeg.c: In function 'xvc_ffmpeg_save_frame':
xtoffmpeg.c:1472: warning: 'av_alloc_format_context' is deprecated (declared at /usr/include/libavformat/avformat.h:873)

Due to this, I forced the ffmpeg_audio check to "1" in order to achieve our goal.

BTW, I will forward this to upstream.

Is this fix will land in jaunty's update repository?

Alessio Treglia (quadrispro) wrote :
Mitchell (mitchellvc) wrote :

It would be great if this fix landed in karmic repository too

Changed in xvidcap (Ubuntu Karmic):
status: New → Confirmed
Alessio Treglia (quadrispro) wrote :

We're waiting for an ACK from a motu-sru team members, please don't change again the bug's status.

Changed in xvidcap (Ubuntu Karmic):
status: Confirmed → New
tags: added: karmic
tags: added: jaunty
John Dong (jdong) wrote :

After thinking through it, although the fix in principle is hackish I think it's reasonably safe. ACK from MOTU-SRU.

Changed in xvidcap (Ubuntu Jaunty):
status: New → Confirmed
Changed in xvidcap (Ubuntu Karmic):
status: New → Confirmed

Accepted xvidcap into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xvidcap (Ubuntu Jaunty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted xvidcap into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xvidcap (Ubuntu Karmic):
status: Confirmed → Fix Committed
Liassic (paul-south-wales) wrote :

I just tested v5.1 in Karmic and it worked for me...Audio settings are there.
Thanks.

Martin Pitt (pitti) on 2009-12-10
tags: added: verification-done
removed: verification-needed
Alessio Treglia (quadrispro) wrote :

Tested on Jaunty too, it works fine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xvidcap - 1.1.7-0.2ubuntu1.1

---------------
xvidcap (1.1.7-0.2ubuntu1.1) jaunty-proposed; urgency=low

  * Depend on libavcodec-unstripped-52 (LP: #290728).
  * debian/patches/01_configure.patch:
    - debian/patches/01_configure.diff:
      + Force check to enable the audio support (LP: #375711).
 -- Alessio Treglia <email address hidden> Sun, 29 Nov 2009 10:36:34 +0100

Changed in xvidcap (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xvidcap - 1.1.7-0.2ubuntu5.1

---------------
xvidcap (1.1.7-0.2ubuntu5.1) karmic-proposed; urgency=low

  * debian/patches/01_configure.diff:
    - Force to enable the audio support (LP: #375711).
 -- Alessio Treglia <email address hidden> Wed, 25 Nov 2009 11:01:32 +0100

Changed in xvidcap (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.