Ubuntu

xvidcap fails to record multi- or single- frame

Reported by John Carlyle-Clarke on 2008-10-29
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xvidcap (Ubuntu)
Medium
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Running xvidcap on the latest Ubuntu 8.10 with all updates, I find that as soon as I try to record anything the program quits with an error.

xtoffmpeg.c add_video_stream(): video codec not found

This occurs even if single-frame mode is chosen.

Versions installed:-

xvidcap: 1.1.6-0.1ubuntu3
libavcodec: 3:0.svn20080206-12ubuntu3
ffmpeg: 3:0.svn20080206-12ubuntu3

try 'apt-get install libavcodec-unstripped-51'

does this help?

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

John Carlyle-Clarke (jpcc) wrote :

Installing libavcodec-unstripped-51 does indeed fix it. Thanks!

chadeldridge (chadeldridge) wrote :

I also had this problem .. and thank you for the quick response, that fixes it for me as well. Would it be possible to make that a dependency upon install ?

chadeldridge <email address hidden> writes:

> Would it be possible to make that a dependency upon install ?

since avidemux is in multiverse it can (and given this BR it even
should) depend on libavcodec-unstripped-51.

I prospective patch should probably add a debian/shlib.local file
instead of messing around in debian/control

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in xvidcap:
importance: Undecided → Medium
status: New → Triaged
lrbabe (public-lrbabe) wrote :

Same problem here.
I launch it without any specific options and it exit as soon as I try to record a video.

kang (dump-tzib) wrote :

another confirm suppose its enough ^^
please fix the dependency

wearetherock (wearetherock) wrote :

use gtk-recordMyDesktop instead , it work well

Akkana Peck (akkzilla) wrote :

In 8.10, this does get rid of the error message and the immediate exit, but xvidcap still can't record (after clicking the record button, all buttons grey out forever and nothing is written to test-0000.mpeg). Looks like maybe it has another dependency that I don't have installed.

If I attach to the process in gdb after trying to click the grey Stop button a few times, this is where it is (probably not very useful):

#0 0xb70d6096 in __pthread_mutex_unlock_usercnt ()
   from /lib/tls/i686/cmov/libpthread.so.0
#1 0xb7809f5f in g_type_instance_get_private ()
   from /usr/lib/libgobject-2.0.so.0
#2 0xb7aa756a in gdk_gc_set_values () from /usr/lib/libgdk-x11-2.0.so.0
#3 0xb7aa79c3 in gdk_gc_set_clip_origin () from /usr/lib/libgdk-x11-2.0.so.0
#4 0xb7abcabd in gdk_window_end_paint () from /usr/lib/libgdk-x11-2.0.so.0
#5 0xb7d79148 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#6 0xb7abb9b5 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#7 0xb7abbfcf in gdk_window_process_all_updates ()
   from /usr/lib/libgdk-x11-2.0.so.0
#8 0xb7cf5ecf in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#9 0xb7a9f46b in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#10 0xb774f7c1 in ?? () from /usr/lib/libglib-2.0.so.0
#11 0xb77516f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0xb7754da3 in ?? () from /usr/lib/libglib-2.0.so.0
#13 0xb77552c2 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0xb7d793a9 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x0805bc4b in xvc_ui_run ()
#16 0x080688b0 in main ()

Gerv (gerv) wrote :

This is still broken on 9.04 - when you try and record a video, you get:

xtoffmpeg.c add_video_stream(): video codec not found

I'm not the only person seeing this; see this forum thread: http://ubuntuforums.org/showthread.php?t=1047614

Gerv

ull (uros-film-noir) wrote :

Confirming for Ubuntu 9.04 Jaunty:

Clicking on "Record" button in xvidcap:
xtoffmpeg.c add_video_stream(): video codec not found

shaman.sir (shaman-sir) wrote :

Yes, the same issue @ 9.04

64bit Jaunty.

I have same problem and additionally xvidcap --aucodec-help said binary has no audio support.
I compiled from source and now it works - with sounds.

svn co https://xvidcap.svn.sourceforge.net/svnroot/xvidcap xvidcap
#e.g. revision 318 works
cd xvidcap/trunk/
./autogen.sh
#install missing dev-libraries and autogen.sh again
fakeroot debian/rules binary
sudo dpkg -i ../xvidcap_1.1.7_amd64.deb

Reinhard Tartler (siretart) wrote :

aapo: that's because the xvidcap svn defaults to use a private copy of ffmpeg, which is not acceptable for ubuntu.

we could make xvidcap depend on ubuntu-restricted-extras or something, but that would drag in a rather large amount of unneeded dependencies.

a shlibs.local file would probably do as well.

dipaish (kiran-pokharel) wrote :

I am trying to record the screen with xvidcap in ubuntu 9.04 version...video is recorded in very good quality but there is no audio....after I stop recording there comes a box saying Audio Codec : None....and I tried to change the audio codec but there is no option for audio in preferences ...I am new with linux so I dont know much,,,,reading upper comments I tried this command in terminal but it didn work..
$ sudo apt-get install libavcodec-unstripped-51
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package libavcodec-unstripped-51

Please help me fix the audio.

Thanks in advance.

dipaish : Try sudo apt-get install libavcodec-unstripped-52

Is my understanding correct that xvidcap will fail to work if libavcode-unstripped is not installed? If so, this bug status should be set to "High" and the dependency should be added. xvidcap is already in multiverse, so adding the dependency to another multiverse package (libavcodec-unstripped) should not be an issue.

dipaish (dipaish) wrote :

hi i did that but still it doesnt work....

apt-get install libavcodec-unstripped-52
and
chmod a+rw /dev/dsp

Should make it OK.
Packager should add libavcodec-unstripped-52 as dependency...

Alessio Treglia (quadrispro) wrote :

I'm on it

Changed in xvidcap (Ubuntu):
assignee: nobody → Alessio Treglia (quadrispro)
status: Triaged → In Progress
status: In Progress → Fix Committed
assignee: Alessio Treglia (quadrispro) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xvidcap - 1.1.7-0.2ubuntu3

---------------
xvidcap (1.1.7-0.2ubuntu3) karmic; urgency=low

  * debian/rules:
    - Run make command without the -j option.
    - A bit of cleanup.
  * debian/control:
    - Add dependency on libavcodec-unstripped-52 to fix LP: #290728.
    - Bump Standards:
      + Add ${misc:Depends} macro to Depends field.
      + Add debian/README.source file.

 -- Alessio Treglia <email address hidden> Mon, 31 Aug 2009 16:30:47 +0200

Changed in xvidcap (Ubuntu):
status: Fix Committed → Fix Released
Reinhard Tartler (siretart) wrote :

Launchpad Bug Tracker <email address hidden> writes:

> This bug was fixed in the package xvidcap - 1.1.7-0.2ubuntu3
>
> ---------------
> xvidcap (1.1.7-0.2ubuntu3) karmic; urgency=low
>
> * debian/rules:
> - Run make command without the -j option.
> - A bit of cleanup.
> * debian/control:
> - Add dependency on libavcodec-unstripped-52 to fix LP: #290728.

please change that to libavcodec-extra-52, as announced on ubuntu-devel
mailing list

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Alessio Treglia (quadrispro) wrote :

xvidcap (1.1.7-0.2ubuntu4) karmic; urgency=low

  * debian/contol: s/libavcodec-unstripped-52/libavcodec-extra-52.

Randy Earl (randy-earl) wrote :

I can confirm the problem as well (although it's well established by now). However, I could not confirm the fix mentioned above. Instead I solved it following the advice to download the binary from the sourceforge page, as recorded on bug 375711:
https://bugs.launchpad.net/ubuntu/+source/xvidcap/+bug/375711

Alessio Treglia (quadrispro) wrote :

Accepted xvidcap into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xvidcap (Ubuntu Jaunty):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xvidcap - 1.1.7-0.2ubuntu1.1

---------------
xvidcap (1.1.7-0.2ubuntu1.1) jaunty-proposed; urgency=low

  * Depend on libavcodec-unstripped-52 (LP: #290728).
  * debian/patches/01_configure.patch:
    - debian/patches/01_configure.diff:
      + Force check to enable the audio support (LP: #375711).
 -- Alessio Treglia <email address hidden> Sun, 29 Nov 2009 10:36:34 +0100

Changed in xvidcap (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments