Gecko embedders will break with the 2.0.1 update after Natty release

Bug #761715 reported by Chris Coulson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
chmsee (Ubuntu)
Undecided
Chris Coulson
Natty
Undecided
Chris Coulson
gnome-python-extras (Ubuntu)
Undecided
Chris Coulson
Natty
Undecided
Chris Coulson
instantbird (Ubuntu)
Undecided
Chris Coulson
Natty
Undecided
Chris Coulson
xiphos (Ubuntu)
Undecided
Chris Coulson
Natty
Undecided
Chris Coulson
xulrunner-2.0 (Ubuntu)
Undecided
Chris Coulson
Natty
Undecided
Chris Coulson

Bug Description

Binary package hint: chmsee

Previously, Mozilla have used a 4 part version number for previous gecko micro-releases (eg, 1.9.0.1, 1.9.2.16 etc), so where packages specify a Gecko run-time requirement, I have set this to a maximum version of 2.0.0.* (so that they work with all the micro-releases).

However, the version numbering has changed and the first point release is 2.0.1, which is going to break everything.

/me cries

Changed in chmsee (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
assignee: Chris Coulson (chrisccoulson) → nobody
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package chmsee - 1.3.0-2ubuntu1

---------------
chmsee (1.3.0-2ubuntu1) natty; urgency=low

  * Fix LP: #761715 - chmsee will stop working with the Firefox 4.0.1
    release
    - add debian/patches/series
    - add debian/patches/01_fix_gecko_version.patch
 -- Chris Coulson <email address hidden> Fri, 15 Apr 2011 13:52:05 +0100

Changed in chmsee (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in instantbird (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
status: New → Fix Committed
Changed in xiphos (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in xulrunner-2.0 (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in gnome-python-extras (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in chmsee (Ubuntu Natty):
assignee: nobody → Chris Coulson (chrisccoulson)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package instantbird - 1:0.3~a1-0ubuntu5

---------------
instantbird (1:0.3~a1-0ubuntu5) natty; urgency=low

  * Fix LP: #761715 - instantbird will stop working with the Firefox
    4.0.1 release
    - update debian/patches/01xulrunner-ubuntu
 -- Chris Coulson <email address hidden> Fri, 15 Apr 2011 15:07:33 +0100

Changed in instantbird (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in xiphos (Ubuntu Natty):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xiphos - 3.1.4-2ubuntu1

---------------
xiphos (3.1.4-2ubuntu1) natty; urgency=low

  * Fix LP: #761715 - xiphos will stop working after the Firefox 4.0.1
    release. We just hard-code the min/max Gecko versions for now rather
    than trying to figure them out dynamically at build time. The existing
    method of doing that doesn't seem to handle all combinations of Gecko
    versions and also currently makes it FTBFS
    - update debian/patches/xul-2.0.patch
 -- Chris Coulson <email address hidden> Fri, 15 Apr 2011 16:39:17 +0100

Changed in xiphos (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in gnome-python-extras (Ubuntu Natty):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-python-extras - 2.25.3-7ubuntu2

---------------
gnome-python-extras (2.25.3-7ubuntu2) natty; urgency=low

  * Fix LP: #740815 - Drop python-gtkspell, as it's provided by a separate
    source package in main. It seems we forgot about this one
    - update debian/control
    - remove debian/python-gtkspell.examples
    - remove debian/python-gtkspell.install
  * Fix LP: #761715 - Applications using python-gtkmozembed will stop
    working after the Firefox 4.0.1 release
    - update debian/patches/01_xulrunner_ubuntu.patch
 -- Chris Coulson <email address hidden> Fri, 15 Apr 2011 18:06:51 +0100

Changed in gnome-python-extras (Ubuntu Natty):
status: Fix Committed → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in xulrunner-2.0 (Ubuntu Natty):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers